Cannot install Leap 15.1 RC due to missmatching boot medium


I just tried to install openSUSE onto a USB stick using a netinstall image on another stick. (the destination stick is not inserted at the time the problem happens).
The installation medium was created on unix using a checksum-verified image and dd.

When trying to start the installation process, after establishing a network connection, I get the message

To use the selected repository a matching boot image is needed. Download it now and restart?

. Proceeding to do so, I get prompted the message

Installation system does not match your boot medium. Sorry, this will not work.

. The “repository” (upon inspection) is set to

Googling the error, it seems that there is a mismatch of linuxrc initrd ID and initsys ID and on the “beta” system 15.1 RC, InstsysComplain is set to 2 (?) and therefore I get the message. After some experimenting (I tried to set InstsysComplain to 0), I think I got into the actual installer, but I didn’t think it was smart to proceed that way.

Why do I get the message in the first place? Could it be that the installer is missmatching due to the internal hard drive (which is running windows), eventhough that hard drive is not supposed to be used in the installation at all?

Thanks for any help.

Okay, I just tested this. And I can confirm the problem.

I did notice this morning, that there were some updates available for 15.1. But they have not updated the install image on the download page. My best guess is that this is the cause of the problem. The NET installer actually downloads the install from the online repos. And apparently it is noticing that what it can download does not match what it expects, probably because the only repos have been updated more recently than the NET installer.

My suggestions:

(1) wait for the next NET installer version;
(2) in the meantime, file a bug report so the that 15.1 team are made aware that what they did does not work.

Will do, thank you!

BTW the DVD installer too has some problems when a “newer” build reaches the repos: