cannot find Linux-kernel-headers

I’m new to opensuse (11.2 just installed from a download dvd).
Can someone please tell me in which repository I can find

when I run Yast i only get Linux-kernel-headers 2.6.31-3.4 which is incompatible with my running kernel

thanks for any help :slight_smile:
greetings from Saigon

They’re the right headers, install them - only the major version matters.

I have tried that sir, but vmware keeps on coming back with that it needs 2.6.31.-01 headers, i even recompiled my kernel and reboot the system…
Its a pity i still need vmware because of plc programming software what i cant get running under wine…

Recompiled your kernel? No no, that would definitely break things.

First, remove your recompiled kernel and install the SuSE defaults and kernel-source + linux-kernel-headers.

Then tell me what VMWare you are trying to install?

You may need the kernel-devel package that matches your kernel flavour

:slight_smile: I simply use need to use vmware player2.52, here in Vietnam we can’t afford expensive software as our average income is only 100usd / month :slight_smile:
PLC programming software mostly uses special assembly written drivers (at least what i use does) and that is not working with wine, crashes all the time. so vmware player is a simple solution what works well.

My previous distro was kubuntu 9.10 but it gave too many issues, so i thought ,lets try opensuse with kde too . I’m self a bit surprised about all the differences between the 2 distro’s, both kde 4 :slight_smile: but I’m happy to have Opensuse working.

By the way ,the recompiling of the kernel was no issue, no broken packages

I wondered a bit why gcc is not standard installed… but those kind of things are easy solved…

hmm maybe a bit off topic, but what is the first serial port(the good old rs232,non usb) in opensuse, i’m used to use serial0(zero) but now its not listed anymore and tty0 is listed ,but not works.

/dev/ttyS0 most likely.

Have you considered using VirtualBox? It’s included with SuSE and should install with minimum of hassle in case you cannot compile VMware even with our help.

indeed, my kernel is and i installed even the source package
but the kernel headers in the standard repository is so it seems I have to open a new trick box to get that version number updated but currently this trick box is empty for me rotfl! .Hopefully soon there will be something useful in it :wink:

Please post result of

rpm --query --all '*kernel*'

For example I get:


And I have no trouble compiling against the kernel

I well understand you, if virtualbox could use an existing vmx(virtual machine) from vmware but that is just the catch. On my system , I’ve my home directory on an other partition . and of course i when installing opensuse i have not let it format :slight_smile: so no data-losses. and my virtual machine is still there.
To have a new working virtual machine setup in virtualbox that is a few days work (installing win2k, drivers ,serial numbers, plc programming software and plc software self)… huge amount of work

I will try virtualbox as last solution :slight_smile: still digging work to do but i’m not afraid of that :slight_smile:

by the way, thanks for your suggestion, its appreciated

I have exactly the same, but somewhere in the vmware installation there seems to be a exact version check between line 4 ( kernel-default- and line 1 (linux-kernel-headers-2.6.31-3.4.noarch)

and is not the same as 2.6.31-3.4

gcc itself has no probelm with it, i could recompile the kernel with no trouble. but the installation program what will integrate vmware with the kernel doesn’t like it that way… sadly

I will drop this question also by the guys of vmware because i can’t imagine i’m the first one with this problem. if they have a solution I will put it in a new post for this forum because it will be useful

thanks anyway for your reply

You actually have:

linux-kernel-headers-2.6.31-3.4.noarch <--------
kernel-default-devel- <--------

At your request

In red. Why are these installed if you are using kernel-default?

What you are missing is the kernel-syms package. Install it and VMPlayer will be a happy bunny ;). You may or may not have to run vmplayer using the user root on the first run (got that hint from elsewhere). I did run it as user root and it worked fine and still does (using less privileged users since).