Cannot download AdobeAir

I am a newbie with 11.2 on acer 1362wlmi laptop using KDE.

So far I am making progress but need to install adobe air which is required by BBC iplayer.

If I try to access the site rich Internet applications | Adobe AIR from Firefox I get a very rapid “unable to connect” message.

I suspect that it is a firewall problem but I cannot find it and dont know how to configure it.

Looking at all the Adobe flak on the web I suspect there are things I need to know.

Access is OK for me
Unlikely a SUSE firewall problem
Have you tried get_iplayer?

thats the problem with being a newbi
sadly “get_iplayer” does not mean anything to me (yet). So I would not know where to find it or what to do with it when I get it.
The learning curve for people fleeing from Windoze is extremely steep and many Forum posts not aimed at the newbie might be useful but are often in a language not yet learned.

If I try to get BBCiplayer in Firefox by downloading a BBC programme which forces the install if the Iplayer Desktop then almost immediately it tries to load Flash (and I already have 10.1.r53 loaded) and within seconds “a download error occurred - Try again?” message pops up.

So I decided to try to get flash and air loaded the hard way - hence my plea for help
thanks for your interest

I wanted to update this thread with coms made with the OP via PM and email. I sent OP get_iplayer package and fix.

Comment from OP

So I have done nothing today.

However last night I used your CLI notes to successfully select and download a program. It would not play - I think Kaffeine is broken in 11.2 and I have not investigated yet. I also loaded VLC but I think it needs setting up as it plays the file but I get a screen full of numbers in the vague form of the picture - not useable in its present form.

I received today a dvd with 11.3 on it and I plan a clean build on another disk - don’t know yet whether this is a good idea - more forum pages to read to see if I should wait a bit longer. (Did not want to download it because my broadband is only 2 meg but there is a nice guy on ebay who will send you a dvd for £1.28 including postage - must be at cost).

I have just had a quick glace at your multi-media guide - it needs a good study - lots in there for a newbie like me to digest.

I am not sure whether I should use Gnome or KDE - I am using KDE at present but dont know enough to judge yet - your advice welcome before I build 11.3

So far I am really pleased although I am finding everything more difficult than it really is because there are so many things to take into account - like finding out how to get a file manager in su - got that sorted last night.

thanks for you continued interest - will update you when I get a player working as it should.
and again from OP

you have made me a happy (and sad) man all in one go.

I have read and followed your absolutely fabulous multi-media-guide.

I can now watch the programme Wild Wales - 2 which I downloaded with get_iplayer yesterday.

The quality is excellent.

Now why am I sad?
simply because I have a lot to do now to work out why, what I did following your guide, works.
There seems little point in just using something without some understanding of the processes involved - but that is my problem and not yours.

So I thank you very much. The more I find out about opensuse (and more importantly the opensuse community) the happier I am that I stumbled upon it.

I was not sure why you went private on the follow through - is it because we were dealing with something that is - how shall we put it - not quite opensuse business? I really need to thank you for you help and advice in the forum but I dont want to put my foot in it.
And comment from me caf4926

I went private because we were having issue getting you the get_iplayer fix if I recall. I’m not in the habit of going this route at all.

The multi-media guide is all about codecs really. openSUSE cannot ship restricted codecs, so whilst it ships with kaffeine, it will only play open source media. The files get_iplayer produces are not open (If you have it working correctly, they should be mp4).

Many of the packages in Packman are the same ‘in name’ to those shipped with openSUSE, kaffeine being an example, but when you switch system packages as outlined in the guide, to Packman, you get kaffeine without any restrictions.
k3b is another example, Packman supplies k3b-codecs as an extra, which you should install and make sure k3b itself is from Packman. You can check individual Packages like this:
ImageBam - Fast, Free Image Hosting and Photo Sharing

As to the choice of kde or gnome, it doesn’t matter. But it sounds like you have been using kde, so maybe that is best. I was strictly kde but now use both. Nothing stopping you using both. If you install kde - you can add gnome later.We can advise of the procedure if you ask.

11.3 is a little tricky to setup graphics if you use a card like nvidia, so you might want to read up:
openSUSE Graphic Card Practical Theory Guide for Users

It is a pity that I started this thread with the title about AdobeAir as it was really about trying to get BBCiplayer to work.

However with some truly great help from caf4926 I now use get_iplayer to retrieve my bbc programmes and vlc to view them.

Speed and quality are excellent and connection to the large screen television was made possible from my nvidia GEforce FXgo5200 by the advice given in other threads to load the nvidia drivers.

I still cannot get BBCiplayer to work because of the inability of the beeb to recognise that both Flash and Air are already the latest versions and because my hardware firewall wont let adobe traffic through. Still I have a better solution and one nearer the heart of a puzzled penguin who is much less puzzled now than I was when the thread was started.

My thanks to all those who have contributed to my feeling of wellbeing.:slight_smile:

It’s not long ago, a few months maybe. I had someone else complain about AdobeAir and I installed it just to try it out. I’m pretty certain it was in an early Milestone release of 11.3 - but it worked fine for me. Thought the iplayer application sucks and I wouldn’t use it, it did work.

How do you mean your hardware firewall won’t let adobe traffic thru? This seems rather odd to me.

Good to hear get_iplayer is OK for you Ralph.

As it turns out I am not alone in having problems with the adobe site. I have checked and re-checked my firewall settings both in the router and the one in Windows XP - I dont yet know enough about opensuse to check what firewalling is going on in 11.2.

The web is littered with people who have a similar problem.

I cannot access the or from my desktop machine running XP nor from my laptop running puppy linux or opensuse 11.2. This applies to all my browsers even if uninstalled and re-installed and with or without extensions and plugins and it also applies when I use someone elses wifi network.

I do have a pristine Windows XP ghost to try yet but from what I read on the web about people with similar problems it appears that a computer builds up a history on the site which for whatever reason subsequently prevents further access.

I do however have the consolation of knowing that I am not alone and if anyone knows of a way to get over the problem I would be grateful. In the meantime I am very happy with what I am learning about Opensuse.

openSUSE firewall is installed and should be ON by default.
Anything you have in windows pales in to insignificance compared to openSUSE’s.
But if you have a hardware firewall - Like maybe in a router. Then actually you don’t really need a software firewall. (Belt and Braces though I guess)
Set to default, a router firewall would not stop adobe. I have Netgear router firewall ON and SUSE firewall ON
and I see this:](

This puzzled penguin is even more puzzled.
To give some background:
I have a desktop running Windows XP Home SP3 with all the updates.
It has three browsers installed - IE6 , Opera 10.6 and Firefox 3.6.8.
I have a laptop running openSuSE 11.2 with Firefox 3.6…

The desktop is connected to a Safecom router with its firewall on and Windows firewall is also on.
The laptop can be connected either by cable or wireless (and it makes no difference which) and again software firewall is on. Wireless is via D-link wireless access point and cable is into the router.

The Router is the DHCP server.

Neither machine can get access to Adobe or

Firefox reports:The page isn’t redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

*   This problem can sometimes be caused by disabling or refusing to accept

Opera gives up with : Adobe - Error page

and IE just never returns with anything.

On the laptop in openSuSE 11.2 the firefox response is exactly as above.

From the Windows PC I can ping the adobe site OK

tracert to the site is normal

I have flushed the DNS and I have wiped all history, cookies etc from the browsers and un-installed and re-installed them all to no avail. I have on my desktop PC run four different anti virus sweeps and found nothing at all

Wishing to remove doubt from my ISP and router etc I ran the desktop machine in memory from a Puppy Linux 4.2.1 boot disk and tried the adobe site in the default seamonkey browser - STRAIGHT IN in milli seconds.

This now is the question what is it about either machine that is stopping me get to the adobe website ? Are there any diagnostic tools that I can use under openSuSE 11.2 that can monitor what is going on and perhaps point to a solution. I suspect that somewhere on my PCs there is a record lurking which gets transmitted with the request and which screws up the link.

When I search the web for incidents of the firefox error message there is a great deal of history in various Forums but non is ever resolved - the discussion just dies.
The actual websites that are in question in these other reported incidents (which seem to start in 2005) can be almost anything - adobe facebook msm gmail and many others.

thanks for your interest

have a desktop running Windows XP Home SP3

I have a laptop running openSuSE 11.2

Neither machine can get access to Adobe or

Do you have setting to ‘accept cookies’? - You should
You are actually manually typing the url, rather than using a bookmark?
Ctrl+F5 forces a refresh of the page, try it.