Cannot disable NumLock using IBM Space Saver

I have set the Space Saver as my keyboard layout in the KDE control center*, but Shift+NumLock/ScrollLock still does not work as it should to disable NumLock. I have tried both ibm_space_saver and ibm_spacesaver (isn’t this practically a duplicate entry?) and restarted after each, to no avail.

Also, a second, possibly related problem – why, at the login screen, does it take so long for my keyboard and mouse to start working? Maybe ten seconds after the login prompt seems to be ready – only then can I actually do anything.

  • I think this should be in Keyboard & Mouse instead of Regional & Language, but I can understand why it’s there.

We will need some more info to help you:

Which openSUSE version ?
KDE3 / KDE4 ?
32/64bit ?
Did you run sax2 ?
and, last but not least, videocard ? Please return brand and model.

openSUSE 11.2 64-bit, with KDE 4. I did run sax2, but as you might know (and as I discovered when I ran it), it no longer configures keyboards and mouses. Apparently it was taking too much development work for the number of people who actually used it or something.

Graphics card is NVIDIA GeForce 9500 GT. (Not sure how that’s relevant in this case, but you asked, so there you go.)