cannot delete file "is a directory"

Hey all, so I have two folders which I cannot delete. I had transferred them to my computer via “Airdroid”
I was able to delete the contents of the folders, but now I am irritated by these two seemingly irremovable folders.
I have tried rm in terminal, at which point it tells me “…cannot delete…is a directory” I tried in superuser as well.
I’m not an advanced Linux user, so I might be missing something simple, or maybe I can change something in the folders options?
Any help would be much appreciated!
“Could not enter folder /home/spencer/guide” is what appears in the directory area when I open the folder.

Spencer:/home/spencer # rm /home/spencer/guide
rm: cannot remove ‘/home/spencer/guide’: Is a directory -this happens in terminal.

They’ve been sitting on my computer for quite some time. lol

Running Opensuse 13.2 now, if that is of any relevance.

This should work:


rm -rf /home/spencer/guide

It should remove “guide” and all of its contents.

If “guide” is really empty, then


rmdir /home/spencer/guide

“rmdir”: remove a directory (but it must be empty)
“rm -rf” recursively remove a directory and anything inside, and don’t stop for errors. The “-r” part is the recursive part, and the “-f” (for “force”) says to ignore errors.

Best done with great care, and preferably not as the root user (but as the owner if the file/directory). If done carelessly as root, you can delete everything in one mistaken command.

Thread moved

You may need to run as root, or use sudo if you are set up that way.

sudo rm -rf /home/spencer/guide

Just always be very sure you want to delete what you want, when running “sudo rm -rf …” because when it’s gone… it’s gone and that includes any system files if you accidentally forgot where you were and didn’t put the entire address in the command :wink: