Cannot decrypt password GPG from password-store

After a few restarts, and a couple attempts of running KDE Wayland and KDE Wayland Full, I find myself in a bit of trouble with my stored passwords.

I have stored quite a few passwords using the command line tool pass from the package password-store.
Now when I try to get a password it complains it cannot find the secret key.
gpg: decryption failed: No secret key

Opening KGpg my key is there. Usually what happens when I read a password with pass, KDE comes up and asks for my password in order to decrypt the pass gpg file, but no such dialog came up.

The files under ~/.gnupg are still there.

I tried to decrypt it manually with gpg
djviking@computer:~> gpg --output test --decrypt .password-store/SiteA.gpg
gpg: encrypted with 4096-bit RSA key, ID XXXXXXXXXXXXXX, created 2020-12-01
“DJViking <>”
gpg: public key decryption failed: No pinentry
gpg: decryption failed: No secret key

I remember I did a package cleanup a few days ago. Some PAM packages was removed. Maybe that is the problem, it cannot ask for my password.

I cannot remember what packages I removed. What do I need for this to work again?

Thankfully I wrote down the packages I cleaned up.
However none of these I think is the reason the password dialog does not work any more

I think this was all, but not 100% sure if other packages also was deleted.

Deleting akregator-lang
Deleting cheese-lang
Deleting dvd+rw-tools
Deleting gcr-viewer
Deleting gdk-pixbuf-thumbnailer
Deleting gnome-desktop-lang
Deleting kaddressbook-lang
Deleting kmahjongg-lang
Deleting kmail-lang
Deleting kmines-lang
Deleting knotes-lang
Deleting kontact-lang
Deleting korganizer-lang
Deleting kpat-lang
Deleting kreversi-lang
Deleting ksudoku-lang
Deleting lightdm-gtk-greeter-lang
Deleting lightdm-lang
Deleting pim-data-exporter-lang
Deleting pim-sieve-editor-lang
Deleting polkit-gnome-lang
Deleting samba-gpupdate
Deleting xdg-desktop-portal-gtk-lang
Deleting yast2-samba-server
Deleting yast2-tftp-server
Deleting yelp-lang
Deleting akregator
Deleting cheese
Deleting kaddressbook
Deleting kmahjongg
Deleting kmines
Deleting knotes
Deleting korganizer
Deleting kpat
Deleting kreversi
Deleting ksudoku
Deleting lightdm
Deleting pim-data-exporter
Deleting pim-sieve-editor
Deleting polkit-gnome
Deleting samba-python3
Deleting xdg-desktop-portal-gtk
Deleting yelp
Deleting patterns-games-games
Deleting patterns-kde-kde_games
Deleting lightdm-gtk-greeter
Deleting kontact
Deleting kmail
Deleting samba
Deleting libgnome-desktop-3-18
Deleting lightdm-gtk-greeter-branding-openSUSE
Deleting libgnome-desktop-3_0-common

I killed the gpg-agent, and restarted it using the --pinentry-program argument

gpg-agent --pinentry-program=/usr/bin/pinentry-qt5 --daemon

Then it worked again. I wonder if this will be gone again when I restart.