Cannot close lid when shuting down .

So everytime when I want to shut down my laptop I can’t close the lid when it’s shuting down as it would make the laptop go to sleep state.

I’ve changed the system settings in power option “action when close lid: no action”

This works fine when I’m logged in but when it’s in shut down session the laptop would still go to sleep state.

So now I always have to wait till the laptop has been shut down then close the lid and leave.


I just find this :

Edit /etc/systemd/logind.conf

I changed “lidswitchignoreinhibited” to no, hopefully this will work.

How did you come to find this setting? By default it says:


and you are changing it to read:


Is that correct? For anyone who wishes to edit this file as root, have a look at my blog on the subject here:

SYSEdit - System File Editor - Version 1.50 - Blogs - openSUSE Forums

And for Systemd specific issues, have a look here:

SysdCmd - systemd Command Help/Config Editor - Blogs - openSUSE Forums

Thank You for using openSUSE,

Thank you for the reply. I will look into the articles when I got time.

Yes I did change that setting to no, and it didn’t work.

I am thinking you would remove the remark and try yes. A restart may be required.

Thank You,

Same thought here, after some reading around: removing the # and leaving the value to “yes” should have the desired effect.

Lidswitchignore I’d say yes.

Lidswitchignoreinhibited is the negative meaning of ignoring lidswitch, so I have to give another no to his no. No?

Did using no work? If not, try Yes.

Thank You,

I tried both no and yes to that option.

When trying “no”, first time it worked, after reboot the next time it didn’t.

I then tried “yes”, it doesn’t work.

I then tried “no” again this morning, it worked. But only in the evening I’ll have the time to see weather it’s gonna work after this reboot.

Most curious that it would work this way, going back and forth like that. You are fully upgraded I assume?

Thank You,

The original solution was here: I didn’t read carefully enough,

The setting that should be changed is


Not others. >:(