Cannot automount windows partition

Hello, thank you for your attention:)

Ok, I´m running opensuse 11.0 and windows xp on dual boot. I want to mount my windows partition from suse permanently. Manual boot works fine.

I did this:

HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE 10.x

My fstab looks fine to me:

But guess what! At boot it doesn´t mount.

Any ideas? Thanx!

Looks to me like you need the “force” option, or to reboot to windows and let it “clean” the partition with that groovy filesystem check it does from time to time with the slow horizontal bar, in the boot sequence. It could of course be somethiong else, but give that a try first.

As swerdna says…or run ‘ntfsfix’ to clean a unproperly unmounted NTFS drive (that has been flagged dirty).

If you have Windows on the same system, booting into that and back to Linux is a better option (safer).

I boot into windows all the time, but the problem remains.

As for the force option - manual mount works without that, so I guess auto mount should, too… :confused:

Booting to and from being a safer option… yeah, and a rather time consuming;)

Indeed if a normal manual mount command works, then the NTFS partition is ok (as in not ‘dirty’).

What is the exact command you use to mount your drive?
Maybe there is a small difference in it compared to the names or a path used in fstab?

This works:

mount -t ntfs-3g /dev/sda1 /home/sara/windows_drive

This doesn’t:

/dev/disk/by-id/scsi-SATA_FUJITSU_MHV2080_NT28T622D49F-part1 /home/sara/windows_drive ntfs-3g defaults 0 0

This doesn’t either:

/dev/sda1 /home/sara/windows_drive ntfs-3g defaults 0 0

The fstab default option will prevent rw mounting as a user. I find the yast partition tool is a convenient way to quickly edit most fstab mounting options. For reference, my windows xp fstab entry:

/dev/disk/by-id/scsi-SATA_TOSHIBA_MK8032G_X5CX6959T-part1 /windows/C ntfs-3g user,users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 0 0

In yast partitioner I have now the option “mountable by user” selected, I rebooted the system, but it doesn’t mount:(

Open a console and type


Are you a member of ‘users’?

The next possible issue that comes to mind is with PolicyKit. Navigate to /usr/share/PolicyKit/policy and do


The system policy for fixed internal storage should look like:

<action id=“”>
<description>Mount file systems from internal drives.</description>
<message>System policy prevents mounting internal media</message>

(The ‘auth_admin_keep_always’ string could be changed to ‘yes’ if desired, as with removable drive mounting policy).

If everything looks ok, we’ll need to call in the guru’s…