Cannot access installation media


This is my first full day with openSUSE. I’m planning to migrate from Win7 Host + Linux Mint Guest to Linux openSUSE Host + WinXP Guest (sans networking). Right now I’m on-line via a live DVD running KDE.

While attempting to install Mate Desktop via YaST Software Management, I got the following:

Title: YaST2<2>

Cannot access installation media (Medium 1).
Check whether the server is accessible.

Show details:
File ‘./Essentials/noarch/gstreamer-lang-1.4.4-3.1.noarch.rpm’ not found on medium ‘

I clicked the “Abort” button – I can’t believe I was given a “Skip” option.

What should I do?


Change that to “

The mirror at “” has recently become less reliable.

You can make the change in Yast Software Repositories.

I clicked the “Abort” button – I can’t believe I was given a “Skip” option.

It would have skipped the packman repo, so you would not have been able to install from that. If what you wanted was available on other repos, that might have worked. But I usually abort at that point, and try later. It’s probably a temporary failure.

you copied the url wrong
it’s not
post your repo list and we’ll tell you how to fix it, or go in yast select that repo, click edit and change the url to the real one

Huh? I see ‘View’ > ‘Repositories’ > ‘packman’, but I don’t know what you would have me do.

I simply copied what I was shown. I have no idea what I’m doing. I don’t know what ‘packman’ is (except, that is, for Inky & Blinky & Pinky & Clyde of course).

I don’t know how to “select that repo”.

PS: I managed to stumble into ‘Configuration’ > ‘Respositories’. It opened a list of repos. Sure enough ‘’ was wrong. The actual repository is ‘’. I couldn’t find a way to dump a list, and I couldn’t find a way to change the packman repo. Further, I wouldn’t feel confident doing that considering that I can’t grab my ass with both hands, even in a well-lighted room.

Are you sure? I tried to change it and YaST said it was “Unable to create repository”.

PS: I was just able to change it to ‘Index of /pub/linux/misc/packman/suse/openSUSE_13.2/’.

…did you suffer a brain-fart?..

the place you copied it from forgot to include a space
start up a terminal and tell us the output of

zypper lr -d

you can copy/paste it here but use the

 tags (the **#** button) so the urls' aren't auto encoded is a real URL
does not exist hence the not found error, remove packman at the end of that url or post your repo list

linux@linux:~> zypper lr -d
# | Alias               | Name                                             | Enabled | Refresh | Priority | Type   | URI                                                                   | Service
1 | Education           | Applications for education users (openSUSE_13.2) | Yes     | No      |   99     | rpm-md |    |        
2 | packman             | packman                                          | Yes     | No      |   97     | rpm-md |         |        
3 | repo-non-oss        | openSUSE-13.2-Non-Oss                            | Yes     | Yes     |   99     | yast2  |          |        
4 | repo-oss            | openSUSE-13.2-Oss                                | Yes     | Yes     |  100     | yast2  |              |        
5 | repo-update         | openSUSE-13.2-Update                             | Yes     | Yes     |   97     | rpm-md |                             |        
6 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss                     | Yes     | Yes     |   99     | rpm-md |                     |        
7 | server_ltsp         | LTSP (openSUSE_13.2)                             | Yes     | No      |   99     | rpm-md | |        

Now that I’ve successfully installed Mate, how do I switch from KDE to Mate?

so you fixed it, don’t forget to do a vendor change to packman to get multimedia working

zyper dup --from 2

if mate is installed just logout and select mate at the login screen and login, at the next reboot you’ll be in mate

Click on that line, and then use the EDIT button.

I’m using 42.1. The corresponding repo is:

That should indicate the typical naming scheme that you can adapt.

You can also point your browser to that url to check whether you have something that looks like a repo.