Can ssh only one way

I am trying to get ssh working on a local network. I have 3 boxes on it XP, pclinux and Opensuse 10.3. I have cygwin installed on the xp. I can ssh the xp and the pclinux from each other. I can ssh the opensuse from the xp and the pclinux. I can not ssh either the xp or the pclinux from the opensuse. I get ssh: connect to host port 22: No route to host when trying to connect to the pclinux. It does nothing when I ssh the xp box. I have tried with and without the firewall on. I am fairly new to Linux and really new to ssh. I appreciate any help.


No route to host means your network setting are incorrect.

Make sure your default gateway and subnet settings are correct.

Possibly your network settings are wrong. What are you using to assign addresses, a home router? What is the output of:

ip addr
route -n
cat /etc/resolv.conf

I they are all set to dhcp from a router. The pclinux is a laptop on wireless.

ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet scope host lo
2: eth0: <BROADCAST,MULTICAST,NOTRAILERS,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
link/ether 00:1d:92:b0:b9:31 brd ff:ff:ff:ff:ff:ff
inet brd scope global eth0

route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface U 0 0 0 eth0 U 0 0 0 eth0 U 0 0 0 lo UG 0 0 0 eth0
cat /etc/resolv.conf


Modified_by: dhcpcd

Backup: /etc/

Process: dhcpcd

Process_id: 2990

Script: /sbin/modify_resolvconf


Info: This is a temporary resolv.conf created by service dhcpcd.

The previous file has been saved and will be restored later.

If you don’t like your resolv.conf to be changed, you


variables are placed in /etc/sysconfig/network/config.

You can also configure service dhcpcd not to modify it.

If you don’t like dhcpcd to change your nameserver



in /etc/sysconfig/network/dhcp, or


/etc/sysconfig/network/config or (manually) use dhcpcd

with -R. If you only want to keep your searchlist, set

DHCLIENT_KEEP_SEARCHLIST=yes in /etc/sysconfig/network/dhcp or

(manually) use the -K option.


domain Palmer

Thanks for the replies

Well you don’t have a nameserver in /etc/resolv.conf. Either the router didn’t send that info, or more likely, you set it up in YaST > Network devices not to use the nameserver that is specified in the DHCP lease. Fix that.

So you won’t be able find a machine by name, but if you ssh to the IP address, it will probably respond.

I am using ip address to connect.

ssh username@ip address

I hit enter and it just sets there not giving me nothing now.

When I do the same thing from the other boxes to Opensuse it connects right up.

Not getting any response means that the server may be blocking incoming traffic on that port. Windows has a firewall, did you open port 22?

In contrast, if you get no such host, you have a name resolution problem or routing problem. And if you get a reject, the machine is there but not accepting connections. Playing deaf usually means the packets are being blocked.

Thanks for all of your advice. I think that I might have solved it. I got the pclinux to work which is on wireless. The xp box is on a client bridge router so I think that the router may be stopping it.
I dont have time to try now but will later. Hope that is the problem.


Solved: port 22 was open on the xp machine but only allowing the pclinux thru.

Thanks for all the replies