Can someone explain DVD regions when it comes to bare drives?

I know what region codes are and how they relate to DVD players, but what about DVD drives? If I have an Asus 16D1HT. Where is the region enforced? In the actual drive or inthe software layers?

@AndersG in the firmware (5 times), I think there are some tools to reset, but it maybe a OTP setup as well. Some DVD’s have the region set to from memory…

I see: Does ASUS optical disc drive support changing region codes? | Official Support | ASUS

1 Like

Crap… Wonder of that isn the problem though… All my DVDs are region free or region 2

@AndersG is libdvdcss2 installed?

1 Like

This was actually on the Vero4 box running debian, but I pulled the DVD and connected it to a real PC to test. On OpenSuse I see no such package to install?

localhost:~ # regionset
Current drive parameters for /dev/dvd:
  RPC Type: Phase II (Hardware)
  RPC Status: no region code set (bitmask=0xFF)
  Vendor may reset the RPC 4 times
  User is allowed change the region setting 5 times
Would you like to change the region setting for this drive? [y/n]:

@AndersG not in the default repositories, see libdvdcss - VideoLAN

Grab the tarball;

configure --disable-static
make V=1
make install...

OK. Since this was a newly installed machine.
zypper in git
zypper in gcc
zypper in make
make folder
git clone https://code…

Stuck on the configure part…

Just add the VLC repo with Tumbleweed packages as described here:
It contains VLC, libdvdcss, libdvdss2 and many many more…

@AndersG There is a download link for the tarball, save having to run autoreconf etc…

I suggest not adding the repo, the file doesn’t change, been over a year now… and vlc conflicts with packman.

If you want to build an rpm: Here is the spec file: SUSE Paste

1 Like

Libraries have been installed in:

Testing with Kaffeine. Should I try VLC instead?

So this is what happens: I tried two DVD drives. One has region unset. The other hs 2, same as the Morse DVD. With a non-region DVD, such as Fawlty Towers, the DVD plays. With the region 2 one I get the initial menu, then the copyright message, then Kaffeine exits. Same with both drives.

Installed VLC. but it will not even open…

@AndersG did you (as root user) run the command ldconfig to update the cache.

I rebooted. Does that count? Interesting… Now it works… On this PC :slight_smile:

This is even wierder. I have this Old HP PC that I got in exchange for a bottle of wine. It was destined for another project that got scrapped. I set the built in DVD to region 2. The Asus is no region. Now, with openSuse 15.3 and the changes you suggested the Morse box DVDs play on both drives… :slight_smile:

1 Like

@AndersG yes, it should have updated… :wink:

Thanks a bundle. I will now take this info to the OSMC people and ask what can be done. I guess I am just that kund of guy, but many of the old, say 80’s series are not present on streaming services so we tend to buy them as DVDs.

@AndersG install handbrake, then can rip the dvd’s :wink:

1 Like

Yes, but that is an extra step and not wife-friendly.

I had to deal with a mis-regioned DVD drive in a MacBook Pro a number of years back. Apple was gracious about it, ultimately (and there were some other hardware issues too) and handled it all under warranty, so I can empathize.

This in particular, but also the realization that optical media was going to go away at some point, prompted me to extricate all my optical media-bound content. It is a very involved process and not at all spouse-friendly unless they’re a tech geek as well, but the end result (in my view) was totally worth it. I have a reasonably decent (though nowhere near as massive as other people) FLAC archive of all my music, complete with personally-curated metadata (album art and all other data), and I can also play all my TV shows and movies on any device I own, with minimal effort to access the data.