Can ping, but cannot access Web pages, dial-up,OpenSuSE 11.1

Hi. I am using OpenSuSE-11.1 Linux on a Hewlett-Packard, ZE1110, Pavilion notebook computer. My computer’s modem is a Conexant type for which I installed software appropriate for my Host-Signal-Family (HSF) modem and Linux kernel downloaded from Linuxant - Company information on the Internet. Although my computer software might not be quite up-to-date, I have installed numerous updates for software installed in my computer’s OpenSuSE-11.1 installation.

With my modem I can dial up my Internet Service Provider’s (ISP’s) access phone number and get connected to the Internet with either the KPPP or KInternet dialing programs. While connected to the Internet I can also perform the command “ping” with success in the terminal program in superuser mode. But the problem is that while connected to the Internet I can’t access Web pages in either the Konqueror-3.5.10, release-21.9 or Mozilla-Firefox-3.5.2 Web browsers.

My ISP dynamically assigns Internet Protocol (IP) addresses to my computer during Internet connections, but uses static primary and secondary Domain-Name-Server (DNS) addresses, which I could obtain by examining the file /var/log/messages. In the Fedora-Core-10, Linux operating system I was able to solve this sort of problem by adding lines of code of the form


, where the represent the IP addresses corresponding to the primary and secondary DNSs used by the ISP, in the file /etc/resolv.conf. Unfortunately this method did not also succeed in OpenSuSE-11.1 Linux for me. Without those two lines in /etc/resolv.conf, in YaST2 (Yet another Software Tool 2) I via “Network Services, Modem,” and then probably “Add” added a software modem, assigning the alias “/dev/modem” for my Linuxant’s softmodem “/dev/ttySFS0” as the “Device,” and inputting the name, access code, and access phone number for my dial-up ISP. I found that unless I clicked for an X to be placed in the box beside “Modify DNS when connected,” my computer could not detect my ISP’s carrier signal. In some Internet connections I did not arrange for an X to be placed beside “Automatically Retrieve DNS,” but instead input my ISP’s primary and secondary DNS addresses as IP addresses in two edit controls. (After the modem configuration process was completed, I could find those two DNS addresses at the bottom of the contents of the file /etc/sysconfig/network/providers/provider2, not in /etc/resolv.conf or /etc/sysconfig/network/config.) I arranged to have Xs placed in the boxes beside “External Firewall Interface” and “Automatically Reconnect,” but initially left the box beside “Ignore Prompts” blank. I tried changing the baud rate from 57,600 (bits/second) to 19,200 (bits/second) for my free, 14,400-bit/second, Linuxant softmodem, but found that in a later entry into YaST2’s “Network Devices, Modem” that the baud rate was again set to 57,600 (bits/second), but this time not by me. I tried turning off the firewall to see what effect that would have via “YaST2, Security and Users, Firewall.” That did not allow a Web page to be reached either. However, strangely on my next entry into “Firewall” the firewall was reported as running without my turning it on again. So I wonder if I really had a test to reach a Web page with the firewall turned off or not.

By attempting to reach a Web page I can be more specific and write that I could not reach a Web page by entering into a browser’s edit control a Uniform Resource Locator (URL), such as or En/registration - openSUSE, or by typing the IP numbers of the DNS address for, according to Kristijan from somewhere within on the Internet. I had no success reaching a Web page in OpenSuSE 11.1 in either the Konqueror-3.5.10 or Mozilla-Firefox-3.5.2 Web browsers in the K Desktop Environment (KDE) 3.5.10, release 21.9.

I should also mention that prior to my recent attempts to install the Linuxant softmodem and access Web pages, also in OpenSuSE-11.1 Linux at a friend’s home I could access the Internet using her fast Internet service, her external modem, a network card plugged into the side of my notebook computer, and an RJ-45 cable joining the network card and my friend’s external modem. My computer’s dial-up modem is listed in OpenSuSE 11.1 as modem0, whereas my network card is identified as eth0. So I would hope that these two devices are separated within the Linux software. However, I wonder if there could be any interference in the software between parameters set for i) the network card, my friend’s external modem’s IP address set as a gateway address, and the fast Internet connection with one ISP with ii) the paramters, such as the DNS addresses, for the dial-up ISP and no network card being used.

Also in this forum I saw that karimbardee posted about a problem very similar to mine, except that he or she used an external, Universal-Serial-Bus (USB) modem. Following deano_ferrari’s advice to karimbardee, here are my computer terminal program’s responses effectively as if the following three commands were typed in it during an Internet connection: /sbin/ifconfig, /sbin/route -v, and cat /etc/resolv.conf:

linux-i3bp:/sbin # ifconfig
lo Link encap:Local Loopback
inet addr: Mask:
RX packets:984 errors:0 dropped:0 overruns:0 frame:0
TX packets:984 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:79008 (77.1 Kb) TX bytes:79008 (77.1 Kb)

modem0 Link encap:Point-to-Point Protocol
inet addr: P-t-P: Mask:
RX packets:3 errors:0 dropped:0 overruns:0 frame:0
TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:42 (42.0 b) TX bytes:483 (483.0 b)

linux-i3bp:/sbin # route -v
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface * UH 0 0 0 modem0
loopback * U 0 0 0 lo
default * U 0 0 0 modem0
linux-i3bp:/sbin # cat /etc/resolv.conf

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:




or disable DNS configuration updates via netconfig by setting:


See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

linux-i3bp:/sbin #

And with my Mozilla-Firefox-3.5.2 browser set to be online, I still could not access a Web page during a dial-up Internet connection. Notice that in my case the P-t-P address does appear in my routing table.

Following the written advice in /etc/resolv.conf, I tried inputting the DNS addresses in line 235 of /etc/sysconf/network/conf, changing that line from NETCONFIG_DNS_STATIC_SEARCHLIST="" to NETCONFIG_DNS_STATIC_SEARCHLIST=“”, where the two ""s represent two static DNS addresses used by my ISP. But still I could not access a Web page. So I changed this line back to the way it was. Thanks in advance for someone providing me any kind of assistance here.


hi Pat, WELCOME…

up front i admit i didn’t read all of your post…because i’m lazy
and i guess i couldn’t actually read it all and help that way
anyway…BUT, i guess if you turn off IPv6 both system wide and in
firefox might help (for sure it will NOT hurt anything, including
your security)…so, try this:

Open Yast -> Network Devices ->Network Settings and in Global Options
tab Uncheck “Enable IPv6”

in firefox type


in the address bar, press enter then

search for

disable ipv6

Double click to set value to true if currently set to false.

check and see if anything is better…hmmmmm, you might need to
restart networking, don’t know…probably easiest to reboot…

if that is no help then it could be that your modem initilization
string needs some wickering…do you have the disk probably supplied
by the modem manufacturer? if so, sneak around in that disk looking
for the modem initialization string…hmmmm, i’ve not used one in so
long i forget…i think it will probably begin AT

ah ha, (found this for you) look at this:
use that and other hints on that site (or similar sites) to figure out
what the modem’s maker wants you to use…THEN find the place in
the setup of dialer you are using to insert THAT string, rather than
the default placed there by some now nameless Linux hacker…

good luck with both…

let us know if any of that helped…

Note: Accuracy, completeness, legality, or usefulness of this posting
may be illusive.

Hello friend!

SuSEFirewall2 is running? You can stop then and try to access
Internet again.


Thanks, Goldie or goldie, for kindly taking the time to post your ideas for me. Internet Protocol version 6 (IPv6) was already disabled within YaST2 (Yet another Software Tool 2) in my OpenSuSE-11.1 Linux installation. In my Mozilla-Firefox-3.5.2 browser after entering “about:config” the closest thing I found to disable ipv6 was network.dns.disableIPv6. Its Boolean value was set as false. I changed it to true, but still could not access Web pages in the Firefox browser. I couldn’t find any mention of IPv6 in my Konqueror-3.5.10 browser settings, but haven’t been able to get it to display a Web page either in my OpenSuSE-11.1 Linux installation while connected to the Internet.

Regarding trying to change the modem initialization string for my modem, first of all I think it should be a softmodem, which I think means a software modem, for a Conexant chip set, which is of course a piece of hardware. I was able to find the precise modem initialization string for my modem. But so far I haven’t been able to try it in my OpenSuSE-11.1 Linux installation. First the desktop in my K-Desktop-Environment-3 (KDE 3) in OpenSuSE 11.1 fills up only part of my computer screen. For almost everything I have been doing this has not been a problem. But in the dial-up program KPPP I couldn’t see the bottom of the Modem-Commands dialog box, the dialog box in which to input the modem initialization string.–Therefore it was somewhat risky for me to use a tab key to select a button I couldn’t see and then press my keyboard’s enter key.–Instead of, for example, choosing an OK button I can’t see, I might instead be choosing a button to clear all entries in the Modem-Commands dialog box and lose all of the modem commands! That would not be good. The solution for this problem is to find an appropriate, OpenSuSE-11.1-Linux driver for my computer’s monitor, which is associated with S3 Graphics TwisterK for my Hewlett-Packard notebook computer. After installing the correct monitor driver and/or video adapter, I could hope that the OpenSuSE-11.1, KDE-3 desktop would fill up my computer screen. Then I should be able to see everything on the Modem-Commands dialog box.

Hypothetically there was another way to enter the modem initialization string. That was via YaST2, Network Devices, Modem, selecting my modem0, clicking on Edit, and then clicking on a Details button. I could enter two lines of modem initialization strings there. However, later those entries were not seen in the Modem-Commands dialog box accessible by KPPP or on a reentry into the part of YaST2’s Network Devices in which I entered them. So I suppose that this was due either to an error in YaST2’s Network Devices, Modem, Edit area, or else that the entries I made within that area were overridden by some component within the software installed within my OpenSuSE-11.1 installation.

There was a similar event when I turned off the firewall via YaST2, Security and Users, Firewall. There I could click on a button to stop the firewall; but on a reentry into that same area via YaST2, the firewall was reported as running, but with it not having been turned on by me. So once again there is either a software error there or else the change I made was overridden by some other software component within my OpenSuSE-11.1 installation.

I suppose there might be yet another way to change the modem intialization string. That could be to type the modem commands directly into some sort of terminal program. Simply typing the modem command AT (I think standing for ATtention) in the terminal program in superuser mode didn’t work for that purpose. I haven’t figured out how that sort of thing could properly be done and/or what sort of program and exact commands to use in OpenSuSE-11.1 Linux.

If you think about the first two of my previous three paragraphs, you will see a pattern emerging that some things I entered via YaST2 did not become effective and did not appear on reentries into YaST2 in OpenSuSE 11.1. Furthermore KPPP, a program outside of YaST2, did not detect a change in the modem initialization string that I made within YaST2. So I suppose that some changes I made within YaST2 for some reason did not become effective. I wonder if a similar sort of thing could have occurred with the static primary and secondary Domain-Name-Server (DNS) addresses I entered for my Internet Service Provider (ISP) within YaST2. Those static, DNS address entries did get recorded in the file /etc/sysconfig/network/providers/provider2. Was that good enough? Or should those static DNS addresses have also been recorded by YaST2 and/or Netconfig in /etc/sysconfig/network/config and/or /etc/resolv.conf or in some other file? I would expect the designer of Netconfig to know the answer to this question. As I wrote earlier, I tried manually entering the primary and secondary, static, DNS addresses for my ISP separately in those latter two files I named, but in each case afterwards still failed to visit Web pages in the Firefox and/or Konqueror Web browsers. It could be helpful if someone would post what is supposed to happen to the static DNS addresses for an ISP entered in YaST2’s Network Devices, Modem, Edit section with the correct modem selected. This may involve how Netconfig and/or YaST2 is/are supposed to work; that is how and where they handle those data on reading and writing them. Then hopefully afterwards one could check to see if those things really happened or happen or not.

The lack of entries for the static DNS addresses for my ISP was the final reason I couldn’t visit Web pages in Fedora-Core-10 Linux; after entering them I could visit Web pages within that system. So until one can prove otherwise, the lack of static DNS addresses for my ISP in appropriate portions of OpenSuSE-11.1 software has been my prime “suspect” for my failure to visit Web pages in OpenSuSE 11.1. However, it is too early to “pin down” this “suspect,” since there could be other possible reasons for my failure to access Web pages so far in OpenSuSE 11.1. (Please don’t take my attempt to use “colorful” language like “pin down” and “suspect” too seriously here. Of course this is not a criminal investigation. And by “suspect” I mean a portion of computer or modem code, not a person. For example, getting rid of my own errors in a Fortran program I wrote has been a normal part of getting the program to work. I hope someone will rather appreciate a little colorful language here.) For example, I haven’t been successful in trying the precise modem initialization string for my modem in OpenSuSE 11.1, as suggested within this thread by Goldie or goldie.

Thanks, Goldie or goldie, for kindly taking the time to help me. I appreciate it! Thanks for anyone posting helping comments here. And although I haven’t used OpenSuSE 11.1 much to do useful things yet, it has already been useful to me in compiling and running a Fortran program. So thanks to everyone who put effort into making OpenSuSE 11.1 a working operating system for various computers in the complex plethora of computers available in today’s world!


considering the number of different and unrelated problems you are
facing i have to wonder if you installed 11.1 using a 100% correct
install image…

did you download and burn an image from,
or where?

did you check the .iso image with md5sum to ensure 100% correctness,
PRIOR to burning the disk?

did you, after burning the disk check it for absolute 100% purity…

more on that at

as ‘they’ say: Garbage in, Garbage out.


In some Internet connections I did not arrange for an X to be placed beside “Automatically Retrieve DNS,” but instead input my ISP’s primary and secondary DNS addresses as IP addresses in two edit controls. (After the modem configuration process was completed, I could find those two DNS addresses at the bottom of the contents of the file /etc/sysconfig/network/providers/provider2, not in /etc/resolv.conf or /etc/sysconfig/network/config.)

You certainly have been thorough with the info, but try to keep your posts concise, otherwise it can be a chore to sift through for the relevant facts. (I’m a bit like goldie with reading). :slight_smile:

Anyway, you’re quite correct in that the missing DNS entries in /etcresolv.conf are key to your problem.

I would try using the manual DNS entry approach (via yast modem configuration) again. These will not show up in /etc/resolv.conf until you dial out.

Can you please post output (via terminal as root) of

cat /etc/sysconfig/network/providers/provider0
cat /etc/sysconfig/network/config

In short, thankfully in OpenSuSE-11.1 Linux I finally am now able to access Web pages while connected to the Internet using either of the tone-“dialing” programs KPPP or KInternet. The two programs don’t appear to have much overlap in the sources of data they use.–That is data input via one of these two programs may not automatically be available to the other of the two programs. In retrospect this is not surprising for two different computer programs.–They could have been written independently of each other, in which case the data input into the two programs could be stored in different locations on the computer hard-disk drive. I just guess that the program KPPP may have been written before YaST2 (Yet another Software Tool 2) came into existence. Based on something I read within YaST2, Network Devices, Modem, YaST2 appears to have been set up to work with KInternet instead of KPPP.

The working of KPPP and YaST2 being apparently at least partially independent of each other is illustrated by the following, which was key to getting KPPP working with my Internet Service Provider (ISP). Via YaST2, Network Devices, Modem, selecting my listed modem modem0, clicking on Edit, and then proceeding through the subsequent modem and dial-up, Internet-connection setup, I could input the static Domain Name Server (DNS) addresses for my ISP. After starting KPPP and then clicking on Configure, on the Accounts tab my ISP was listed. Clicking on the line containing and then clicking on the Edit button, on the DNS tab I saw “Configuration: Automatic” with a radio button selected between “Configuration:” and “Automatic.” This meant that the DNS addresses were in effect set up within KPPP’s Configure to be automatically assigned! That indicated that the static or non-automatic arrangement, including the primary and secondary DNS addresses for my ISP that I had input via YaST2, Network Devices, Modem had not been communicated to KPPP! So after changing the DNS setup there, deep within KPPP’s “Configure,” to a “Manual” instead of “Automatic” one and inputting the primary and secondary DNS addresses explicitly there, thankfully I could access Web pages in my Web browsers in an Internet connection using KPPP for the tone “dialing.”

In this paragraph I take a “side journey” to express how I think things are supposed to work. Someone can correct me if my understanding is incorrect in any way. On the dialog box entitled “Connection Parameters” within YaST2, Network Devices, Modem, then editing my modem0, via the “Help” button I read this: “If the provider does not transmit its domain name server (DNS) after connecting, disable Automatically Retrieve DNS and manually enter the DNS.” My ISP is one of those providers. So the client who use such ISPs have to inform their ISPs what static DNS addresses are to be used for the purposes of i) translating domain names like into Internet-Protocol [IP] addresses or vice versa and ii) I guess probably also sending my request out on the Internet for access to the Web site I want to access. Is this latter guess of mine of what a DNS computer does correct? I suppose a Domain Name Server [DNS] address is the IP address of the ISP’s server computer which performs such translation and sends out my requests to Web sites. Naturally if my computer doesn’t “know” where to find such a translating server computer, that is its IP address, that translating server computer won’t be able to help me translate my request for access to the domain name into its DNS IP address and won’t be able to access that Web page for me.–That server computer won’t even “know” I am “looking” for it and want its help.

At this point I could access Web pages via the program KPPP, but not with the program KInternet. Within YaST2, Network Devices, Modem, then selecting my modem and clicking on the Edit button to proceed ahead, on the page with the words “Connection Parameters” at the top of it I tried lots of combinations of options, checking and unchecking “Modify DNS When Connected,” “Automatically Retrieve DNS,” “Ignore Prompts,” “External Firewall Interface”, and after “How the inteface should be set up” selecting “Manually” and “Automatically,” I did not find any combination of these options among those which I tried which would allow me to access Web pages using KInternet for the tone “dialing.” The poster deano_ferrari requested that I provide a listing of my file /etc/sysconfig/network/config. He or she also wrote that the lack of special information (perhaps DNS-related information) in the file /etc/resolv.conf was the reason I could not access Web pages (This would be via the KInternet “route” to accessing Web pages.). I read in the comments in the file /etc/resolv.conf that within the file /etc/sysconfig/network/config rather than in /etc/resolv.conf was the preferred place to manually input some things or to change some things. While connected to the Internet, a big difference in the operation of KPPP and KInternet was that at the top of /etc/resolv.conf I could see “ #kppp temp entry,” whereas there was no additional line beyond just comment lines there when KInternet was being used to tone-“dial” my Internet connection. Eventually by right-touchpad-button-clicking on the plug-looking KInternet panel icon, like a taskbar icon in Microsoft Corporation’s Windows, then selecting “Check Connection,” I saw in the ensuing window something like “Name Server failure. no name server found in /etc/resolv.conf.”

From somewhere, perhaps within /etc/sysconfig/network/config, I learned that Netconfig or netconfig was an important component of the network software (probably used by YaST2). In the program terminal in superuser mode I typed “info netconfig” and tried to understand what was written there for Netconfig. There I learned that the writing of the critical DNS-related information was performed by the Netconfig module called dns-resolver. Yet the information which dns-resolver wrote apparently originated from netconfig options set in /etc/sysconfig/network/config, not from within dns-resolver itself. The option NETCONFIG_DNS_FORWARDER was already set to equal “resolver,” which would force the lists of static domain names and static name servers or nameservers, which I presume to be the static IP addresses of the ISP’s DNS computers, to be written in the file /etc/resolv.conf. But the options which were written, namely NETCONFIG_DNS_STATIC_SEARCHLIST for the static domain names and NETCONFIG_DNS_STATIC_SERVERS for the static, DNS IP addresses were each set equal to “”, or null. So the module dns-resolver was apparently being instructed to write nothing in the file /etc/resolv.conf; in the software I suppose that might be translated to not attempting to write anything in /etc/resolv.conf. To get something to be written in /etc/resolv.conf when using KInternet, in /etc/sysconfig/network/config in place of “” on each of the right sides of the equations below I set


, where the pair of represent my ISP’s primary and secondary, DNS computers’ IP addresses. I decided not to explicitly state those static DNS IP addresses here in the public Internet in order to protect the ISP I am using from possible DNS attacks. After making those changes, using my Mozilla-Firefox-3.5.2 and Konqueror-3.5.10 Web browsers, thankfully I could access Web pages over the Internet when using KInternet to tone-“dial” my ISP and thereby make my connection to the Internet. The dial-up modem device is identified on my computer as modem0. It is using modem software from Linuxant - Company information on the Internet for my computer’s Conexant chip set.

The manual editing in the file /etc/sysconfig/network/config to make NETCONFIG_DNS_STATIC_SEARCHLIST=“” and
NETCONFIG_DNS_STATIC_SERVERS= the pair of IP addresses for the DNS computers appeared to have been necessary for me. But all of that information had already been input in the dialog boxes via YaST2, Network Devices,
Modem, "Edit"ing my modem modem0, etc. One of those dialog boxes was entitled “Connection Parameters,” had “How the interface should be set up”, and below that had drop-down list box containing the choices “Manually, Automatically,” and “Off.” Was the choice “Automatically” there designed to have the software write NETCONFIG_DNS_STATIC_SEARCHLIST=“” and NETCONFIG_DNS_STATIC_SERVERS= the pair of IP addresses, all data that I input within YaST2, Network Devices, Modem, etc., for’s DNS computers in the file /etc/sysconfig/network/config? That is is that what “Automatically” is supposed to mean? Clicking on the “Help” button on the dialog box entitled “Connection Parameters,” there was no such additional, detailed explanation given for what choosing “Automatically” would in detail accomplish. If that is what was supposed to happen, in my case, it evidently did not happen. Instead I had to edit the file /etc/sysconfig/network/config appropriately myself in order to access Web pages using KInternet. Below “How the interface should be set up,” I left the setting in the drop-down list box as “Manually.”

Now I present some background information leading up to a decision on how NETCONFIG_DNS_POLICY, which is currently set equal to “auto,” should be set in the file /etc/sysconfig/network/config. Prior to my attempts to dial up an Internet connection in OpenSuSE-11.1 Linux, I had been successfully updating OpenSuSE software in a kind friend’s home using i) the fast, AT&T (originally American Telephone and Telegraph) Yahoo!'s Digital-Subscriber-Line (DSL) Express Internet service, ii) an ethernet card plugged into the left side of my Hewlett-Packard notebook computer, iii) an RJ-45, ethernet cable connecting that ethernet card to iv) my friend’s external modem, into which an RJ-11 phone cable was connected from her RJ-11 phone receptacle in the wall of her mobile home, through which v) a line ultimately leading back to the telepone company she uses travels. A key to that success, for which I am also thankful, was something I am grateful to have learned from Best of Technical Support on the Internet. That was to within Network Manager or KNetworkManager via an icon near the bottom of my K-Desktop-Environment-3 (KDE-3) desktop (lighted part of my computer screen), set my friend’s external modem as a gateway. For that purpose via right-touchpad-button-clicking on that icon and then selecting “New Connection” or “Edit Connections,” selecting the DSL connection I used, and then clicking on “Edit Connection,” I think I arranged for an X to be placed in the check box beside “Use manual IP configuration.” Below that I likely input an IP address, which I suppose could be any set of four, one-to-three-digit numbers separated by periods in the form; beside “Netmask:” I input the subnet mask for the external modem; and beside “Gateway:” I likely input the IP address for my friend’s external modem. I have both of the labels dsl0 and eth0 associated with this setup on my computer. I think eth0 is associated with my ethernet card while dsl0 is the interface for the fast Internet connection I use in my friend’s mobile home. Anyhow, I found by experience that I could not visit Web pages without having the dsl0 interface.

Given the changes I made in /etc/sysconfig/network/config to make KInternet work for a dial-up Internet connection, I puzzled what would happen if I were to try to access a Web page in my friend’s home using the dsl0, eth0 combination and her DSL Express (non-dial-up) Internet service using KInternet. First I suppose I should right-mouse-button-click on the KNetworkManager icon and select dsl0 for the interface to use. That automatically selects the AT&T Yahoo! ISP I use for the fast Internet connections. I don’t recall having to input any static DNS addresses for my friend’s AT&T Yahoo! DSL Express Internet service. So I presume that with that ISP the DNS addresses are automatically or dynamically set. And when using KInternet, Network Manager will probably be enabled for use with my ethernet card, which can also be referred to as a network card. Therefore based on what I read via “info netconfig” the “auto” option would in that case mean STATIC_FALLBACK, which is operationally defined to use static settings for DNS only when no dynamic ones are available. In the case of my friend’s ISP’s AT&T Yahoo! DSL Express service, dynamic or automatic DNS addresses are probably available.–That would mean, according to STATIC_FALLBACK’s operational definition, that the static DNS addresses would not be used in that case, which is just what I would want. My conclusions are that: i) the default setting NETCONFIG_DNS_POLICY=“auto” will work fine for me using my friend’s fast Internet service; and ii) NETCONFIG_DNS_POLICY=“modem0” should also work because with this setting the static DNS settings will only be used when the modem0, dial-up interface is being used. Is my thinking correct in this paragraph? I continue my discussion in the posting which follows in this thread.


In response to other posts kindly posted by people wanting to help me, as well as to report progress on difficulties I previously reported in this thread:

1a. md5-sum check and Web source for my installation Digital Video Disk (DVD):
Performing an md5-sum check might not be possible for me to do in a way that I can see it. My nephew-in-law (niece’s husband) kindly used his DVD writer and fast Internet connection service to obtain the necessary file(s) for OpenSuSE-11.1-DVD-i586. What I saw on the DVD he burned for me was not just one file called OpenSuSE-11.1.DVD-i586-ISO, or something like that, but instead some folders, probably containing other files, and single files. Also it is not clear to me which Web site my nephew-in-law used for the download of this software.

But anyhow, for the purpose of checking whether I obtained a good download or not, I think I have a good “workaround” solution. Booting from that DVD there is a kindly included option to “Check installation media.” That took some minutes to do using the program Linuxrc v.3.3.22. And the quoted result of that check did not include a value for the md5 sum. Nevertheless I think “No errors found” was a good report on my installation DVD from that program. I’ll settle for that result and guess that it might have been obtained by performing a calculation of the hash, md5, or other type of sum for the DVD disk files and comparing those sums with included values for what those sums should be.

1b) But okay, even if the installation DVD was properly made, there could in principle still be a possible error in the CD- (Compact-Disc-) and DVD-ROM (Read-Only-Memory) drive reading that DVD. I did have some trouble reading CDs or DVDs with my DVD-ROM drive until I cleaned the lens in it a few months ago and then afterwards installed OpenSuSE 11.1. How can I verify that my installation of YaST2 is a perfectly good one or not with no misreads of data on a DVD by my DVD-ROM drive? If a package is listed as being installed in YaST2’s Software Management section, does that mean that the installation was performed exactly the way it was designed to be installed? I suppose it may.

1c) Another point is that in updating software via YaST2 using my friend’s fast Internet connection service and external modem cabled to my ethernet card in the side of my notebook computer, numerous times I have had software packages fail to be installed. I click Ignore after one or more of such failed attempts and continue installing other software packages. If necessary, I make another entry into the Online-Updates or Software-Management section of YaST2 until finally there are no more updates available from the Internet listed in YaST2 for the software on my computer. I assume this could be because a package attempted to be installed in the first attempt at updating is attempted to be installed before one of its dependencies has been installed. After those dependencies have been installed, I assume the installation which initially failed finally succeeds. If my guesses are correct here, I end up with an installation just as it was designed to be, agreed?

  1. My desktop was smaller than the size of my computer screen.
    Via YaST2 (Yet another Software Tool 2), Hardware, Graphics Card and Monitor, on the tab shown by default I could see Monitor–> LCD 800x600@60Hz, Card S3 Twister_K; then on the “Display Size” tab I saw 15" for the diagonal size of the screen. It was very good to see that S3 Twister_K was the correct identification for my computer’s monitor and/or video adapter. I changed the parameters to Monitor–>LCD 1024x768@60Hz and 14.1" to at least approximately match the diagonal dimension of my computer’s screen. I clicked one or more OK buttons and then on the button labeled Test. I clicked on “Save.” (It might be important to do that or or to select the other option there before the displayed time counted down for doing that reaches zero seconds.) Then on rebooting my computer into OpenSuSE-11.1 Linux my desktop thankfully filled up my computer screen. Monitor manufacturers might not provide in software the physical dimensions of their monitor screens. If that is true, as a future improvement I suggest that in OpenSuSE installations there be a note during OpenSuSE installations to inform the installer how to set the display options to match his monitor, according to what I just I explained I did. I recall that there was some kind of notice about the monitor or display during my installation of OpenSuSE-11.1. I suggest that notice be more specific regarding how match the diagonal dimension of the computer screen, the number of pixels to be used in the horizontal and vertical directions of the display.

  2. The solution 2 provided a means for me to input the correct modem-initialization strings for my computer’s software modem which uses the Conexant chip set. That was via K menu, Applications, Internet, Dial-Up, KPPP, Configure, Modems, with my software modem and/or chip set which I labeled as “Conexant AC97 V92 Data Fax” selected, then clicking on Edit, then on the Modem tab, and finally on Modem Commands. For the first modem-initialization string I input AT, which I think stands for ATtention. For the second modem-intitialization string I input a much longer modem-initialization string which began with AT. (For now I don’t include it here. There is a question whether this information would be considered proprietary or copyrighted or not.) I clicked OK. Clicking OK might seem to a reader to be a trivial matter. However, it is only trivial if your computer is working well and you can see OK on the dialog box. I couldn’t see OK there until I made the change in 2. So 2 was important to me in this respect. (Sorry, contrary to what I wrote earlier, as it turns out there is no button on that dialog box by which one could clear all entries in the dialog box and lose all of the modem commands.) On the next entry into that portion of KPPP I saw that my modem-initialization strings were still there. That was good. Furthermore the KPPP tone-“dialing” program includes a convenient option one can choose with an X in a check box on its main window by which one can see the modem commands and the responses from the modem to them in a Login Script Debug Window. So in that window I could see that the modem-initialization strings I input were gratefully actually being used. But alas, after connecting to the Internet, I still could not access a Web page in the Mozilla-Firefox-3.5.2 Web browser. So changing the modem-initialization string was unfortunately not critical change needed for me to be able to access Web pages in a dial-up Internet connection in OpenSuSE-11.1 Linux installation.

In YaST2, Network Devices, Modem, selecting my modem0, then by clicking first the Edit and later the Details buttons, I could see that the modem-initialization strings I entered using KPPP had not been read via YaST2, Network Devices, Modem. This again shows that KPPP and YaST2, Network Devices, Modem were apparently not designed to work with each other.

  1. After reading deano_ferrari’s posting that something in /etc/resolv.conf is supposed to be changed in it after dialing a phone number, I decided to look in it during an Internet connection and found the following line at the top of it that I hadn’t previously noticed:

domain #kppp temp entry

. The characters make up the domain name for my Internet Service Provider (ISP). In YaST2 I listed my ISP as Access the Net. The names and Access the Net are somehow connected to each other. For example, regarding payments for Internet service, Access the Net is listed. I decided to have just one designation within the software for my ISP, namely To do that I deleted one of the provider files in /etc/sysconfig/network/providers and within YaST2, Network Devices, Modem, selected my modem0, then clicking on the Edit button I eventually input as the name for my dial-up ISP. That probably generated the new provider file provider3 containing the designation for my dial-up ISP. I don’t know if having just one designation for my dial-up ISP was important or not within the software. But I could imagine that having just one designation within the software for my dial-up should be the sure way to avoid problems. I continue this discussion in the next posting in this thread.


> I continue my discussion in the posting which follows in this
> thread.
> Pat

i can hardly wait…

i think i know you from another worm hole, with a ‘z’ in it…


  1. The poster deano_ferrari requested outputs of the commands in a terminal program as a root user cat /etc/sysconfig/network/providers/provider0 and cat /etc/sysconfig/network/config. The file provider0 is for a Digital-Subscriber-Line (DSL) fast Internet service I use in a friend’s home in which no dialing of a phone number is involved. To successfully access Web pages separately using KPPP and KInternet, I made the changes described above. Within YaST2, Network Devices, Modem, the file provider3 is now listed as the “Name for Dialing” with my modem0. It is for the Internet service that I use KPPP or KInternet in dial-up Internet connections. So instead I below list the contents of provider3, except using for its Domain Name Servers (DNS), something for security reasons I can imagine my ISP might not want to be published on the open Internet; also for security reasons I changed the dial-up access phone number for my ISP to zzzzzzzzzz. And finally I changed my e-mail address to and password to something like yyyyyyyyyyy as added precautions on the open Internet.

Contents of /etc/sysconfig/network/providers/provider3 with the changes for security and precautionary reasons as I outlined them above:


Below are the contents of the long file /etc/sysconfig/network/config after I made the changes to NETCONFIG_DNS_STATIC_SERVERS=“” and NETCONFIG_DNS_STATIC_SEARCHLIST=“” described above in order to successfully access Web pages. Again to protect my ISP from possible DNS attacks I changed the actual, static, DNS IP addresses to a pair of in the listing below:

Path: Network/General

Description: Set some general network configuration

Type: string("","-","+")

Default: “+”

ServiceRestart: network

DEFAULT_BROADCAST is used when no individual BROADCAST is set. It can get one

of the following values:

“” : don’t set a broadcast address

“-” : use IPADDR with all host bits deleted

“+” : use IPADDR with all host bits set


Type: yesno

Default: yes

sometimes we want some script to be executed after an interface has been

brought up, or before an interface is taken down.

default dir is /etc/sysconfig/network/if-up.d for POST_UP and

/etc/sysconfig/network/if-down.d for PRE_DOWN

Note: if you use NetworkManager then down scripts will be called after the

interface is down and not before.


Type: yesno

Default: no

If ifup should check if an ip address is already in use, set this to yes.

Make sure that packet sockets (CONFIG_PACKET) are supported in the kernel,

since this feature uses arping, which depends on that.

Also be aware that this takes one second per interface; consider that when

setting up a lot of interfaces.


Type: yesno

Default: no

Switch on/off debug messages for all network configuration stuff. If set to no

most scripts can enable it locally with “-o debug”.


Type: yesno

Default: yes

All error and info messages from network and hardware configuration scripts go

to stderr. Most tools that call sysconfig scripts (udev, rcnetwork, scpm,

YaST) catch these messages and can log them. So some messages appear twice in

syslog. If you don’t like that, then set USE_SYSLOG=no.


Handling of network connections


These features are designed for the convenience of the experienced

user. If you encounter problems you don’t understand then switch

them off. That is the default.

Please do not complain if you get troubles. But if you want help to

make them smarter write to <>.

Type: yesno

Default: no

If you are interested in the connections and nfs mounts that use a

network interface, you can set CONNECTION_SHOW_WHEN_IFSTATUS=“yes”.

Then you will see them with ‘ifstatus <interface>’ (or 'ifstatus


This one should never harm :wink:


Type: yesno

Default: no

If an interface should be set down only if there are no active

connections, then use CONNECTION_CHECK_BEFORE_IFDOWN=“yes”


Type: yesno

Default: no

If these connetions (without the nfs mounts) should be closed when

shutting down an interface, set CONNECTION_CLOSE_BEFORE_IFDOWN=“yes”.

WARNING: Be aware that this may terminate applications which need

one of these connections!


Type: yesno

Default: no

If you are a mobile laptop user and like even nfs mounts to be

closed when you leave your current workplace, then set



WARNING: Be aware that this may terminate applications which use

these nfs mounts as working directory. Be very carefull if your home

is mounted via nfs!!!

WARNING: This may even lead to hanging ifdown processes if there are

processes that could not be terminated. If you are using

hotpluggable devices (pcmcia, usb, firewire), first shut them down

before unplugging!


Type: yesno

Default: no

If terminating processes that use a connection or nfs mount is not

enough, then they can be killed after an unsuccesfull termination.

If you want that set CONNECTION_SEND_KILL_SIGNAL=“yes”


Type: string

Default: “”

Here you may specify which interfaces have to be up and configured properly

after ‘rcnetwork start’. rcconfig will return ‘failed’ if any of these

interfaces is not up. You may use interface names as well but better use

hardware descriptions of the devices (eth-id-<macaddress> or eth-bus-… See

man ifup for ‘hardware description’). The network start script will wait for

these interfaces, but not longer as set in WAIT_FOR_INTERFACES.

You need not to add dialup or tunnel interfaces here, only physical devices.

The interface ‘lo’ is always considered to be mandatory and can be omitted.

If this variable is empty, rcnetwork tries to derive the list of mandatory

devices automatically from the list of existing configurations. Configurations

with names bus-pcmcia or bus-usb or with STARTMODE=hotplug are skipped. (try

‘/etc/init.d/rc5.d/S*network start -o debug fake | grep MANDAT’)


Type: integer

Default: 30

Some interfaces need some time to come up or come asynchronously via hotplug.

WAIT_FOR_INTERFACES is a global wait for all mandatory interfaces in

seconds. If empty no wait occurs.


Type: yesno

Default: yes

With this variable you can determine if the SuSEfirewall when enabled

should get started when network interfaces are started.


Type: string

Default: “eth*[0-9]|tr*[0-9]|wlan[0-9]|ath[0-9]”

Automatically add a linklocal route to the matching interfaces.

This string is used in a bash “case” statement, so it may contain

‘*’, ‘’, ‘]’ and ‘|’ meta-characters.


Type: string

Default: “-f -I”

Set default options for ifplugd. You may also set them in an ifcfg-* file

individually. Have a look at ‘man ifplug’ for details. We let ifplugd set the

interface UP when starting, because there are many interfaces where link beat

cannot be detected otherwise. If you want the interface to stay down then add

the option ‘-a’. If you like ifplugd to beep on cable (un)plug, remove ‘-b’.


Type: yesno

Default: no

Instead of the usual network setup (now called ‘NetControl’) you may also use

‘NetworkManager’ to control your interfaces.

NetControl is what you were used to in SUSE Linux up to now. It has a wide

range of configurations means for setting up any number of different virtual

and real interfaces. It should be used if you:

- want a static network setup

- have many interfaces

- need VLAN, bonding, bridging, multiple IP addresses

- must restrict network control to root

It may also switch interfaces automatically, but lacks a usable GUI for normal


NetworkManager lets the user control interfaces and switches automatically if

network interfaces lose/gain physical connection. It should be used if you:

- move between networks frequently

- want a GUI for network control

Especially on mobile computers that use mainly one wired and one wireless

interface NetworkManager will please you.

If you are used to SCPM then you might probably stay with NetControl. But at

least try NetworkManager, because it can replace SCPM in some usage scenarios.


Type: int

Default: 0

When using NetworkManager you may define a timeout to wait for NetworkManager

to connect. Other network services may require the system to have a valid

network setup in order to succeed.

This variable has no effect if NETWORKMANAGER=no


Type: string

Default: “dns-resolver dns-bind ntp-runtime nis”

This variable defines the start order of netconfig modules installed

in the /etc/netconfig.d/ directory.

To disable the execution of a module, don’t remove it from the list

but prepend it with a minus sign, “-ntp-runtime”.

NETCONFIG_MODULES_ORDER=“dns-resolver dns-bind dns-dnsmasq nis ntp-runtime”

Type: string

Default: “auto”

Defines the DNS merge policy as documented in netconfig(8) manual page.

Set to “” to disable DNS configuration.


Type: string

Default: “resolver”

Defines the name of the DNS forwarder that has to be configured.


Type: string

Default: “”

List of DNS domain names used for host-name lookup.


Type: string

Default: “”

List of DNS nameserver IP addresses to use for host-name lookup.


Type: string

Default: “auto”

Defines the NTP merge policy as documented in netconfig(8) manual page.

Set to “” to disable NTP configuration.


Type: string

Default: “”

List of NTP servers.


Type: string

Default: “auto”

Defines the NIS merge policy as documented in netconfig(8) manual page.

Set to “” to disable NIS configuration.


Type: string

Default: “yes”

Defines whether to set the default NIS domain. When enabled and no domain

is provided dynamically or in static settings, /etc/defaultdomain is used.

Valid values are:

- “no” or “” netconfig does not set the domainname

- “yes” netconfig sets the domainname according to the

NIS policy using settings provided by the first

iterface and service that provided it.

- “<interface name>” as yes, but only using settings from interface.


Type: string

Default: “”

Defines a default NIS domain.

Further domain can be specified by adding a “_<number>” suffix to


variables, e.g.: NETCONFIG_NIS_STATIC_DOMAIN_1=“second”.


Type: string

Default: “”

Defines a list of NIS servers for the default NIS domain or the

domain specified with same “_<number>” suffix.


In OpenSuSE-11.1 Linux using modem software for my computer’s modem kindly provided from within on the Internet, my dial-up Internet connections often only lasted from hardly any time at all to a few minutes before being disconnected from the Internet, often not by me. So the next challenge in dial-up Internet connections for me in OpenSuSE-11.1 Linux is to increase the connection time on the Internet before losing the dial-up Internet connection. So far I have followed one of the suggestions within on the Internet for my Linuxant software modem with a Conexant chip set; Host Signal Family (HSF) is also somehow associated with this combination of software and hardware. That is to keep the Internet connection active by having a command like “ping,” where stands for the DNS IP address for an Internet Web site, running in a terminal program in superuser mode.

Thanks to everyone who kindly took the time to read what I posted and/or to try to help me. I am grateful that I can now access Web pages in a dial-up Internet connection using either of the programs KPPP or KInternet for the tone “dialing” within OpenSuSE-11.1 Linux. Even so, in the above writing I still pose some questions.


Goldie, thanks so much for posting this… I’ve been fighting this problem all day and your info was exactly the answer I was looking for.