Can not print on hp deskjet 710c

Hello, I’m an happy user of 11.2 but I’ve a weird and very annoying problem with my old but still good for me hp 710c Printer.

I should say that I have this problem on with 11.2 because printer runs well either on windows or with other linux distro.

the problem is that when I try to print anything I get:
/usr/lib/cups/filter/foomatic-rip failed

I’ve found an other thread (11.2 - Cups ends /usr/lib/cups/filter/foomatic-rip failed - openSUSE Forums) regarding the same problem but with 11.2 milestone 1 and the solutions seemed to be to downgrade to an older cups and ghostscript version.

I tried me to but without success this solution and also I would prefer to find a better answer to my problem.

I really hope someone could help me, thanks for any kind of help and sorry for my worst english.


Did you try with hplip?

Install hplip and hplip-hpijs. Connect the printer, turn it on. Start Yast - System - Printer and let the autodetection do the job. You should be printing in no time.

Hello, thanks for your answer

I followed your suggestion but nothing has changed.
I delete my old printer configuration and re-do automatic check
on yast I can still see HP DeskJet 710C Foomatic/pnm2ppa

When I try to print I still get /usr/lib/cups/filter/foomatic-rip failed
I’ve found on this page Are drivers available for the Deskjet 710C, 712C, 720C, 722C, 820Cse, 820Cxi, 1000Cse, 1000Cxi; or Color LaserJet 1500, 2600 printers? | HPLIP Knowledge Base so seems that for my printer there are no drivers.

Any other suggestion ?

Can you run hp-setup and see?

If I run hp-setup no device is founded. I’m quite sure my printer is not supported by hp-slip. I figure I sould use Foomatic/pnm2ppa as I’ve always done with other distro but I do not know why with opensuse 11.2 is not working :frowning:

any other suggestion ?

thanks again for you kindly help

Sorry, hplip does not support this printer and the only driver seems to be OpenPrinting database - Driver: pnm2ppa

Which is the ghostscript-library version on your machine?

I’m using ghostscript-library version 8.64-6.2.1

thanks again for your help

Hello Marcello,

I found the following page describing supported printers for OpenSuse:

Unfortunately the 710C part is only in the german version. (search for 710c on the page)

In short, it states that the required packet “filters” is not part of the standard 11.2 release any more.
But it can be found in the openSUSE Build Service.


Please try this and give feedback if it works for you. I am also owning a 710C and currently thinking about switching to OpenSuse 11.2, so it would be nice to know if my printer will work with it…


We have a 710c and it works fine. Must say, it’s on openSUSE 11.2, but upgraded from 11.1 (I’ll check when I can get to the machine.

Installing the filter package grabbed from the above link defenitely works.

Cheers, David

After installing the

package I was able to use my HP DeskJet 820 Cxi printer

Thank you very much by your solution, It works!!!

But I can not understand the policy of the SUSE releases, one driver that works in one release in the next release doesn’t work, What stuff is it this?

Здарова, чуваки! Это первый раз, когда я сталкиваюсь с такой ничтожной проблемой на юникс-системах, но которая поставила меня в тупик. Очень хорошо, что я нашел этот тред, спасибо, ребятки, что написали о решении проблемы…
У меня hp deskjet 720c & openSUSE 11.3 x86_64 что ж, после установки фильтров из Index of /repositories/home:/buschmann23/openSUSE_11.3/x86_64 всё прекрасно стало печатать…
Спасибо вам большое пребольшое!!111


Hi dudes! This is the first time I encountered such an insignificant problem in the Unix-based systems, but which has put me stumped. Very well, I found this thread, thanks, guys that have written about solving problems …
I have a hp deskjet 720c & openSUSE 11.3 x86_64, then, after the installation of filters from Index of /repositories/home:/buschmann23/openSUSE_11.3/x86_64 everything was fine print …
Thank you very very big! 111

Yeah thanks a lot! I found this little problem with openSUSE 11.3 and 11.4 too and the given suggestions worked, even for 11.4!
But with the latter I had to modprobe the lp module too.
So (just to make a little résumé) to make HP Deskjet 710C work on 11.4 I had to:

  1. download the driver HP-DeskJet_710C-pnm2ppa.ppd from Printer Driver List | OpenPrinting - The Linux Foundation
  2. put it gzipped in /usr/share/cups/model/manufacturer-PPDs/hp/ (optional)
  3. download and install the “filters”: (still functioning in 11.4, at least for me)
  4. then
sudo /sbin/modprobe lp

(to put in /etc/init.d/boot.local, for example, in order to run lp at boot)

  1. finally
kdesu /sbin/yast2 printer

to config the printer.

  1. print test page (reboot if it doesn’t work at once).

Well, hope I haven’t forgotten anything important :wink:

Just a little update: same issue and same procedure on openSUSE 12.1. Filters package from obs project home:buschmann23 (, very useful for a lot of GDI printers! Installed openSUSE 11.3 version (latest version, as of writing), working nice.