Can not get USB DAC (Audioquest Dragonfly) working on openSUSE Tumbleweed


I’ve got Audioquest Dragonfly USB DAC (version 1.2, I think) that works perfectly on MacOS machine. But I can not get it working on Linux. There is no sound in headphones, when I play some music.

  • Dragonfly output selected in settings
  • DAC presents in aplay -L output: aplay.txt · GitHub
  • pavucontrol shows that there is signal, when I do speaker-test -c2 -l5 -twav

But there is no actual sound in headphones.
Information on my hardware and sound configuration:

I’ve tried to troubleshoot this issue according to this article “SDB:Audio troubleshooting”
But I can not finish section “Determine the order of sound devices”, because I don’t have such modules when I open Yast:

Can you please help me what to do, to hear sounds from my Dragonfly?

By the way, I’ve tried this DAC in Ubuntu 23.04: same situation, no sound. Aplay and pavucontrol show the same output.

Gnome or KDE?

did you click on the the loudspeaker symbol in the tray and tried to choose the correct output?

I do have multiple input and output devices connected.
Logitech H340 , two HDMI screens. And I can toggle in the tray

Yes, correct sound output is selected in settings:

I’ve also tried to select USB-DAC through asoundconf:

marker1k@localhost:~> asoundconf list
Names of available sound cards:
marker1k@localhost:~> asoundconf set-default-card DragonFly