Can not create bootable usb for suse in ubuntu

ISO file with 13.2 version is OK as it is possible to run installer in the virtual machine

Used: two USB stick to check if one is faulty

Two laptops: one with brand new disk, other with preinstalled Ubuntu

Preformated USB stick with various methods: GParted, disk format build in Ubuntu.

Tried to create bootable usb according descriptions below. None worked:

  • Unetbootin - that trial of creating USB did not even run boot after restarting both computers. I know this method in not recommended according to some threads but I gave it a go. Tried to use my own image as well as recomended file.

  • tried dd method - few articles on this in the net. Tried with/without umount first. - with this method I got so called “Minimal BASH-like line editing is supported- GNU GRUB version…” problem

  • methods on the opessuse website do not describe how to create usb through ubuntu specifically.

Any other ideas how to create usb stick with opensuse please?

There is no need to do any pre partitioning, because all will be overwritten when you store the ISO on it.

You should use

dd if=the-file.iso of=/dev/sdX

For the-file.iso, you should of course fill in the path to the ISO file you have, and for sdX the device file of the USB srick. Take care that you first are very sure what X should be (something like b, c, d, e,…). When you make an error there, you will overwrite some other disk! And mark that it is sdb (or the like) and NOT sdb1!

This should work on all Unix/Linux systems.

BTW, you should not say only “I can not create”, because that is your conclusion. You should tell why you think you can not create.

Also please do not say “… according to descriptions …” because we do not know those descriptions. Tell exactly what you do. Preferable by copy/paste from your terminal window (and paste that in the post between CODE tags, you get them by clicking on the # button in the tool bar of the post editor).

Thank You hcvv for include me into opensuse community!!! Done it!! Also for useful style advices. Now I am practicioner. :slight_smile:

I owe You.

Beauty of the internet.


‘dd’ command worked. What I was doing all the time in the ‘of’ part of ‘dd’ command was using path /dev/sdb1 instead /dev/sdb. You also saved me some time on not performing formating on usb stick before every trial.


I hope you now understand how important it is to tell exactly (best by copy/past) what you do instead of a vague " I followed some unspecified story I found in some dark hole on the internet". Only in that way we can see if you did it correct or not.

See you next time.

I guess you know why your “of=/dev/sdb1” was an error?
sdb = points to a whole disk
sdb1 = points to the first partition on the sdb disk

Although i might be possible to install an entire install image in a partition (not the whole disk), you’d have to have enough room to do so.

Although not generally necessary, some people will still re-format to wipe out old data, particularly on a rotating disk (perhaps not so much an issue on solid state). This is because if your writing tool creates a partition positioned <exactly> like the old, then “magically” all the old data will re-appear, visible to the system potentially causing file conflicts and/or loss of privacy if the old files were intended to be wiped.

So, if there is any question or you run into file conflicts, re-format (or wipe the disk using dd) before you write new data.


That is not the point. The point is that when the image starts on sdb1, it is NOT at the start of the disk. And thus it is not bootable.