can not connect to samba server [11.3]

I have a samba server on a 11.1 that can access a 11.3 shared folder supposed to be the client (with limitations on files with accentuated characters or with language related characters as ‘ç’ and spaces, it seems the utf8 is not respected but this is another issue).

The idea was that the 11.1 samba server will share the folders and the 11.3 suse notebook will act as the client to access the shared folders.

When I’m browsing using the 11.3 (shutdowned because I lost patience) there is optimistic behaviour with domain/workgroup visible and the two names of the hosts within the domain but when I click on the server entry there is nothing displayed.
There is no login asked…

smbtree displays all the informations that confort me saying all is done to work but I have no access from the client to the server.

The samba server’s version is 3.2.7-11.8.1-2426-SUSE-CODE11

And for sure the client’s side version of samba is higher…

How can I mount the folder in command line ? I did not found smbmount like command and I pray that mounting the shared folder will solve the issue…

Thank you in advance…

On Thu January 13 2011 07:36 pm, soundlord wrote:

>
> I have a samba server on a 11.1 that can access a 11.3 shared folder
> supposed to be the client (with limitations on files with accentuated
> characters or with language related characters as ‘ç’ and spaces, it
> seems the utf8 is not respected but this is another issue).
>
> The idea was that the 11.1 samba server will share the folders and the
> 11.3 suse notebook will act as the client to access the shared folders.
>
> When I’m browsing using the 11.3 (shutdowned because I lost patience)
> there is optimistic behaviour with domain/workgroup visible and the two
> names of the hosts within the domain but when I click on the server
> entry there is nothing displayed.
> There is no login asked…
>
> smbtree displays all the informations that confort me saying all is
> done to work but I have no access from the client to the server.
>
> The samba server’s version is 3.2.7-11.8.1-2426-SUSE-CODE11
>
> And for sure the client’s side version of samba is higher…
>
> How can I mount the folder in command line ? I did not found smbmount
> like command and I pray that mounting the shared folder will solve the
> issue…
>
> Thank you in advance…
>
>
soundlord;

For the CLI, use mount.cifs for shares that lie on a Windows or Samba server:

This HowTo should help:
http://opensuse.swerdna.org/susesambacifs.html

Can you explain how you tried to browse from 11.3?


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

It has gettin’ worse, I ‘shutdowned’ the “client” computer and now it asked for a domain that is always <local> but no way to log on !!!
I tried using console login, but it says pam_mount: getpwnam: Success but Incorrect Login after passing the password associated with the login…

I tried using the init=/bin/bash to disable pam authentication but I failed, I never found where to disable it (I think it is because I installed a windows domain membership and selected use smb information for linux authentication, but how to change this ? I don’t know because kdm is not available in the /bin/bash environnement)…

The console says also that HX_exited because the reference count was already zero…

I tried to browse using the dolphin and ‘network tab’ then the domain then the computer but there was nothing displayed at screen…

I don’t remember havin’ installed any pam authentication…

I really don’t have any idea of what I’ve done to have this behaviour but register the “client” to a windows domain and activated the also use smb authentication but nothin’ else…

Thank you for help if any…
I go back try to fix it…

more informations:

when I use the root login and the password associated the system answers Last connexion… and Unknown module and then after HX_exit… reference count is already zero !

I browse the internet concerning HX_exit but I didn’t find relevant way to fix it…

Using run level 3 (by modifying the inittab file) the issue is the same, this is not kde related, I have to find the module and then disable it…
Any idea of how restore the default behaviour at login (console as well as kde) ?

On Fri January 14 2011 06:06 pm, soundlord wrote:

>
> I browse the internet concerning HX_exit but I didn’t find relevant way
> to fix it…
>
> Using run level 3 (by modifying the inittab file) the issue is the
> same, this is not kde related, I have to find the module and then
> disable it…
> Any idea of how restore the default behaviour at login (console as well
> as kde) ?
>
soundlord;

It may me possible for you to recover now, but IMHO your best bet is to
reinstall. Preserve /home. It looks to me like you have broken one of the
PAM modules.


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

On Fri January 14 2011 06:22 pm, PV wrote:

> On Fri January 14 2011 06:06 pm, soundlord wrote:
>
>>
>> I browse the internet concerning HX_exit but I didn’t find relevant way
>> to fix it…
>>
>> Using run level 3 (by modifying the inittab file) the issue is the
>> same, this is not kde related, I have to find the module and then
>> disable it…
>> Any idea of how restore the default behaviour at login (console as well
>> as kde) ?
>>
> soundlord;
>
> It may me possible for you to recover now, but IMHO your best bet is to
> reinstall. Preserve /home. It looks to me like you have broken one of
the
> PAM modules.
>
soundlord;
On second thought; can you post the contents of /etc/samba/smb.conf from the
11.1 server. You may conceal any sensitive data such as public IPs or
Domain names with substitute values. A reinstall on 11.1 may still be in
order, but I suppose we should see the above first.

P. V.
“We’re all in this together, I’m pulling for you.” Red Green

[global]
workgroup =
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
logon path = \%L\profiles.msprofile
logon home = \%L%U.9xprofile
logon drive = P:
usershare allow guests = No
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain logons = Yes
domain master = Yes
local master = Yes
netbios name = antares
os level = 65
passdb backend = smbpasswd:/private/smbpasswdfile
preferred master = Yes
security =
wins support = Yes
idmap gid = 10000-20000
idmap uid = 10000-20000

This is the smb.conf globals from SuSE 11.1 (server).
Note that I solved the Domain combobox appearing in the kde login screen by modifying the file in sysconfig (displaymanager)

Type: yesno

Default: no

Display a combobox for Active Directory domains.

DISPLAYMANAGER_AD_INTEGRATION=“no”

Now the issue is really related to run levels 2 and 3. (not in /bin/bash mode)
What the f*** is PAM ? How can I get rid of it ?

I did nothing but trying to read the informations from samba client in 11.3 to a samba server in 11.1…

I can’t believe this is the windows domain membership because I used it on the 11.1 but nothing happened as wrong as in the client side…

pam is not kernel level, this is a module that could be added to the system, pam is “pluggable authentication module” but I want it unplugged right now ^^

On Fri January 14 2011 06:29 pm, PV wrote:

> A reinstall on 11.1 may still be in
> order, but I suppose we should see the above first.
That is 11.3, the client.

P. V.
“We’re all in this together, I’m pulling for you.” Red Green

On Fri January 14 2011 07:06 pm, soundlord wrote:

>
>> [global]
>> workgroup =
>> printing = cups
>> printcap name = cups
>> printcap cache time = 750
>> cups options = raw
>> map to guest = Bad User
>> logon path = \%L\profiles.msprofile
>> logon home = \%L%U.9xprofile
>> logon drive = P:
>> usershare allow guests = No
>> add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody
>> -s /bin/false %m$
>> domain logons = Yes
>> domain master = Yes
>> local master = Yes
>> netbios name = antares
>> os level = 65
>> passdb backend = smbpasswd:/private/smbpasswdfile
>> preferred master = Yes
>> security =
>> wins support = Yes
>> idmap gid = 10000-20000
>> idmap uid = 10000-20000
>
> This is the smb.conf globals from SuSE 11.1 (server).
> Note that I solved the Domain combobox appearing in the kde login
> screen by modifying the file in sysconfig (displaymanager)
>
>> ## Type: yesno
>> ## Default: no
>> #
>> # Display a combobox for Active Directory domains.
>> #
>> DISPLAYMANAGER_AD_INTEGRATION=“no”
>
> Now the issue is really related to run levels 2 and 3. (not in
> /bin/bash mode)
> What the f*** is PAM ? How can I get rid of it ?
>
> I did nothing but trying to read the informations from samba client in
> 11.3 to a samba server in 11.1…
>
> I can’t believe this is the windows domain membership because I used it
> on the 11.1 but nothing happened as wrong as in the client side…
>
> pam is not kernel level, this is a module that could be added to the
> system, pam is “pluggable authentication module” but I want it unplugged
> right now ^^
>
soundlord;

PAM handles basic nix authentication. AFAIK you can not get rid of it easily,
someone else may contradict this.

What you have now is really not a network problem but a broken PAM. You might
want to post to the “install boot” forum where someone more knowledgeable
than I might be able to give you instructions to recover the install. If you
can now login to the 11.3 client, you should be able to undo your earlier
settings. If you can not log in…

Unless you simply omitted the workgroup value in your smb.conf for
confidentiality, you have no domain name.


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

It’s just a configuration issue… I have modified all the files in the /etc/pam.d/ folder related to winbind and then I get on my desktop again !!

For your information, when you face this type of issue, it is related to those files

/etc/pam.d/login
/etc/pam.d/xdm
/etc/pam.d/su
/etc/pam.d/common-session-pc
/etc/pam.d/common-auth-pc
/etc/pam.d/common-account-pc
/etc/pam.d/common-password-pc

and in those files you should have

pam_unix2.so instead of winbind.so

Those changes make the things go better ^^

Thanks for your help anyway !! And by the way, I’m the type of guy that never reinstall/restore nothing, I give up with microsoftians way of troubleshoot things ^^