Can not change login theme

When I try to change the login theme using Personnel Settings Command I get an error window stating: ‘/usr/bin/kcmshell4 kdm --lang en_US’ not found.

I am using openSUSE 11.1 and KDE 4.1.3

Thanks for the help!!

Well, I discovered that you need to go into Yast and install kde4-kdm–branding-upstream and replace kde4-kdm-branding-openSUSE. You will still get this error but the changes will take effect. :slight_smile:

Well I did that and now it has changed to a different theme, just not the one that I selected. Also if I try to download/install a new theme from the theme tab, it says that it is installed but does not show up as one of the available themes.:frowning:

Probably u are doing some other mistakes. Themes installed by themes tab works fine here. After adding themes it gives you option DO U WANT TO ISE NEWLY INSTALLED THEME NOW. Say yes to it. But yes, sometimes newly installed theme is shown as modified theme. But it works.

Ok, I guess there is a step I am missing.

Conigure Desktop
-Advanced Tab
–Login Manager
—Theme Tab
----Get New Themes(Button at the bottom)
-----Click the Install Button to the right of the theme(Bottom of the screen shows download progress, then the install button turns to uninstall)
------Click the close button which brings me back to the Themes Tab.

But theme that was just downloaded is not there.

The main difference in procedure followed by you and me is :
I download theme archieves (kdm themes) and from theme tab use Install New Theme. Thene browse to the downloaded theme and add it. Actually the links to the themes obtained by Get new themes is wrong sometimes. For example Young Fairies theme links to another php page not kdm archieve. You may find archieves in Eyecandy for your KDE-Desktop - or Skin Antics - A Skinning Community: Downloads / KDM & GDM Themes .

Probably your system looks for the theme in another directory.
Have a look at /opt/kde3/share/apps/kdm/themes. It is probably looking into that place but your new theme is installed in /usr/share/kde4/apps/kdm/themes.
Solution is to make a softlink to point your theme to the directory where kdm is using.

I have the same problem. The themes are downloaded to <username>/.kde4/share/apps/kdm/themes, but inorder to use them I have to copy them into /usr/share/kde4/apps/kdm/themes after download. Once I do that they show in the list and are usable.

Also what sahaittanmoy said is true. Sometimes the theme poster will link to download site, so what you download is just a link to that web page, not the actual theme.

Hi all,
I hope that this will help to solve this complication…
The trick is choice or kdm , or kdm3 , or kdm4.
I can say that change the theme in kde4 "personal setting > advanced >login manager>theme work just if we change in
yast>system>“etc/sysconfig editor” two line.
Search “kdm” you will found:
1)DISPLAYMANAGER >>> here the default value is “kdm4”
Change it as you want.
So if you want use the old teme of kde3 you have to install in yast>software>softwaremanagement “kdebase3-kdm” and remove “kde4-kdm”. You have in additional install “kdm theme manager”. This pack can be founded in rpmsearch (install 64bit or 32bit latest version).
At the end in small words you have to say at your system what you want to use like login manager. kdm,kdm3,kdm4.

After this …

Here you can select/write the name of your theme. (name of the folder)
You can choice to install by hand or with “Theme manager” above.
/opt/kde3/share/apps/kdm/themes/ (for kde3)
/usr/share/kde4/apps/kdm/themes (for kde4)
there you have to copy your folder theme. (with no sub-folder)

Reboot and all should be ok.
Just I had to write in a terminal (as root) “nvidia-xconfig” to restore this module. Probably because when I have uninstalled “kde4-kdm” it change something.

For me all this work fine.

Thanks for the reply, unfortunately it will be a moment until I can try it. I am having some other issues currently but I will get back at you. Thanks!!

I changed the kdm theme doing this:

  1. I installed the theme (there’s no difference between installing by hand or downloading with the assistant).
  2. I went into YaST and I open the /etc/sysconfig Editor.
  3. go to Desktop > Display Manager > DISPLAYMANAGER_KDM
  4. and the droplist type the name of the theme (you can see it in /usr/share/kde4/apps/kdm/themes/ -it’s the name of the folder that contains the theme-).
  5. Press “OK” and reboot.

It works fine for me, and I didnot replace the kdm-branding-OPENSUSE…

Ummm, sahaittanmoy, your link is useless. It brings me to a sports blog. Is there a more up-to-date link?