Can no longer print after recent DUP - rastertogutenprint.5.2 missing

Running Tumbleweed. After running DUP today (and rebooting) I found that printing no longer works*. It seems rastertogutenprint.5.2 (from the gutenprint package) has been replaced with version 5.3, but the Cannon iP4800 driver requires version 5.2.

(* May have been broken for a couple of weeks – don’t print often – but it was working in the last month. I see gutenprint was updated on 22 April 2023).

Some info:

stephen@localhost:/usr/lib/cups/filter> lpstat -t
scheduler is running
system default destination: iP4800-series
device for iP4800-series: usb://Canon/iP4800%20series?serial=225F24
iP4800-series accepting requests since Sun 07 May 2023 14:55:09 BST
printer iP4800-series is idle.  enabled since Sun 07 May 2023 14:55:09 BST
File "/usr/lib/cups/filter/rastertogutenprint.5.2" not available: No such file or directory
iP4800-series-41        stephen          95232   Sun 07 May 2023 14:55:09 BST

I’ve tried looking for a new driver, but without any success; I’m not really sure what I’m looking for, or what to do with it if I find it.

Is there any other info I should provide?

Can anyone tell me how to fix this, please? Thanks.

Have you tried simply removing the printer and adding it again? That should be sufficient to get the ppd generated against the current installed gutenprint version.

If not try using ‘cups-genppdupdate’ to regenerate the gutenprint ppd file in question.

More info:

man cups-genppdupdate
1 Like

Following your advice, I opened the yast printer interface (which I had not considered before) to delete/add the printer. But before deleting it, I thought it best to take a look with ‘edit’ to see how it was set up. I then saw that it gave me the option to select a new driver for V5.3.4. I did that and now it works.

So, not only does my printer work again, but I have learned something new.

Thank you very much. :slightly_smiling_face:

Glad to read that the printer is working again. :slight_smile:

1 Like