Can I get rid of Plymouth?

It takes few extra seconds to start. Can I get rid of Plymouth?

~> systemd-analyze blame
31.095s plymouth-quit-wait.service
10.532s firewalld.service
9.940s initrd-switch-root.service
7.361s ModemManager.service
6.026s avahi-daemon.service
5.565s kbdsettings.service
5.523s mcelog.service
5.400s nscd.service
5.275s smartd.service

Or, at least stop Plymouth from starting?

You can put “plymouth.enable=0” on the kernel command line. Do this in Yast bootloader.

Do I delete


Thank you!

I deleted


and left



~> systemd-analyze blame
4.288s apparmor.service
3.343s postfix.service
3.180s firewalld.service
3.013s display-manager.service
2.488s initrd-switch-root.service
1.919s fwupd.service
1.755s ModemManager.service
1.424s systemd-logind.service
1.337s systemd-udevd.service
1.192s udisks2.service
1.093s upower.service
1.054s systemd-journal-flush.service
988ms smartd.service
751ms systemd-journald.service
745ms initrd-parse-etc.service
644ms polkit.service

Please mark this as solved. Thank you.

I don’t let it install in the first place, saves bandwidth during updates, which also must result in smaller initrds and thus quicker loading.

It is there, so will this be enough?

zypper rm libply* plymouth*

and, do I have to lock them too?

zypper al libply* plymouth*

Oh, you put those in quotes instead of CODE blocks, so they don’t requote.

I replaced “splash=silent” with “plymouth.enable=0” but it probably doesn’t matter.

I left the “quiet”. I should probably experiment with that some day.

That will work, run mkinitrd as well when you have done the above…

Thank you!
How do I tag this thread as solved?

Plymouth grabs some time:

:~ # systemd-analyze blame |grep ply
2.810s plymouth-quit-wait.service          
 276ms plymouth-switch-root.service        
  67ms plymouth-start.service              
  23ms plymouth-read-write.service         
:~ # 

But it does not show up in the critical chain:

:~ # systemd-analyze critical-chain 
The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character. @5.417s
└─display-manager.service @3.491s +1.925s
  └─systemd-logind.service @2.003s +1.484s
    └─ @1.977s
      └─ @1.977s
        └─pcscd.socket @1.977s
          └─ @1.974s
            └─apparmor.service @254ms +1.719s
:~ # 

Typical values are:

Startup finished in 4.102s (firmware) + 4.216s (loader) + 822ms (kernel) + 1.162s (initrd) + 5.477s (userspace) = 15.781s.

Snapshot 2191028 disabled systemd-networkd and enabled wicked resulting in:
Startup finished in 4.092s (firmware) + 4.037s (loader) + 810ms (kernel) + 1.294s (initrd) + 34.038s (userspace) = 44.274s. :’(

Then I disabled wicked and again enabled systemd-networkd. I am back to previous values:
Startup finished in 4.111s (firmware) + 4.060s (loader) + 812ms (kernel) + 1.351s (initrd) + 5.427s (userspace) = 15.763s.:slight_smile:

When I asked the question, I was running Gnome. I found it starting slow, so thought of getting rid of Plymouth, thinking it might be the culprit. Installed KDE today in a separate partition in Btrfs. Gnome is in Ext4. I noticed that the KDE Plasma desktop boots faster than the Gnome one. And, I like the plymouth screen there, so won’t disable it in that. :slight_smile:

I run the Gnome DE on Tubleweed, no plymouth, btrfs SSD (for boot) and NVMe for OS as the motherboard doesn’t support booting from the NVMe device…

Startup finished in 1.590s (kernel) + 1.450s (initrd) + 2.962s (userspace) = 6.003s reached after 2.625s in userspace

systemd-analyze critical-chain 
The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character. @2.625s
└─display-manager.service @1.877s +746ms
  └─ @1.854s
    └─chronyd.service @1.799s +52ms
      └─ @1.794s
        └─wicked.service @639ms +1.152s
          └─wickedd-nanny.service @620ms +17ms
            └─wickedd.service @567ms +51ms
              └─dbus.service @544ms
                └─ @541ms
                  └─ @541ms
                    └─pcscd.socket @541ms
                      └─ @538ms
                        └─systemd-udevd.service @254ms +283ms
                          └─systemd-tmpfiles-setup-dev.service @233ms +11ms
                            └─kmod-static-nodes.service @220ms +6ms

systemd-analyze blame |head -n10
1.152s wicked.service                                                           
1.107s conky_cpu_freq.service                                                   
 746ms display-manager.service                                                  
 489ms systemd-logind.service                                                   
 347ms initrd-switch-root.service                                               
 324ms upower.service                                                           
 317ms smartd.service                                                           
 286ms postfix.service                                                          
 283ms systemd-udevd.service                                                    
 184ms systemd-journald.service

I haven’t used ext4 for awhile, that may be an issue…?

Actually, I don’t know the difference between btrfs and ext4. I had been away from OpenSuse for a while, and using other distros with ext4. Maybe, I’d reinstall Gnome DE on a btrfs and see how it goes. :slight_smile: