Camera won't copy all pictures over

I am trying to copy pictures over from my Canon Powershot SD 1100 to openSuSE, but I am getting errors. About half of my pictures will copy over to my desktop, and the other half give me an error:

There was an error while copying the file into /home/nick/Desktop/pics
Error getting file: -2: Bad parameters

I don’t understand why half of them copy and half of them don’t? I have successfully copied all my pics over on my Ubuntu 8.04 machine, so I know my camera is working fine.

If it matters, i’m running GNOME.

Are you doing this directly from a browser?
are you using digikam or similar?

I have had copy paste errors myself in reading flash media from konqueror, but open the camera in digikam and it’s fine.

I tried using F-Spot to copy them over and it wouldn’t recognize any connected camera. So then I just tried using the browser.

So I’m not familiar with F-Spot, well I have never used it. Is there an option to add a camera and if so is yours not in the list? What about gPhoto app - should be installed already if you use gnome.

If the word canon is anything to go by, I suspect NOT. Canon printers I know are poorly supported.

But check here: HCL/Digital Cameras - openSUSE

I use a Olympus camera with f-spot, however I normally just open a
Nautilus window just to checkout the photos first as sometimes I
have found it gets upset if one of the photos is a damaged file. Then I
normally just drag and drop into f-spot.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 1 day 22:09, 3 users, load average: 0.22, 0.22, 0.19
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

sorry to hear you are having trouble downloading files from your Canon Powershot SD 1100; caf felt canon might be problematic, but using a different canon series, the ixus we had nearly three good years of downloading from an ixus, till the shutter played up;

like you, we used gnome; and f-spot; and the camera was recognised by f-spot; over several iterations, from Suse 9.3 thought 10.2 to 10.3;

we are now using a panasonic camera, (with 11.0) set up in the ptp mode; so the camera is NOT recognised by f-spot when connected; (in the sense that f-spot autoloaded when the camera was connected via USB and turned on … )

we have to open f-spot; and we select “import” in the f-spot menu and select ptp device, and that works beautifully;

… so … can we ask …

if you connect the camera; does f-spot auto-detect the canon;

(I assume if you enter lsusb in a CLI the system reads the camera?)