ca0106 4.1 surround problem

Hi there,
i’m writing here because i’m desesperate… three days i’m trying hundred’s solution proposed in forum and blog all around Internet … Surround doesn’t works !
My card is an SB Audigy SE.
The best i had was surround with flash player (youtube)
When i do the test speaker speaker-test -D duplicate -c 6 -t 2 all works fine.
But neither amarok nor kaffeine had surround, only 2 speakers works with these apps.
For example i saw
Ubuntu ca0106 Audigy SE sound card working with 5.1 -
surround sound on alsa CA0106? - Ubuntu Forums
SDB:AudioTroubleshooting - openSUSE
and many more … none of these solutions works.
I found some solution about xine / ca0106 … nothing !
Please, help me !!

What .asoundrc file are you using now?

Here is the /etc/asound.conf file (tried with it in ~/.asoundrc)

pcm.!dmix {
type plug
slave {
pcm surround51
channels 6
pcm.!default {
type plug
slave.pcm “dmix”
slave.channels 6
route_policy duplicate

Even if my surround is a 4.1 and not a 5.1 … It should works no ?
Thanks for reply.

I documented my surround sound experiences here:
Exploring surround sound in Linux - openSUSE Forums
note I did NOT have to create any special nor extra configuration file.

My view is if the .asoundrc file does not appear to work, it should be removed, else it will corrupt any subsequent testing.

I found this file very useful for testing:

I found both mplayer and vlc useful for testing, where if my memory serves me correct (I’m not at a linux pc currently) they have settings for surround sound that one has to select.

The page where I obtained hints for surround sound is here: Surround sound in Linux

Ensure you mixer is set correctly. If you wish others to check your mixer, then you need to share the settings. One way to do that is with your PC connected to the internet, to run this script:
and select SHARE/UPLOAD, and then when it completes, it will pass you a URL. Just post the URL here.

Thanks for help oldcpu.
Unfortunately,i’ve already read the links you gave me.
Here is the link provided by the script :

Thanks again ^^

No one could help ?

Patience. I have a day job too.

I note this works for my surround sound

speaker-test -c6 -Dplug:surround51 -t wav -l1 

You could install xchat, then go to IRC freenode #alsa and ask some of the sound guru’s there.

Hooray ! I finally found a solution to my problem !
I post it … maybe it could help.
People on #alsa still muted but i found myself a working solution.

zypper in gstreamer-0_10 gstreamer-0_10-plugins-base gstreamer-0_10-plugins-farsight gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly gstreamer-0_10-utils gstreamer-utils phonon-backend-gstreamer-0_10 python-gstreamer-0_10 gstreamer-0_10-ffmpeg gstreamer-0_10-plugins-badgstreamer-0_10-buzztar

Ok, maybe all package aren’t useful … but it works with it ^^
And then, when i go in sound preferences, it’s possible to change engine to gstreamer and I obtain another list of hardware, choose default, restart alsasound

/stc/init,d/alasasound restart

And I have my surround functionnal
Thanks for your help ! you can mark the thread as resolved !
PS : Sorry for poor english … :x

Interesting … so the problem was with your sound engine of choice (gstreamer).

Congratulations on sorting this. Thankyou for sharing your solution.