Bumblebee issue with Opensuse leap 42.3

I have installed and configured bumblebee but it is working only with nouveau driver and when using official driver from nvidia I get this error.
My goal is to use CUDA so I need nvidia driver.

 1856.825074] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied

 1856.825110] [ERROR]Aborting because fallback start is disabled.

I have opensuse leap 42.3
Nvidia GTX950M
I have this package for nvidia driver

  • nvidia-bumblebee-352.63-2.1.x86_64
  • nvidia-gfxG04-kmp-default-384.111_k4.4.76_1-3.1.x86_64
  • nvidia-glG04-384.111-3.1.x86_64
  • I have also nouveau driver and bumblebee packages

I don’t know if this problem is related but when I use nouveau driver I get a lower fps.

optirun glxspheres
Polygons in scene: 62464 (61 spheres * 1024 polys/spheres)
Visual ID of window: 0x20
Context is Direct
OpenGL Renderer: Gallium 0.4 on llvmpipe (LLVM 3.8, 256 bits)
35.703037 frames/sec - 32.362661 Mpixels/sec
36.195262 frames/sec - 32.808833 Mpixels/sec
Polygons in scene: 62464 (61 spheres * 1024 polys/spheres)
Visual ID of window: 0xb3
Context is Direct
OpenGL Renderer: Mesa DRI Intel(R) Haswell Mobile 
60.545201 frames/sec - 54.880592 Mpixels/sec
60.040112 frames/sec - 54.422759 Mpixels/sec

this is bumblebee configuration file

# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
# The secondary Xorg server DISPLAY number
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
# The name of the Bumbleblee server group name (GID name)
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
# Directory with a dummy config file to pass as a -configdir to secondary X

## Client options. Will take effect on the next optirun executed.
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?

# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method, use at your own risk
#             none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
# Module name to load, defaults to Driver if empty or unset
# colon-separated path to the nvidia libraries
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path

## Section with nouveau driver specific options, only parsed if Driver=nouveau

Thank you


Now everything is working I just deleted all the driver and bumblebee.

In my case I thing the package nvidia-bumblebee was causing the problem. After some times I notice that this package is related to Tumbleweed

So if you have this package try to delete it.

Pay attention, if you do this carefully you can break the X server. when you delete the nvidia-bumblebee package there are other package that you should install in my case after deleting all nvidia related package including nouveau(which is an opensource driver for nvidia GPU That I don’t know why did they made it) I did zypper up and recommended package check.