Built in Mic on Lenovo T60

I can’t use my built in mic. The system does have a port for a port for an external mic, but I haven’t tried it yet. Any tips or workarounds would be great. Software that been tried is: audacity and the default voice recorder.
The weird thing is that when I’m not listening to music via headphones I can hear myself typing though them.
Any help you can provide would be helpful.

You could plug a mic into your external port and try it. :slight_smile: … Most the time this is a mixer setup problem.

In order to help, I need more information on your hardware and software setup.
To learn more about your audio hardware and software setup, with your PC connected to the internet, copy and paste the following into a gnome-terminal or konsole:

wget http://home.roadrunner.com/~infofiles/tsalsa && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following into a gnome-terminal or konsole and post the output here.rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

I should add, when I test my mic, I typically use a simple arecord command. ie something likearecord -d 10 myrecording.wavorarecord -d 10 -f cd secondrecording.wavwhere “-d 10” sets a 10 second recording. I then play back the recording with xine or mplayer or xmms (or any audio playback program).

When advising of the results of that, please make it clear as to whether you were trying your Internal mic or your external mic.

May results were for for the troubleshooting test-: tsalsa.txt - nopaste.com (beta)

The results for the second second troubleshooting test:
options snd slots=snd-hda-intel

u1Nb.pC0kUcwQ4PA:ThinkPad T60/R60 series

alias snd-card-0 snd-hda-intel

I only have a two sound ports. 1 for a mic and 1 for headphones. The headphones work without a problem.

Thanks. I see your PC has an AD1981, and that you have 1.0.16 of alsa, and that you are using the kernel on openSUSE-11.0.

ok, thankyou. But how about the output of the rest of the commands?

Anyway, I looked at what the script reported for your mixer:

Amixer contents for card 0 [Intel] _____________________________________
amixer set ‘Mic’,0 Mono: 61%,61% on
amixer set ‘Mic Boost’,0 0% 0%
amixer set ‘Capture’,0 Capture 0 0% off Capture 0 0% off
amixer set ‘Mix’,0 Mono: Capture offIt appears to me you have your mixer set wrong in order to record. I think you should switch the boost on, switch the capture on, and move up the capture levels.

Now its still possible that will not work. I note for the AD1981, in the documentation ALSA-Configuration.txt file, there are some model options in the /etc/modprobe.d/sound file:

	  basic		3-jack (default)
	  hp		HP nx6320
	  thinkpad	Lenovo Thinkpad T60/X60/Z60
	  toshiba	Toshiba U205 

If you mic still does not work, you could try editing your /etc/modprobe.d/sound file, adding an extra line at the end so that it reads like this:

options snd slots=snd-hda-intel
# u1Nb.pC0kUcwQ4PA:ThinkPad T60/R60 series
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=thinkpad

and then in a gnome-terminal or a kde konsole restart your alsa sound driver with **su -c ‘rcalsasound restart’ **, enter root password when prompted and then test your mic. Pay CLOSE attention to your mixer settings.

I also did a search on the alsa web site for the AD1981, and I note some alsa driver updates for that hardware audio codec, but I do not believe they are applicable to your problem:
Search results for AD1981 - AlsaProject

Good luck.

:)What I did was delete the driver by using the sound icon under the hardware section with the Yast Control Center. After doing so I rebooted and the magic happened. All I had to do then was scale down the volume on microphone via the Volume Control icon thats in the Application Browser.
Thank you for all your help because it made me think that the driver my have been screwed up.

Glad to read its working now. Congratulations!

Thanks for sharing your solution.