Building Xen Source

Hello friends,
I have installed xen during o.s installion and used it with SLED 10 VM.Now i hav a wish to download the source from the xen website and to compile and run it.So i have dowbloaded a file called “xen-3.3.1.tar.gz” from the xen website and trying to build it.Now i have successfully removed the xen which was inbuilt in suse.I have read the Read me file and tried it…but i could not succeed.The moment i press “enter” in the grub menu"xen 3.3.1".i get error"error 15"…
i think i have committed a fatal mistake…Can any one help me from scratch…

Honestly,I dont know why,i cant understand why this question is attracting no interest from my fellow users…hey friends…pls have a look at the question and try to give me a clue…

Dot no how to bring in people here

Hey, it is not the question of not creating interest etc. This is a forum and people come here whenever they get free time. Then again, only those who have expertise in the topic can help.

You just posted it few hours back. So, please be patient. Someone will answer you.

Ok fine thanks

It is not so simple as you think.
When i compile 11.1 with Xen 3.4 i’ll describe the process
if success :wink:

How to rebuild xen-3.3.1-enabled kernel SuSE 11.1 for x86_64:

  1. Install packages (may be you need more):


In /usr/src/packages/SOURCES you can see tens of patches which
make difference between SuSE’s version of Xen and standard one

  1. cd /usr/src/packages/SPECS

  2. comment reference to “kernel-dummy” in kernel-xen.spec

  3. rpmbuild --rebuild kernel-xen.spec

  4. get results in /usr/src/packages/RPMS/x86_64


You can install it as usually.

I have had the exact same trouble as you have had with Xen from source except my kernel booted but would not mount my encrypted LVM volumes. I had really fallen in love with SUSE but I just didn’t have another day to devote to getting it running with xen so, I went back with Ubuntu. Here’s a breif overview of what I had to do to get xen working from source (I’ll post the rest if I get a chance at work tomorrow b/c my scratchpad is there with all of the “notes to self”):

  1. (here’s an obvious one) downloaded xen-3.4.tar.gz (probably not the right file name but you get the point, the 3.4 one) from xen’s site
  2. extract to ~/tmp (to keep things clean)
  3. cd ~/tmp
  4. wget somefile* (google “linux/compile.h error” and you’ll find it I’ll post the complete stuff tomorrow, but doing this much tonight will oblige me to finish)
  5. hg clone somefile* (this is really sad, I just can’e remeber what it is)
  6. Install openssh-devel, libx11-devel, zlib-devel, ncurses-devel, and more
    7 through infinity. lots of make then depmod then mkinitrd

Basically the end result was a running xen kernel but one that could not boot into my encrypted lvm volumes. From the googling that I have done I think the correct kernel modules for encryption are not loaded, and I’m honestly not sure how to do that. I’ve tried xen with ubuntu before (about a year ago) but I also gave up when it failed to know what to do with my encrypted disk. I REALLY REALLY like suse otherwise, coming from ubuntu I was at a loss after the install because 99% of all my tweaks were already done! Alas, time is scarse and I have to have this server up this week and it looks like it will be KVM and not xen because this wouldn’t work. Again, I’ll post more quantity and better quality tomorrow and see if we can get some good neurons firing here.

This doesn’t seem to work anymore on OpenSUSE 13.2. kernel-dummy doesn’t exist anymore in kernel-xen.spec
I have a similar problem that I wish to recompile the supplied Xen kernel in 13.2 using 13.2 source code and make a change (disable a driver from it).
Can anyone provide me with instructions to doing so?

On Mon, 07 Dec 2015 22:56:06 +0000, ysaliens wrote:

> Can anyone provide me with instructions to doing so?

If it were me, I’d install the kernel sources and then do a ‘make
cloneconfig’ to clone the current config.


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at

Then, it’s best to ask in a new thread.