Bug in Spyder 3


I would like to report what I believe to be a bug in spyder3. I’ve been reading about reporting bugs in openSUSE wiki and since I do not have experience in bug reporting it was advised to search for forum support. Moreover if I want to file a bug report I would want to be accurate on my report, thus this post.

The issue is concerned with the IPython console in Spyder and I have found two distinct problems:

  1. When a code is run with F5, the following command line is run in the IPython console as usual:
runfile(FILENAME, wdir=PATH)

However this time it seems that the console gets stuck upon the first F5 press, only getting through the code execution after a second F5 press. The code is than run and a copy of the command appears on the next console prompt.

  1. When using the IPython console, whenever an error occurs (either a simple typo or any other error kind), any further commands are broken, displaying the message:
ERROR: execution aborted

While I realize the first is really a minor issue, the second behaviour is moderate and quite hinders my workflow. It can overcome this by restarting the console but this isn’t a permanent solution, since it actually doesn’t correct the issue.

I tried to figure if it is really a problem with Spyder3 or IPython, so I opened a terminal window, ran ipyhton and tried to reproduce the error. Something as simple as calling an undefined variable would be enough produce the error, that is all subsequent commands getting “ERROR: execution aborted”. It showed that everything’s OK in IPython called from the terminal window and only in spyder3 this problem occurs. So I believe that the bug is in spyder3.

What are your thoughts on this? Should I go ahead and file the bug? Or is there a simpler solution?

IMO you have enough to file a bug report although some additional info could be helpful, the problems you describe are almost certainly code related and not something you (an End User) can be expected to fix.

Include what you’ve posted,
But you also have to provide the following additional information…

  • How you installed or set up your application. Include excruciating details, enough that you’re certain a person can replicate your setup exactly so can see the error for themselves. Special attention should be paid if you have any repositories installed besides the default (and maybe you should also try installing the special python repos beofre submitting a report, perhaps updated components might solve your problem?)

Looks like as I remember for 15.0, the python2 and python3 packages now come from a single repository,

  • The errors you posted are fairly cryptic, you might see if more verbose errors might show up in your system log, the likely easiest way to capture those events is to first open a windowsed console and run the following command… Leaving the window open, then try to launch your app and see what happens in your windowed console
journalctl -f


I realize that my input is a bit lacking but actually I tried to get more meaningful messages, such as running Spyder from command line and reproducing the error, but I had no meaningful output. It is strange because if I open a IPython console from a command line I have no issues, only on Spyder. I did a journalctl -f while using Spyder, but I believe it doesn’t show anything useful to debug. But maybe I am wrong and someone else would know better. In any case here’s the journal log in this link. Do you think it is helpful?

You’ve pretty much eliminated any installation problem, the problem is likely entirely within the Spyder application.

Installing the special Python repository (I’d recommend this anyway for anyone who does development)


Then do a “zypper up” to update any apps including Spyder which might be affected.

If adding the python repo doesn’t improve things,
There are alternate ways of installing Spyder, eg by installing Anaconda, which installs (and supersedes) the entire Python environment which ordinarily won’t cause problems on openSUSE. Would be interesting if you see the same problems or not in an alternate install. Uninstalling Anaconda is simple… either delete the entire file tree or remove from your PATH.

You should also submit a bug report to https://bugzilla.opensuse.org.
Include extreme detail about how you installed and set up, eg which repo Spyder was installed from, your experiences with and without the Python repo, any special configuration, etc… enough for anyone to replicate your install.


The funny thing is that neither spyder3 or ipyhton (python3-jupyter_ipython) are in the development repo you provided. I could try to use anaconda but I have some projects in virtual environments and I’m not sure if it would disrupt all my work to set it all up again, not to mention the hassle of doing it. I already filed the bug report and hopefully it gets fixed. Otherwise I would surely find an alternative solution.

The idea behind adding the repo wasn’t to provide any specific package but to generally provide more recent versions of just about anything on the chance that would fix the problem you’re seeing… and whatever python code you’re running would also be able to use most recently available versions.

If it doesn’t fix your problem, it was just a chance.

Time to submit a bug report with your findings.


All right I got it. I updated all python versions to the devel repo but the problem wasn’t fixed. I guess is really something to do with spyder3. The bug has been reported (Bug 1136643) and I’ll be aware of any further developments. Thank you for the feedback.