BTRFS read-only because of full disk


on my Notebook I have Leap 15.1 on my SSD installed and have BTRFS as my file system. Because of my stupidity I also have my /home partition in the same BTRFS partition.

When I boot I cannot excess my desktop GUI or other files because the filesystem is read-only.
At boot there are some errors:

BTRFS critical (device sda2): corrupt leaf: root=1005 block=730333184 slot=14 ino=1556978 file_offset=0, invalid offset for file extent, have 60067072, should be aligned to 4096
BTRFS warning (device sda2): Skipping commit of aborted transaction.
BTRFS: error (device sda2) in cleanup_transaction:1881: errno=-5 IO failure
BTRFS info (device sda2): forced readonly
BTRFS info (device sda2): delayed_refs has NO entry
BUG: unable to handle kernel paging request at ffffffff8127e840
IP: apparmor_file_free_security+0x1b/0x40

In terminal I tried some stuff:

sudo btrfs filesystem show /

That gives me 97% full disk

  • Deleting some snapshots or other stuff is not possible because of read-only.

With a openSUSE Tumbleweed rescue usb-stick I tried:

mount /dev/sda2 /mnt

It’s possible to mount but still read-only and I’m still not able to boot.

btrfs scrub start /mnt

At the beginning it’s really fast with 300mb/s but than it gets slower and slower (some kb/s) and it will possible not finish at all. I waited two days, it was still not finished and the estimated finish-time was increasing every time i looked at the laptop. So I canceled it.

What else can I do to get my files from /home?

If you can mount (even read-only) you can also copy files to another device.

Help! I ran out of disk space!