Brother MFC5440 Printer Installation- OpenSuse 11

Brother MFC5440CN printer is not listed; I found the printer driver & CUPS rpm: still cannot install the drivers.

So I understand from your post that you have been here, and now have the lpr driver and CUPS wrapper packages downloaded and installed. You can confirm with

[/QUOTE]rpm -qa |grep MFC[/QUOTE]

It should return with something like


If not have a look at the instructions on the Brother website, or post back here.

Then you should be able to configure via CUPS interface

Don’t worry about trying to use YaST to do this.

Thank you for the reply. I finally installed the driver after logging in as superuser (I thought I was already logged in as SU). I still cannot print, however. The printer shows “receiving data” but nothing prints. Note: this is a networked printer over IP (printer has it’s own NIC) within a simple peer-peer home network. I could also try configuring the printer as a SAMBA printer since it is principally used with Windows computers.

I could also try configuring the printer as a SAMBA printer since it is principally used with Windows computers.

If the printer is connected directly (via ethernet) to network then forget samba printing.

Fisrt of all, you can establish whether or not you have network connectivity with the IP address of printer. For example, I have a network printer (Brother MFC7820CN) connected with an IP address


See if you can get a reply with ping command.

Not sure how you configured printer, but an overview as follows (sorry if this part obvious):

CUPS > Administration > Add Printer. Give your printer a name, then choose ‘LPD/LPR Host or Printer’

Now, enter device URL like this (use the applcable IP address):


(This also works for me –> lpd://
Follow the prompts until done.

See how that goes. You should also try test printing from the CUPS interface.

Good CUPS network printing HOW TO

The printer shows “receiving data” but nothing prints.

I have had this happen, but normally fixed by turning printer off then on again. Then cancel CUPS job and try again. Start with test print first. Then try from an application. Make sure default printer is correctly set (eg not printing to non-existent printer).

Thank you for the help ! I figured it out ! I removed the option for a cups server. It’s working fine now…and, I just configured NX for remote console connection from my laptop. So, I’ll save steps running back and forth between rooms !
Regards, Gary

Good work :slight_smile: