Broken grub

Hello all, I’ve just installed openSUSE tumbleweed and I think I installed not correctly. Right now I have trouble with GRUB and can’t seem to make it use openSUSE’s bootloader. I’m currently dual-booting with Windows.
I migrated from EndevaourOS and there is currently an option for that bootloader in my boot options, how do I remove/fix that? I’d like to use the openSUSE bootloader.

I managed to fix it by myself with a bit of googling.
Steps if you have this problem

  1. Go to /boot/efi/EFI and delete the old OS boot loader.
  2. If you’re bootloader is now Windows just head to BIOS and change the values to make openSUSE more priority.

We are glad you were able to fix it.

This is partly a BIOS issue. For most of us, installing openSUSE automatically takes care of it. The installer sets the opensuse-secureboot entry to be the first choice. But some BIOS reject that, and set their own order. In that case, you have to use BIOS settings to get the order the way you want.