Broken fonts

Hi all,

I have installed fresh tumbleweed today (had leap 15 before) and I have problem with ugly looking fonts.
I tried to tweak it via system settings, but still can’t achieve better result. Interesting is that this problem
persists after rebooting to Win10, so I suppose it is something with AMDGPU driver and GC settings.
Any idea how to solve it? Thanx

Jaroslav

My HW is i5 4460, sapphire nitro+ radeon rx 580

Hi
System all up to date via zypper dup? No third party libfreetype installed? Have you played with the tweaks tool to set the hinting etc?

You might get smoother fonts by enabling subpixel rendering.
This link might be helpful although I don’t think you need to install the New Libraries from namtrac any more to have it enabled properly.

http://www.ocsmag.com/2017/09/23/opensuse-fonts/

Yes, No, Yes, still ugly.

Hi
So what are your font’s selection and tweaks etc?

Mine looks fine here, I use a osX theme with Full hinting and Subpixel for LCD;

http://thumbs2.imagebam.com/ff/c2/4d/4d78ca1050975644.jpg](http://www.imagebam.com/image/4d78ca1050975644)

I’m running dual AMD gpu’s with amdgpu.

I made some screenshots to upload here and I found that screenshots look well in Windows but are broken when displayed in Tumbleweed.
So it seems is is not problem of fonts but graphics processing.

As you can see - screenshot

http://thumbs2.imagebam.com/14/be/32/ffac211051517784.jpg](http://www.imagebam.com/image/ffac211051517784)

picture of screenshot taken by phone.

http://thumbs2.imagebam.com/8f/e9/c5/f5b55b1051517744.jpg](http://www.imagebam.com/image/f5b55b1051517744)

Hi
Is this an internal or external screen? If an external screen, how are you connecting?

What are the specs on your screen and model number?

Can you post the output from;


xrandr
/sbin/lspci -nnk |egrep -A3 "VGA|Display|3D"

Can you upload to say SUSE Paste your ~/.local/share/xorg/Xorg.0.log

I have external HP LP2475w connected via HDMI cable. Here is result of your commands.
GC is reported as having 4GB but it is 8GB variant.

Hi
One thing I set in the kernel options is amdgpu.dc=0 (Display Core Driver) to disable, but that maybe a red herring since I have two gpu’s in the laptop connected over hdmi.

What about the xorg log, do you see anything in there, also check the boot log for possible errors;


dmesg |egrep "amdgpu | drm"
journalctl -b --no-pager |egrep "amdgpu | drm"

It could just be tweaking for the card and monitor that’s needed… No auto adjust on the monitor your can press?

There are multiple settings on the amdgpu driver which would need investigating for your card.

Have you tried Xorg rather than Wayland?

Xorg.log - https://susepaste.org/view/simple/86121750
dmesg - https://susepaste.org/view/simple/58959893

Xorg.log looks good I thing, no WW or EEs there, but there is this in dmesg log:

3.290470] amdgpu: [powerplay] Failed to retrieve minimum clocks.
3.290471] amdgpu: [powerplay] Error in phm_get_clock_info 

I found it mentioned here - https://bugs.freedesktop.org/show_bug.cgi?id=108260
Interesting is I have another PC with Tumbleweed (updated, no tweaks), RX 560, same monitor type, same error in log, but image is OK there.

It seems that amdgpu.dc=0 helped, thanx!:slight_smile:

The problem with subpixel rendering is that not all fonts require the same setting. Some look best without. Some need full. Some light. It’s just not an easy job to find the right settings.