Broadcom Wireless BCM43224 Problems in Dell Latitude E6410

So I am having Wireless problems with my new install of openSUSE 12.1 and my Work Laptop, a Dell Latitude E6410

This what I can find out with lspci

02:00.0 Network controller: Broadcom Corporation BCM43224 802.11a/b/g/n [14e4:4353] (rev 01)
        Subsystem: Dell Wireless 1520 Half-size Mini PCIe Card
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at f4200000 (64-bit, non-prefetchable) [size=16]
        Capabilities: [40] Power Management version 3
        Capabilities: [58] Vendor Specific Information: Len=78 <?>
        Capabilities: [48] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [d0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [13c] Virtual Channel
        Capabilities: [160] Device Serial Number 00-00-38-ff-ff-48-c0-cb
        Capabilities: [16c] Power Budgeting <?>
        Kernel driver in use: bcma-pci-bridge

I have installed the b43-firmware (from Packman) & b43-fwcutter. Tried the following terminal commands:

sudo /usr/sbin/install_bcm43xx_firmware
sudo /sbin/modprobe -rv wl
sudo /sbin/modprobe -v b43

This actually cases it to work for a few minutes, long enough to configure it where it finds my local wireless router. But then, Wireless goes to unconnected. I can open up a terminal session and run:

sudo /sbin/modprobe -r b43
sudo /sbin/modprobe b43

Kwallet starts, ask for my password, and once again my wireless is activated, but in a few minutes, it goes unconnected again. Not sure what I am looking for to fix this problem. I was using openSUSE 11.4 & the proprietary Broadcom driver before which did work, but decided I would try to get the one from Packman working, it kind of works, but for only a few minutes and then off it goes again. Any help would be appreciated. I have the laptop out at home today, but don’t always have it so I can play with Linux on it like at the moment.

Thank You,[/size]

Did you mean you had previously used ‘wl’ in 11.4
Have you tried that in 12.1?

After the openSUE 12.1 install the wireless did not work and it did not show to be even loading wl, but later I did try this

sudo /sbin/modprobe -rv b43
sudo /sbin/modprobe -v wl

The wl module then shows to be loaded, but the interface disappears from network manager.

Since it actually works for a few minutes the other way using b43, I figured I could find out why it stops. But I have not seen wl module do anything. But I am ready to try other commands.

Thank You,

It’s not in my experience to have ‘wl’ installed and switch to and from b43 and wl
And typically ‘wl’ loads a blacklisting for b43

On my installs I can use either or.
So if I were to use ‘wl’. Which I am currently. And decided to switch to b43, I would first uninstall ‘wl’

For me - removing ‘wl’ also removes the blacklisting. But I have seen case where it has not, so keep an eye on that if trying to use b43.

Hope that makes sense

So, right now I am using the b43 drivers and it seems to be working longer than a minute. First I did uninstall the wl drivers as suggested and rebooted the Laptop. But, no wireless on restart and unloaded and reloading b43 worked, for a while, just as before. So, I then disabled Network Manager and went to the ifup/down stuff.

linux-tcm7:~ # ifstatus wlan0
    wlan0     name: Broadcom WLAN controller
DHCP4 client (dhcpcd) is running
. . . but is still waiting for data
4: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether c0:cb:38:48:2b:99 brd ff:ff:ff:ff:ff:ff
    inet brd scope global wlan0
Configured IPv4 routes for interface wlan0: - - wlan0  
Active IPv4 routes for interface wlan0:
  default via  scope link
1 of 1 configured IPv4 routes for interface wlan0 up
    wlan0     is up

I would find that after a few minutes, it would go disconnected. But I kept turning it back on repeatedly. Finally, sick of that nonsense I re-enabled NetworkManager, did a reboot and here am am with it working. Now one can say that I was trying too many things at once, but when it does not work out of the box and you don’t do this very often, I just can’t say for sure what I did that worked and what did not work for sure. Humm… And what should I do on the next kernel update or will it even work on the next reboot. Even more questions to ask. Now I forgot to save what it said, but I did notice an error on ifup wlan0 & Power Management and you wonder if perhaps the card is turning its self off for some reason and that is what is wrong, but not now for some reason. Another Hummmm.

Thank You,

b43 shouldn’t be affected by kernel updates.

On 12/18/2011 10:36 PM, caf4926 wrote:
> b43 shouldn’t be affected by kernel updates.

It is not. Any driver built into the kernel is automatically updated whenever
the kernel is. That situation is not true for frivers that are out-of-kernel.
After an update, they will no longer work.