Brightness Control stopped working

Dear Community

After long inquiry into Linux compatibility I have bought a Dell Latitude E7450 and installed OpenSuse 13.2 that supported all hardware out of the box - including the touchscreen. I changed to tumbleweed in order to update some software and everything went fine for quite a time with different kernels. I am now using 3.19.x-y-desktop kernels, still having a 3.16.2-x-desktop at disposal. All of a sudden, must have happened after a system update, the function keys for brightness stopped working and a setting of the brightness by the gnome controls as well. I tried with xbacklight -set 0 (50 or 100) but no change neither. The brightness seems to be unchangable and seems to be set to a high level by default thereby draining on the battery life which is much worse than advertised anyway.

I tried all of the kernels at hand with no difference in success. I never updated the BIOS of the machine, btw. The graphic seems to be by intel, in the yast2-hardware information I can only see a hint at it in the section Display (Intel VGA compatible controller).

Is there a way to get brightness working again or to revert to 13.2 stable after many updates and additional software installations being made?

Thanks in advance for contributions.


If you are using Tumbleweed you should post to the Tumbleweed thread

Just a reminder: When riding the cutting edge be prepared to bleed.

Thanks for the hint. I just reposted to the Tumbleweed section. So there is good chance that with the next stable release (probably in autumn 2015) the problem will be fixed, if I got you right.
Yes, I think I was naive about Tumbleweed.

But do I understand you correctly that the stable release of openSuSE works out of the box on the Latitude E7450 including all peripherals? (I’m considering whether to buy it…)
Thanks, Hendrik

If you go into YaST bootloader and in the kernel boot options add the following after splash=…

acpi_osi=\"!Windows 2012\"

Reboot and see if that fixes things…