Bouncing Icons but Software not loading

I have 2 icons on my Desktop (Firefox and Thunderbird) on my newly installed openSUSE 11.2, which when I click on them the icon bounces for about 30 seconds, but then stops bouncing and the software doesn’t load. I’ve deinstalled and reinstalled the software to no avail. What causes these icons to bounce but then not load? Is there anyway I can fix this so the software loads normally? I have a working internet connection, so it’s not because of the lack of internet, as far as I can tell.

Usually it means that the program could not start. Open up the properties of the icon and note the program name. Then open up a terminal and run that command manually. That will show you what errors occurred.


firefox returns
couldn’t load XPCOM

thunderbird returns
error while loading shared libraries: cannot open shared object file: No such file or directory

How to overcome these two errors?

How did you install those packages? From mozilla? They don’t happen if you use the openSUSE packages.

I installed them with openSUSE. I even deleted them with openSUSE and reinstalled them with openSUSE.

Show us your repos and packages:

zypper lr
rpm -qa ‘Mozilla*’

I can’t cut 'n paste because I’m posting on another machine. So I’ll type it in here.

zypper lr

openSUSE 11.2-Debug No No
openSUSE 11.2-Non-OSS No No
openSUSE 11.2-OSS No No
openSUSE 11.2-Source No No
openSUSE 11.2-Update Yes Yes

rpm -qa “Mozilla*”


Look ok so far. Check if your packages are complete:

rpm -V MozillaFirefox MozillaThunderbird

Also check that you are running the correct programs:

which firefox thunderbird
ls -l /usr/bin/firefox /usr/bin/thunderbird

Should return

/usr/bin/firefox → …/lib64/firefox/
/usr/bin/thunderbird → …/lib64/thunderbird/

The rpm command returned nothing. the which command returned the first 2 (of the 4) lines. The ls command returned the last 2 (of the 4) lines.

How did you install the OS? IF CD/DVD did you check the media?

Installed from openSUSE 11.2 KDE Live CD x86.64. I just check the media again. It is still ok.

Yast is working. so is Konqueror.

stubble wrote:
> openSUSE 11.2-Debug No No
> openSUSE 11.2-Non-OSS No No
> openSUSE 11.2-OSS No No
> openSUSE 11.2-Source No No
> openSUSE 11.2-Update Yes Yes

my eye says you need to enable/update oss, non-oss and update (and
when time to add codecs etc, add packman) and THEN remove and
reinstall the two offending apps…

DenverD (Linux Counter 282315)
posted via NNTP w/TBird | KDE 3.5.7 | openSUSE 10.3 SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

That’s fine, but there are library dependencies so those may be missing. Do this:

ldd /usr/lib64/firefox/firefox

That should give: =>  (0x00007fffc936a000)                                => /lib64/ (0x00007f7041d7d000)                    => /usr/lib64/ (0x00007f7041a6f000)        => /lib64/ (0x00007f7041853000)          => /lib64/ (0x00007f70414f8000)                      
        /lib64/ (0x00007f7041f81000)                        => /lib64/ (0x00007f70412a3000)                      => /lib64/ (0x00007f704108c000)


ldd /usr/lib64/thunderbird/thunderbird-bin

which should give: =>  (0x00007fffa69e1000)                                => /lib64/ (0x00007f0b7d161000)          => not found                                                => not found                                                => not found                                           => /usr/lib64/ (0x00007f0b7cf5d000)              => /usr/lib64/ (0x00007f0b7cd58000)                => /usr/lib64/ (0x00007f0b7cb1b000)              => /lib64/ (0x00007f0b7c917000)                    => /usr/lib64/ (0x00007f0b7c714000)                                                                      => /usr/lib64/ (0x00007f0b7c4dc000)                => /usr/lib64/ (0x00007f0b7c2b1000)            => /usr/lib64/ (0x00007f0b7bf7a000)                => /usr/lib64/ (0x00007f0b7bd5b000)        => /usr/lib64/ (0x00007f0b7b75a000)                                                                              => /usr/lib64/ (0x00007f0b7b53a000)      => /usr/lib64/ (0x00007f0b7b292000)      => /usr/lib64/ (0x00007f0b7b069000)                                                                            => /usr/lib64/ (0x00007f0b7ade3000)    => /usr/lib64/ (0x00007f0b7abae000) => /usr/lib64/ (0x00007f0b7a902000)                                                                              => /usr/lib64/ (0x00007f0b7a6e6000)                                                                        => /usr/lib64/ (0x00007f0b7a4da000)                                                                        => /usr/lib64/ (0x00007f0b7a290000)  => /usr/lib64/ (0x00007f0b7a012000)          => /usr/lib64/ (0x00007f0b79dcd000)                                                                              => /usr/lib64/ (0x00007f0b79bc9000)                                                                              => /usr/lib64/ (0x00007f0b79902000)    => /usr/lib64/ (0x00007f0b796f8000)                                                        => /usr/lib64/ (0x00007f0b793bc000) => /usr/lib64/ (0x00007f0b7919a000) => /lib64/ (0x00007f0b78f5a000) => /lib64/ (0x00007f0b78d51000) => /usr/lib64/ (0x00007f0b78b2d000) => /lib64/ (0x00007f0b78917000) => /usr/lib64/ (0x00007f0b786d4000) => not found => not found => not found => /usr/lib64/ (0x00007f0b784ca000) => /usr/lib64/ (0x00007f0b78265000) => /usr/lib64/ (0x00007f0b78060000) => not found => /usr/lib64/ (0x00007f0b77d90000) => /usr/lib64/ (0x00007f0b77a82000) => /lib64/ (0x00007f0b7782d000) => /lib64/ (0x00007f0b77616000) => /lib64/ (0x00007f0b772bb000)
        /lib64/ (0x00007f0b7d37d000) => /usr/lib64/ (0x00007f0b770b5000) => /lib64/ (0x00007f0b76e9f000) => /lib64/ (0x00007f0b76c81000) => /lib64/ (0x00007f0b76a58000) => /usr/lib64/ (0x00007f0b76846000) => /usr/lib64/ (0x00007f0b76643000) => /usr/lib64/ (0x00007f0b76438000) => /usr/lib64/ (0x00007f0b7622f000) => /usr/lib64/ (0x00007f0b76024000) => /usr/lib64/ (0x00007f0b75e21000) => /usr/lib64/ (0x00007f0b75c1e000) => /usr/lib64/ (0x00007f0b759c4000) => /usr/lib64/ (0x00007f0b7579c000) => /usr/lib64/ (0x00007f0b75598000) => /usr/lib64/ (0x00007f0b7538f000) => /usr/lib64/ (0x00007f0b75172000) => /lib64/ (0x00007f0b74f44000) => /usr/lib64/ (0x00007f0b74d40000) => /usr/lib64/ (0x00007f0b74b3b000) => /usr/lib64/ (0x00007f0b74932000) => /usr/lib64/ (0x00007f0b74715000) => /usr/lib64/ (0x00007f0b74511000) => /lib64/ (0x00007f0b7430c000)

The reference to libglitz is strange. Have you altered LD_LIBRARY_PATH? What is the result of


? Also re XPCOM, what is the result of:

rpm -V mozilla-xulrunner191-


I tried that. Same result.


ldd /usr/lib64/firefox/firefox - I get the same

ldd /usr/lib64/thunderbird/thunderbird-bin - I get the same except => not found

echo $LD_LIBRARY_PATH - I get a blank line only

rpm -V mozilla-xulrunner191- - Doesn’t return anything.

You may be missing some dependencies. When you installed MozillaFirefox did you run YaST on a downloaded package or did you install from the software manager and let it fetch the dependencies automatically?

See if you have any versions of xulrunner, old or new:

rpm -qa ‘mozilla-xulrunner*’

Also did you encounter any installation errors when installing from CD/DVD and ignore them? You may have an incomplete system with errors.

I don’t recall having any errors with my install. I used Software Manager for the installation of both Firefox & Thunderbird

rpm -qa “mozilla-xulrunner*” returns


When I run rpm -V mozilla-xulrunner191- on the machine i’m posting from, it returns …T. /usr/lib/xulrunner-

So is this significant that it doesn’t return anything?

OK. Success. I got both firefox and thunderbird working by installing the 32bit version of mozilla-xulrunner. But I’m definitely using a x86.64 machine. It installed some other stuff at the same time, which might have installed the dependencies I was missing. But they’re both working now. Thank you very much for your help.