Booting to LEAP ISO Hangs at Black Screen


I’m attempting to install LEAP 15 onto a Dell Precision 5530 laptop.
However, when I boot to the USB stick (I’ve also tried an ISO burned to DVD-R) I get a black screen with a little cursor in the upper left. The system is completely unresponsive at this point. I’ve seen lots of posts about setting “nomodeset” as a paremeter in GRUB, but… I never get to GRUB.

  • I’ve been able to install LEAP 15 onto an older laptop with this same USB stick.
  • Fedora Workstation 28 will hang before it gets to the installer screen (but after GRUB). But, If I edit the parameters to include the option nomodeset it loads without error to run live.

Any advice?

Specs I found for Precision 5530 indicate it has Optimus hardware, which seems to be more often problematic than not. Searching for Optimus may provide better clues, but I would start by using the laptop BIOS to try to disable NVidia gfx. If that doesn’t do it, use the F12 key during POST and see if you can select specifically the boot media in UEFI mode.

I actually was using UEFI and selecting the USB stick from the F12 one time boot manager.

I’ll look again, but my first cruise through BIOS settings didn’t show anything disable-able video-wise.

Booting with UEFI –

when you see the boot menu, hit the ‘e’ key. This will give you an edit window.

Scroll down to find the line that begins “linuxefi”.
Hit the END key to get to the end of that line.
Type in " nomodeset" (without the quotes)
Hit CTRL-X to resume booting.

This gives you an alternative video driver, probably poorer resolution. But it should be enough to install. You can work on configuring the video setup after you have an installed system.

… and if nrickert’s suggestion doesn’t work, you can try the ncurses installer by adding, instead of nomodeset, you could next try adding


at the end of that line.

Problem is I never get a boot menu. The black screen is immediate after selecting the one time boot from USB stick via F12.

How old is the laptop you had the success with? Does it also have Optimus? If I had them here I’d try a TW stick instead of 15.0 first. If no joy I’d probably try to put the SSD from the newer into the older, install there, then return SSD to the newer and see if it boots. Alternatively, clone the older’s storage to the newer’s SSD. Or, I’d go ahead and install Fedora multiboot, then use Fedora’s installed bootloader to load the 15.0 installation kernel and initrd.

How did you make the stick you must do a unmodified binary copy to the device not a partition on the device.

In the opening post you wrote:

  • I’ve been able to install LEAP 15 onto an older laptop with this same USB stick.

Can you boot of this stick at other computers at this moment? In other words is the stick still Okay, or maybe damaged?
It looks as if the stick is found during boot and the computer wants to boot from it, but there is no boot-able system on it.

The USB stick in question still works on the older laptop. It seems to be fine.
Older laptop does not nave optimus.

Does the older laptop boot in Legacy/MBR mode (the GRUB menu has 8 “buttons” for F1-F8 at the bottom) or in UEFI mode?
If Legacy/MBR, can you set the Dell Precision to boot in “CMS” mode (or Legacy or whatever it might be called in its BIOS)?
If it can boot in Legacy mode, maybe the USB stick was burned the wrong way and cannot boot in UEFI mode?

I suspect you are hitting a GRUB bug related to it’s handling of one of the clocks for it’s time source in this system.

Here is the fix:

You can recompile GRUB with that fix in place.

Alternatively you may be able to work around it by turning on legacy option ROM (which will restore this legacy clock as well IIRC).

If this is really a timing problem, then a different installation method could be a solution. Is Grub already installed on that laptop? If yes, you could add a stanza to it to load the installation kernel and initrd to do a NET install. Other methods include a different stick with the NET install instead of full DVD, as well as PXE.

I’ve run into a similar problem with Leap 15.0 on an Asus UX433. The Tumbleweed NET install image worked, so I think it is indeed that Grub got updated in the meanwhile.

I stumbled onto this thread due to a blank screen when booting to the DVD installer ripped to a USB thumb drive. This is on an Asus Prime Plus H570, 10th Gen., with integrated graphics. I found help here: However my menu list did not show

setparams 'Installation'

   set gfxpayload=keep
   echo 'Loading kernel ...'
   linuxefi /boot/x86_64/loader/linux splash=silent
   echo 'Loading initial ramdisk ...'
   initrdefi /boot/x86_64/loader/initrd

rather it was

setparams 'Installation'

   set gfxpayload=keep
   echo 'Loading kernel ...'
   linux /boot/x86_64/loader/linux splash=silent. <-- ### Notice the difference here ###
   echo 'Loading initial ramdisk ...'
   initrd /boot/x86_64/loader/initrd

This was the line to add

setparams 'Installation'

   set gfxpayload=keep
   echo 'Loading kernel ...'
   linuxefi /boot/x86_64/loader/linux splash=silent nomodeset       <-- add the space and text in this line
   echo 'Loading initial ramdisk ...'
   initrdefi /boot/x86_64/loader/initrd

to the end. This got me to the installer GUI. I hope this helps someone. :slight_smile: