Booting stops with sp5100_tco: I/O adress 0x0cd6 already in use

After installing Opensuse Tumbleweed, the boot process stops with the message:

sp5100_tco: I/O adress 0x0cd6 already in use

This bug is present since months when I install Opensuse Tumbleweed!

When I choose “Recovery Mode” (sorry i see it only in german) the system (Opensuse Tumbleweed 4.7.5-1-default) boots up and everything works fine!

When the module sp5100_tco is blacklisted via /etc/modprobe.d/50-blacklist.conf
I get no error but system still halts at boot when booting per default grub2 entry!
There is no message or indication to see why booting stops at this point…

Opensuse Leap 42.1 works fine.
Fedora 24 with the same Kernel (4.7.5-1) shows the error message, but continues booting…
Opensuse Tumbleweed installation media as the Live CD media boots just fine.

Bugreport filed

I see the same error, but system comes up fine, I’m running kernel:HEAD though 4.8.0-1.gbbbf852-default ;

Oct 08 18:17:18 ernie3 kernel: sp5100_tco: SP5100/SB800 TCO WatchDog Timer Driver v0.05
Oct 08 18:17:18 ernie3 kernel: sp5100_tco: PCI Vendor ID: 0x1022, Device ID: 0x780b, Revision ID: 0x42
Oct 08 18:17:18 ernie3 kernel: sp5100_tco: I/O address 0x0cd6 already in use

cat /proc/ioports | grep 0cd6
  0cd6-0cd7 : pnp 00:04
    0cd6-0cd7 : smba_idx

Have a read of

Hey malcolmlewis,

thanks for replying!
What about the same behavior when sp5100_tco is blacklisted?
Why does is work in recovery mode?

How can I pinpoint the problem?

So created a blacklist file (/etc/modprobe.d/50-sp5100_tco.conf) and rebuilt initrd (mkinitrd) and rebooted fine and don’t see the warning.

Before I blacklisted, both modules sp5100_tco and i2c_piix4 are loaded but not used.

I found this thread on the redhat bugzilla list

and someone found a bug with the sp_5100tco driver and submitted a patch for fixing.
Apparently sp_5100tco and i2c-piix4 tries to use the same resources but fails.

But as of today using kernel 4.11.4 nothing has happened. So hopefully this will be fixed soon.

The bug is still there in Tumbleweed. I can’t boot my HP N54L Microserver now. Any advice?

I have the i2c_piix4 blacklisted on my HP 14-an013nr running Tumbleweed;

cat /etc/modprobe.d/50-i2c_piix4.conf
blacklist i2c_piix4

If you edit the grub menu at boot time and add;


Then you should get to your DE and create the blacklist file, run mkinitrd and reboot to test.

After changing several kernel options which removed the error messages but didn’t allow the system to boot properly I went back to look at the last changes I made to the system. I had added a nofail option to an entry in fstab while I was swapping disks. It appears that when the kernel attempts to mount a disk with a nofail option it starts a time-limited process. It seems that this process triggered the problem and prevented the system from booting further than the diagnostic stage. I also tried booting a Knoppix live system from a USB key and that failed to boot even though it wasn’t looking at fstab so that’s looking like a separate problem.

Thanks for your help.