boot problem with Leap 42.2 - can I install open SUSE 15.2


I am a beginner when it comes to Linux installation. I run into boot problems with Linux installation I had (Leap 42.2) while trying to install python and fixing some libraries inconsistencies (not very successfully obviously). I have some limited support and I think there was an attempt to go back to the previous installation to undo the python mess I created. But right now I have a boot problem.

The error i see on screen is the following:

[FONT=Times]failed to create mount unit file /run/systemd/generator/home.mount duplicate entry[/FONT]

According to some online posts this is a ‘cosmetic problem’ and not a cause for the boot errors. Following the post advice I hit Esc to see more information that could identify the problem and the hang happens after:

[FONT=Times] OK ] Started Getty on tty1.[/FONT]
[FONT=Times] OK ] Started target Login Prompts.[/FONT]
[FONT=Times] OK ] Started /etc/init.d/after.local Compatibility
Starting X Display Manager
Starting Locale Service

So perhaps this is the windows manager that crashes since there is no ‘OK’ there? I dont get to the point where I can log or use command line to see something more.

I am wondering what should I do now. And specifically if I can simply try to download the open suse 15.2 and try to boot from a DVD

Forgive my ignorance but can you point me to some reading or posts where I could learn more to about how to upgrade without possibly loosing the existing files? I guess normally you make a backup and then just run an upgrade, but I can not boot.
I have two disks mounted. Not that much I worry about on the main disk that contained all the main partitions in the current install. And en extra disk with quite a lot I would like to still have access too. I am not sure I understand/explain this properly.

Any advice much appreciated!


I’m not sure what caused your problem. Support for 42.2 ended some time ago (several years ago). Yes, I would recommend that you install Leap 15.2.

Answering your question about accessing and preserving your files…
You should make a backup or better yet a copy of all your personal files (recommend an external hard drive as easiest).
If you download the most recent LEAP 15.2 DVD, you cannot simply run LEAP 15.2 like a LiveCD, the DVD can only be used for installing and upgrading.

Regarding any attempt to upgrade preserving all your applications and personal files…
I wouldn’t advise that because upgrades are supported from one version to the next. You would have to download and upgrade
42.2 > 42.3 > 15.0 > 15.1 > 15.2

I would install ask you to inventory which applications you’ve installed and are using. More than likely you can replace and re-install rather than upgrade.
As for your personal files, once you’ve identified their location (most will be a subdirectory of /home) you can simply copy them elsewhere and back again to minimize any risk to your files.

So, to review since an upgrade strategy is likely your best way forward (and keep updated on a weekly or monthly basis)…
Unless you ahve an extra hard drive or an extraordinary amount of unused disk space, you’ll have to invest in an external disk drive. You might be able to buy a smaller drive, but typically the “sweet spot” where you get best value for money spent is about $100 US dollars… give or take a little bit each way. If you know someone who is willing to lend you this, that’s great, otherwise you can continue to make good use of your purchase after you’ve used it to safeguard your files during your upgrade.

You’ll need to inventory what apps you’re using.
As a home user, it’s unlikely any apps can’t be replaced, but to be certain you need to either evaluate or post a list of your apps so others can confirm your apps aren’t worth upgrading and don’t pose special problems.

You’ll want to copy any important data to a safe place, I’ve recommended an external hard drive.

Only after you’ve prepared thoroughly, you should be able to re-install with LEAP 15.2, install any apps you need brand new, copy your personal files to their usual locations in your system and… You’ll be good moving forward.


Hej guys!

Thank you so much for all the responses and detailed information =)
I actually dont mind trying to do the updates the way you described going through all the versions. If I can learn to better understand Linux administration along the way. I need better control over my workstation and being more self-sufficient.

CURRENT ISSUE: open SUSE 42.3 upgrade and a GUI ‘Login Failed’ problem.
I have just upgraded to openSUSE 42.3
root login and starts in terminal works. The same root and password combination in any GUI I have available now (IceWM, KDE Plasma Workspace, Plasma 5, User/System Default) give me ‘Login Failed’. Same for my user.

Q1. does one create new posts for each problem like this? Since I am no longer trying to install 15.2…?
Perhaps not.

Briefly in connection to the advice I got before:
I could not boot the computer or ssh to it from elsewhere, so with the unresolved boot problem I could not access any files.
I realized I did not try booting from previous system snapshots systematically to find the one that was still working. Sorry I am learning all this as I go along.
I went back one by one, to identify a snapshot that did not hang and allowed me to log into the computer, missed that I needed to ‘rollback’ and started doing updates, created more snapshots, went back again to last working snapshot, did the rollback. It seems to take back all these unfortunate python libraries that created the problem in the first place.
From there I followed a very easy step-by-step instruction on upgrading 42.2. → 42.3
I did the upgrade, I can log into both root and my account from terminal after accusing it thought Ctrl-Alt-F1.

But I can not log into the GUI.

That seems to be a fairly common problem I found several suggestions. I actually seem to have the same problem as described here

now that I realized I can start GUI from command line login by doing as root

init 3



but if I login as myself I can no longer startx getting some of the following error messages:

[FONT=&quot]Please check the log file “/home/kasia/.local/share/xorg/Xorg.0.log” for additional information"
VGA Arbitration: Cannot restore default device
Server terminated with error
/usr/bin/Xorg is not setuid, maybe that is the reason? Use display manager (or something about /etc/permissions.local)

Following the advice from the post I tried
systemctl status display-manager
Q2. How can I show the output to you guys? I have a crappy phone photo of the screen and dont want to re-type all the lines from that.
It seems I also lack from skills for writing the outputs in the posts properly.
I just thought maybe I output the commands to a file and log into the forum from the workstation root account where GUI works to paste it all…?

Is auto-login configured?
grep “AUTO” /etc/sysconfig/displaymanager
No, auto login is empty “” so that is good.

There was a helpful description to try simpler graphical interfaces for example “IceWM”. That does not seem to help.

Q3. Is it possible that keyboard setup is different in terminal and GUI?
I was wondering if it is possible that when I type the special character in password in terminal it is not the same as what I type in GUI. Since I can not see them. In terminal I can check by typing password as login if the password is right. In GUI I can not type and see, only * appear, so I can not even check if the special character is what it should be.

Q4. Is using ‘zypper dup’ the problem?
It seems some people dont recommend using zypper dup to upgrade
Why do you use ‘dup’ on Leap? It might even cause your issues. Leap needs ‘zypper up’.

but that seems to be exact same command that the official system upgrade is using

I saw some suggestions to try downgrading plasma and see if it helps. I am guessing using IceWM which seems a simple GUI is sort of checking that this will not help? I dont want to start blindly playing around with GUIs.

There is a list of commands that I pasted at the end mentioned in other posts. However I dont know what to look for.
Let me know if it would be helpful to post any of that and from which user, or maybe it does not make a difference for most fo them.

so I am not sure what is a good direction to follow now.
I appreciate a pointer on what might be helpful, and any other comments you might have.



because I dont know what to look for and currently did not figure out how to paste outputs here:

more information about your graphics hardware/drivers
/sbin/lspci -nnk|egrep -iA3 “vga|graphics”
inxi -Gxx
To get an overview of the execution tree of systemd units (current init system) doCode:
sudo systemd-analyze critical-chain
You’ll see that display-manager.service is triggered by
cat /usr/lib/systemd/system/display-manager.service
When you installed, which did you choose, Gnome, KDE, or one of the others? Such choice would affect which login manager was installed.

zypper se -si dm
will list installed dm package gdm, kdm, lightdm, lxdm or sddm plus xdm, and

ps -A | grep dm
will show which, if any, is running.

Sorry for the messy editing! I tried to change it later on but there is only 10min to do it. And I am experiencing a lot of hanging of this page right now.

A few things.

First about posting computer code:
There is an important, but not easy to find feature on the forums.

Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

An example is here: Using CODE tags Around your paste.

Then about the versions of openSUSE. You have indicated with the prefix above that you use openSUSE Leap 15.2. But you are all the time talking about 42.n versions, which are not supported for a long time already. Not many people will have a 42 version to see if they can follow all what you say, they can not look anymore in e.g. configuration files to compare with what you have, etc.

Best is to save your user data (and probably other data like databases) and install openSUSE Leap 15.2. Then it will be an easier concversation with your fellow openSUSE users here, because all are then talking about the same.


Thanks for the comments. I will use the code tag!

Some of the questions I thought are general (not connected to the version) and come not enough knowledge of Linux administration. But I am learning.

15.2 is exactly what I want.
I thought I had no choice but to re-install the system because of boot problems.
But if possible, isn’t it better to do the upgrades from version to version (skipping versions is not supported) and not touch the files and programs? This in my intuition perhaps I am wrong.
If I re-install the system directly to 15.2 then the main partition/disk where root directory / is located is wiped - am I wrong? I need to create partitions on that disk again, copy all the files from backups, install all programs again, perhaps mount other disks again(?). That is how I understand it. Am I wrong?

I skipped solving the GUI problem since it did not prevent me from doing the next upgrade.
Currently I have en error with double lines in /etc/fstab and trying to figure out how is that file created, and why two things (disks…?) are mounted under /home.
One more upgrade and we are speaking about the same version finally and I can shoot my issues hopefully, hopefully I get there.


When you have now 42.2 and want to go to 15.2 then a fresh install is the best.

You can upgrade from one version to another, but that is only supported one step at a time. And such an upgrade should be done on fully up-to date versions In this case that would involve four (4!) steps. And how to get each of them fully updated where most of them are out of support? And it would be best to run each of them for some time to iron out some differences that might show up. I do not think that is a clever path to go.

And yes, a fresh install will start from a clean system part. Most people save there (user) data, e.g. by having a separate partition for /home that will then of course be left as it is.

And when you talk about having two lines for mounting /home in your /etc/fstab, that is certainly wrong. You have to find out which one is correct and remove the other.


Thanks a lot or the explanation with the upgrades! I do see your point now.
I have been reading up about the fstab. Especially that on top of the double /home mount in fstab, I also have one more issue with a RAID0 that does not want to assemble (whatever that means). Apparently due to some error between Linux kernel changes where an array size have been unintentionally changed and one has to set a number now (default_layout) to make sure the correct value is used. Way over my head!
Do I want to do an open heart operation while reading up about it on the Internet? No thanks :wink:
Silly joke to diffuse the nerves. Obviously this is pretty easy and I can roll anything back, haha!
At least for now. Back to square 1.

I do have a separate /home partition.
I am still not sure what about the tools but that is a smaller issue since there are not many of them. (/bin is overwritten but anything installed in /home is not?)
So when I do a fresh install I need to create the partitions and decide their sizes, or keep default. And create users again, right?

If I do

df -h

I see sizes of the / and /home

/dev/sda2 27G /
/dev/sda3 71G /home
Here is also a whole bunch of folders like /var, /tmp on /dev/sda2 - not sure who re-created that (do I need to do something or the system creates that?)

I can see where are my other two disks that I need to be able to access
and some folders mounted over network from another machine, that dont care about that much.

  1. Does that mean that if I do not create /home again?
    and then the old one simply stays where it was…? How do I make sure that the new files in root paritition / are not written where the /home partition is now?

  2. What about the users?
    I setup root user again, separate it from my user that I need to create again…?

Sorry for asking about the same things over and over but I am still not sure about this.
And I get this open-heart-operation feeling that I do not want to mess this up and then think what to do.

thanks so much for Linux-babysitting me =)


Easiest option that I see is to fresh-install LEAP 15.2 replacing the Leap 42.2 “/” partition and use the same /home partition during installation. The important step is that you create a new user with a different name.

This way, you can have an up to date system with the ability to move things over from old home.

Better stay to exactly reporting what you do, see and have. Always take into account that we can not look over your shoulder and that our configurations will be different from yours. We depend complete on your information.

Please do not post half of the information, always copy/paste the whole command line, output and the next command line between the CODE tags. To express this blunt: we do not believe your stories, we believe the computer. All that is outside the CODE tags is your conclusions (maybe even fantasies) and not facts to us.

And for giving us an impression about your disks and their partitioning, better post

fdsik -l

and of course your broken fstab

cat /etc/fstab

During installation, you the result must be that you create a new / file system on the partition that is now used for it (sda2) and that you do not touch your /home file system on sda3, that will simply be mounted again. Same for other file systems on the same or another disk.

Also the installer is able to see that there is a Linux system already there and it is possible to let it copy (part or all of) the users configuration to the new system. I did that many times.

Why do you not download 15.2, put it on a DVD or an USB memory and start the installation. Then you can ask questions on what you see and we do not have to talk so vague.

A general remark, I might be wrong, but I have the idea that you have not much understanding about disks, partitioning anf file system. When that impression is wrong, please accept my appologies. You could start with,_filesystems,_mount_pointsand then ask questions.


thanks for the suggestions, so if I follow the openSUSE 15.2 installation guide from

3.7 Partitioning
3.7.1 Important Information

Custom Partitioning and Snapper
Being able to create system snapshots that enable rollbacks requires important system directories to be mounted on a single partition, for example /usr and /var. Only directories that are excluded from snapshots may reside on separate partitions, for example /usr/local, /var/log, and /tmp.

Q1. Who creates these partitions and makes sure they are properly placed for snapper to work - me or the installer?
I have now learned how useful snapper is, I certainly want to have it working.

Proposal with a Separate Home Partition
The default proposal no longer suggests to create a separate partition for /home. (…)
In case you want to change the proposal to create a separate partition for /home, choose Guided Setup and click Next until you reach the Filesystem Options screen. Check Propose Separate Home Partition. By default it will be formatted with XFS, but you can choose to use a different file system. Close the dialog by clicking Next again.

Q2. So I have an old /home partition that I want tohave access to. So I skip making a separate /home partition now as is the default - correct?

3.9 Create New User

If you install openSUSE Leap on a machine with one or more existing Linux installations, YaST allows you to import user data such as user names and passwords. Select Import User Data from a Previous Installation and then Choose Users for import.

Q3. So do I import the previous users (root and my user). Or do I need to create a new users and copy files over?
Sounds to me like I can keep the old home, import my old user and I setup the root user again in the next step: 3.10 Authentication for the System Administrator “root”.
Do I get this right?


A general remark, I might be wrong, but I have the idea that you have not much understanding about disks, partitioning anf file system. When that impression is wrong, please accept my appologies. You could start with,_filesystems,_mount_pointsand then ask questions.

Yes, I dont fully get it - perfect diagnosis =) Thanks a ton for the link. And being so gentle, I am not at all offended by the remark, it is not possible to be an expert in every field! All pointers are welcome.

I do have that installation disk ready to use.
I thought I am going to have to make all these choices by myself and therefore hesitated a lot. It is absolutely amazing that you guys are so helpful!
I read up quickly and then just start it.

and just to be clear. I did a rollback to openSUSE version 42.2 (that I started from) and all the problems are gone therefore (with fstab etc).



You can just boot from installation media and do a “dry-install”, just go through everything except initiating the installation to get a better idea.

Q1. I cannot tell you because I never use snapper and I typicaly use ext4 partitions but you want to be aware of the following:
When you get to the “partition” page, use the “expert partitioning” and “start with existing partitions” and allocate a space for / (in BTRFS and ~100GB if you want snapper), and mount but do not format the existing /home partition at /home.

Q2.Answered above, and you are going to be mounting and using the existing /home partition. Be absolutely sure that the installer will not format it!

Q3. Your “root” user will be gone with the / partition. It is located in /root within your LEAP 42.2 / partition. Your “regular” user is located in /home and you can preserver it. Jumping from LEAP 42.2 to 15.2, “importing” your older user will cause a lot of issues. Instead create a new user and copy-and-paste data and configuration files after you’ve installed LEAP 15.2

Be sure to go through Henk’s (hcvv’s) post in case if you’ve missed it.

I understand fully what you are asking, etc. But as long as you do not post that

fdisk -l

I am not going to do any next step. Without information, I am walking in the dark and not give any more precise information, only general remarks (like @SJLPHI also provides).

SURE! here it is.
No idea why it seems not follow the actual disk sizes …

> sudo fdisk -l

Disk /dev/sda: 223.6 GiB, 240057409536 bytes, 468862128 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x000d6c8c

Device     Boot     Start       End   Sectors  Size Id Type
/dev/sda1            2048 264253439 264251392  126G 82 Linux swap / Solaris
/dev/sda2  *    264253440 320319487  56066048 26.8G 83 Linux
/dev/sda3       320319488 468860927 148541440 70.9G 83 Linux

Disk /dev/sdb: 3.7 TiB, 4000787030016 bytes, 7814037168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 467D5237-7570-4E6D-8880-B4FC74EE32E4

Device          Start        End    Sectors  Size Type
/dev/sdb1          34     262177     262144  128M Microsoft reserved
/dev/sdb2      264192 3908694015 3908429824  1.8T Linux RAID
/dev/sdb3  3908694016 7814035455 3905341440  1.8T Linux RAID

Partition 1 does not start on physical sector boundary.

Disk /dev/sdc: 3.7 TiB, 4000787030016 bytes, 7814037168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 36DCF6CE-F64D-4D93-98BD-E8D7DE56D6FC

Device          Start        End    Sectors  Size Type
/dev/sdc1        2048 3908421631 3908419584  1.8T Linux RAID                                                                                                                                              
/dev/sdc2  3908421632 7814035455 3905613824  1.8T Linux RAID                                                                                                                                             
GPT PMBR size mismatch (1 != 3519069871) will be corrected by w(rite).                                                                                                                                    
Disk /dev/sdd: 3.7 TiB, 4000787030016 bytes, 7814037168 sectors                                                                                                                                           
Units: sectors of 1 * 512 = 512 bytes                                                                                                                                                                     
Sector size (logical/physical): 512 bytes / 4096 bytes                                                                                                                                                    
I/O size (minimum/optimal): 4096 bytes / 4096 bytes                                                                                                                                                       
Disklabel type: gpt                                                                                                                                                                                       
Disk identifier: 306588A1-2CA4-4D52-A14C-2C8A22715216                                                                                                                                                     

Device     Start        End    Sectors  Size Type
/dev/sdd1   2048 7814035455 7814033408  3.7T Microsoft basic data

Disk /dev/md1: 3.7 TiB, 3999209029632 bytes, 7810955136 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 32768 bytes / 65536 bytes

Disk /dev/md0: 3.7 TiB, 4002226831360 bytes, 7816849280 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 32768 bytes / 65536 bytes

and another beginner question.

To reboot from the install DVD for 15.2 I inserted it into the drive and hit something that looks like the options on where to boot from, sorry forgot already what was that called.
I end up in

Please select boot device:

with names that unfortunately dont tell me anything.

UEFI: Built-in EFI Shell
P5: DRW-24D5MT
IBA GE Slot 0400 v1572
PO: SAMSUNG MZ… sorry cant copy paste this

this does not look like what I expected. I thought there would be some simple ‘DVD/USB’ boot option, so does that mean I ended up in a wrong menu…?

126GB SWAP?! How much RAM do you have?

~> free -g
             total       used       free     shared    buffers     cached
Mem:           125          1        124          0          0          0
-/+ buffers/cache:          0        124
Swap:          126          0        126

or do you mean

~> cat /proc/meminfo
MemTotal:       131918552 kB
MemFree:        130312476 kB
MemAvailable:   130148168 kB
Buffers:            3164 kB
Cached:           664192 kB
SwapCached:            0 kB
Active:           752584 kB
Inactive:         433776 kB
Active(anon):     520764 kB
Inactive(anon):    16064 kB
Active(file):     231820 kB
Inactive(file):   417712 kB
Unevictable:          80 kB
Mlocked:              80 kB
SwapTotal:      132125692 kB
SwapFree:       132125692 kB
Dirty:                 0 kB
Writeback:             0 kB
AnonPages:        519128 kB
Mapped:           269728 kB
Shmem:             17828 kB
Slab:             117824 kB
SReclaimable:      55464 kB
SUnreclaim:        62360 kB
KernelStack:       10416 kB
PageTables:        24752 kB
NFS_Unstable:          0 kB
Bounce:                0 kB
WritebackTmp:          0 kB
CommitLimit:    198084968 kB
Committed_AS:    2392812 kB
VmallocTotal:   34359738367 kB
VmallocUsed:           0 kB
VmallocChunk:          0 kB
HardwareCorrupted:     0 kB
AnonHugePages:    135168 kB
HugePages_Total:       0
HugePages_Free:        0
HugePages_Rsvd:        0
HugePages_Surp:        0
Hugepagesize:       2048 kB
DirectMap4k:      206204 kB
DirectMap2M:     5971968 kB
DirectMap1G:    130023424 kB

Okay, so you have ~126GB RAM and as a result 126GB SWAP. Depending on what this machine is used for, this can be a good thing or a huge waste, and you root partition is quite small and that may cause problems in the future because I am myself having issues already with a 55GB / partition.