Boot problem, Error stack smashing detected

Hello Everyone,

I am running Leap 15.0 which I just upgraded from Leap 42.3 .
By following instructions here:https://snapcraft.io/install/github-desktop/opensuse , I installed
snap and github-desktop. While trying to launch github-desktop, I got error libpcre.so.3 not found.
The specific library version was not available in system shared libraries, but I found it within a subfolder
of snap installation folder.

I looked online to find out way to add this folder so that libpcre.so.3 can be found when github-desktop
launches. So following instruction on one website, I created a file snap.conf with folder path of libpcre.so.3
in /etc/ld.so.conf.d/ . After that I ran sudo ldconfig. I think I made big mistake here.

My troubles started after that. Any command running in konsole gives error “stack smashing detected”. I tried
to restart my PC. Now it gets stuck with same error at boot time.

I understand I did stupid thing and should have done my research before trying things out.
Anyway can anyone please suggest any solutions or point to direction towards fixing this problem.

Thanks for the help.

One of many Internet hits for removing ldconfig paths…

https://stackoverflow.com/questions/23026126/how-to-remove-an-entry-from-ld-so-cache

If it doesn’t work (removing your problem entries from the cache file),
Post again.

TSU

Comment about github-desktop…
It appears to be proprietory although free to use (subject to usual licenses of embedded FOSS).
The page you referenced seems to be very recent (a month old) but is possibly incomplete.
The instructions to install stop just there, and don’t include steps to configure the default Desktop using systemd, so without actually installing I don’t know if it complies with how Desktops are deployed on systemd systems.

The missing PCRE file looks to me a very common file,
I assume you should be able to find the file from an openSUSE repo if it’s not found in the Desktop install (which additionally worries me that it may not be fully compliant with standards).

I wrote a short guide for generally finding missing and needed files

https://en.opensuse.org/User:Tsu2/Missing_Files_Dependencies

HTH,
TSU

Thanks @tsu2 for the reply.

Your comments were useful. I removed the snap.conf file from /etc/ld.so.conf/ and renamed
ld.so.cache to ld.so.cache.old (by booting to live disk). After that I restarted my pc and it got back to normal.

As your comment about libpcre, OpenSuse does have it as libpcre but the github-desktop (latest available version)
specifically required libpcre.so.3 (somewhat similar to here https://forum.snapcraft.io/t/gnome-contacts-error-under-solus/2354).
Anyway I used older version github-desktop from snap, then it worked fine.

Thanks a lot for help :slight_smile: