Boot problem after latest kernel update today.

For some reason I get tossed into a screen with ‘Rescue >’ Prompt.
I tried to get boot repaired(see below), and got nowhere.

And of course, this is ME and I don’t know what to do with it.
I had to unplug Leap HDD’s to get to Windows.

Do the instructions here work? I tried something similar from another web site, and got nowhere

I am putting Leap on my windows drive, hoping I can salvage some things from the other installs.

Leap 15.3 on the PCI 160GB PATA drive

Leap 15.3 on a SATA 160GB drive (with some bad sectors)
Any way to fix those bad sectors assuming I can get it to boot again?

The latest kernel, in a fresh install, starts the boot script showing, then gets to a point where it is a black screen, and the monitor goes into standby mode(orange instead of blue), The on/off button is blue when active and orange when off(or standby?).
Any thing I can do to stop that black screen? And let the boot complete? If I put it in ‘Recovery’ option, the same thing happens.

This fresh install is on the Windows drive, and I can get to Win 7 & Win 10, BUT Leap blanks out on it!

Is there an iso I can download that has the previous(or older) kernel?

The PATA on the PCI CARD started ONCE up with the previous kernel then nothing!

I suspect the ‘boot loader’ or Grub or ??? has been corrupted.
When I get the RESCUE> prompt and do an ‘ls’ the the ‘ls (hd0,msdos?) nothing shows up as having a boot partition(something has to because Windows works!).

I need suggestions for finding places to look to ‘fix’ it.
I know I am going to lose a LOT of things I’d like to keep.

If you have radeon graphics, see the thread at and the bug report at

I will have to check the graphic card on that machine(HP Compaq dc7700 CMT).

The update to the HP AIO seemed to work OK. At least when I restarted it after the update it came back without that ugly black screen. I don5 use it much because the onboard graphics hic-cups once in a while, and I’m not in the mood to replace the chipset(s).