boot problem after 11.1 to 11.2 upgrade

Hi, performed an upgrade from 11.1 to 11.2 using a DVD based iso after checking Md5 etc.

System boots eventually but hangs showing a message “rtc0: alarms up to one day, 114 bytes nvram” for a long time. Once past that things appear fine.

/var/log/boot.msg shows next message as “device-mapper: uevent: version 1.0.3” with no obvious warning or error message.

The “hang” interval is a couple of minutes. Any suggestions for diagnosing much appreciated.

Hi there,

Humm. . . that is an interesting one. It’s hard to say without more info though, can you please post your entire dmesg so we can see what init is running right before and after that point? Might help zero in a bit more.

Are you using the default, desktop or Xen kernel? Tried it with apci turned off as a boot argument?

Lews Therin

rtc0 is the /dev entry for the realtime clock. See ‘man rtc’ for more info.

And some googling and LewisWithTheLongName’s post gives us a hint: AFAICS your problem is solved by replacing the installed kernel-desktop by kernel-default.

Good luck

Thanks to you both. I have the full /var/log/boot.msg from yesterday saved on the relevant m/c. Will that provide relevant info? Happy to provide.

An early line in it says Linux version 2.6…0.1-default so I think that’s already done.

I did try substituting acpi=force (new) for acpi=off (old) late yesterday and today it seemed to boot fine.

Yesterday’s boot.msg reported apcid & splash as skipped services in run level 5; today only splash.

I’ve also noticed that the machine now fully shuts down on software power off instead of needing a final long press of the power button.

Hi there,

So it sounds like passing the acpi=off boot argument corrected the issue then is that right? It’s starting up without undue delays now? If trouble persists go ahead an post in the full dmesg, or pastebin it, etc.