Boot openSUSE from FAT32 USB flash memory

Hi everybody,
I search for a right way to booting openSUSE from the FAT32 USB flash memory.
I did the steps of THIS LINK to use Grub4DOS but still my openSUSE could not boot correctly.
How can I boot THIS LIVE OPENSUSE by FAT32 Flash USB memory?

There’s a command (really, a script) called “live-fat-stick”. It’s in the 42.3 repos. It is probably in the Tumbleweed repos. Or you can find it with a google search.

That script will do what is needed for booting a live iso from a FAT32 flash drive.

I always use SUSE Studio ImageWriter

Well, Is that compatible with FAT32 flash USB memstick and write ISO on it?

You can use ImageWriter to write an iso to a memory stick. But it will no longer be FAT32 if you do that. You could, of course, reformat it back to FAT32 once you are finished with its use for booting the live system.

It writes the iso direct to the stick not to the FAT partition. Any partition is lost but the stick is then bootable to the installer

https://forums.opensuse.org/showthread.php/453515-SUSE-Studio-ImageWriter-for-Microsoft-Windows
http://www.mediafire.com/file/9haeauu9sq8xtkx/ImageWriter.exe

At the Conclusion, I’m going to test my ISO by “live-fat-stick”.
Welcome to any other helpful suggestions.

I tried with “live-fat-stick” on my Flash Memory (8GB-Fat32) but I get these Errors! How can I resolve that?

root@slinux:~/live-fat-stick# ./live-fat-stick /home/user/Images/openSUSE/Live/openSUSE-Tumbleweed-GNOME-Live-x86_64-Snapshot20170928-Media.iso /dev/sdcPlease make sure the following information is correct:
iso name: openSUSE-Tumbleweed-GNOME-Live-x86_64-Snapshot20170928-Media.iso distro: suse stick device: /dev/sdc
stick uuid: /dev/disk/by-uuid/2017-04-01-11-29-57-00 stick partition:
continue ? [y/n]? y
copying openSUSE-Tumbleweed-GNOME-Live-x86_64-Snapshot20170928-Media.iso to usb stick
dd_rescue: (info): Using softbs=4096.0kiB, hardbs=4.0kiB
dd_rescue: (fatal): open “/tmp/tmp.0BPHICNtkg/openSUSE-Tumbleweed-GNOME-Live-x86_64-Snapshot20170928-Media.iso” failed: Read-only file system
stat: cannot stat ‘/tmp/tmp.0BPHICNtkg/openSUSE-Tumbleweed-GNOME-Live-x86_64-Snapshot20170928-Media.iso’: No such file or directory
Source and destination image does not match
root@slinux:~/live-fat-stick#

I am still not sure that you understand what is what in mass-storage > partition > file system land.
The advices above are correct in themselves, but IMHO when you have misunderstandings about what you are doing (or try to, or want to), then confusion may be great.

The term “FAT32 USB flash memory” is a confusing mix about identifying hardware, partitioning and file system.

The USB flash memory is about hardware: a specific type of mass-dtorage, connected through a specific type of bus to the system.

The FAT32 part is defines a file system.

What you most probably have is a mass-storage device with a partition table (that is on the first block of the device) that defines only one partition. That partition is then occupied by a file system of type FAT32.

What you seem to want is a mass-storage device where you can boot openSUSE from. For this it is very unimportant what is now on the device (a partition table, and a partition with a FAT32 file system), because they will all be replaced by the ISO file that you must copy to it. Thus afterwards, there is no partition table, and thus no partition and thus no FAT32 file system anymore. And if these things existed some time in the earlier history of the device is completely uninteresting. There could have been a partition table with two partitions and one partition could have an NTFS file system and the other an ext2 one. I have no idea what you would have called such an USB stick, but from the viewpoint of putting a bootable ISO on it, it is again uninteresting and of no influence on your question.

Maybe this might be of interest: SDB:Basics of partitions, filesystems, mount points - openSUSE Wiki

Exquse me, Your Description was really Truism, I search for a way to make my Flash USB Drive to booting Live openSUSE and its filesystem is FAT32.
No Need to play with WORDS. Thanks in Advance.

Then just dd ISO image onto your USB stick. This will remove previous content on stick and make it bootable as openSUSE Live. If this is not what you want to do, then explain what you want to do so that others can also understand it.

Your USB stick was likely used for some install/live distribution image; it contains ISO9660 filesystem (or at least label that identifies it as such) so it is mounted as iso9660 which of course is read-only.

Thanks, But What was needed to be said was said!

How can I resolve that?

To the best of my knowledge there is no GNU/Linux that is compatible with a USB stick where the file system kept is formatted to FAT32.

Instead when GNU/Linux is installed, it needs to run on a GNU/Linux specific file system.

This means your USB memory stick, that is currently formatted to FAT32, will need to be reformatted to a GNU/Linux file system.

Maybe I can be educated and corrected here if I am wrong, but best I know is that trying to keep a FAT32 file system and run GNU/Linux on it can not work. Can not. It is destined to failure.

I sense if you continue down your current course of action, you could encounter increasing frustration. I do believe that the ImageWriter approach, that was recommended to you, is IMHO the easiest and most simple approach - if all you want is a openSUSE boot USB stick. It will replace all content on that USB stick, and place a GNU/Linux file system on it with openSUSE.

You use device that has filesystem that is writable (probably, FAT). If this device already has correct filesystem, it is possible that mount is confused by stale signature (it happens when you create filesystem over existing filesystem); you can examine and selectively delete signatures using wipefs command.

At the Final My problem was Solved! :wink:
http://reboot.pro/topic/21594-boot-in-fat32/