Boot only whit cdrom

I installed the Leap 42-3 on an Asus RT5390 notebook
After that, the setup was modified and the HD boot disappeared and was only booted by CDROM

How do I put the boot on HD?

Do you have any data on this computer? (to know if you can reinstall without problem)

else if the computer is recent, chance is it uses UEFI and you should find a boot manager there


UEFI ? What is it? Where do I find this?
I’m trying to install again. This time I chose GRUB2

Put the CD/DVD back in the drive, choose ‘Boot from harddisk’. If that works, use YaST to reconfigure your bootloader.

UEFI is the name of the new BIOS since some years. You use it if you see a /boot/efi folder. When you use this firmware, it’s the firmware/bios/uefi, whatever name you use, that choose the system to be started (Linux, Windows…). Then you have to use grub2-efi.

But it may happen that even with UEFI firmware you use “CSM” compatibility mode and then only Grub2 (non efi).

Very recently I had great problems to boot openSUSE from a HP laptop for this reason, UEFI firmwares are not that well done and very buggy


How i reconfigure the bootloader?

as said: use yast :slight_smile:


I logged into YaST2 -> System -> startup, is it?

Yast -> System -> Boot Loader

yes. Change anything and save.

check what grub version is used


I tried to do a new install, this time using the whole hd.
Now bios does not find grub and does not start
I’ve tried installing 3 more times and it always gives the same problem
It seems that I lost this notebook

do not stop too fast :slight_smile:

First I do not understand yet if you install using grub or grub-efi. When you boot the cd, boot on “rescue”. log a root (no passwd).

fdisk -l will show you what partition are on the disk and if it’s GPT or MSDOS

say so here, and stop reinstalling :slight_smile:

UEFI install and MSDOS install do not boot at all the same


There are several options. Which one should I use?

First you need to answer jdd’s question (#12) as to whether you are using grub or grub-efi. It’s difficult to advise when we are unsure of exactly what you are doing.

First you need to answer jdd’s question (#12) as to whether you are using grub or grub-efi. It’s difficult to advise when we are unsure of exactly what you are doing.

Where do I find this information?

Yast-system - boot loader

There is enabled the option “GRUB2”

LANG=en fdisk -l
Disk /dev/sda: 298.1 GiB, 320072933376 bytes, 625142448 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 3B8CE02E-D9C8-4C0E-9577-CE6D9CAB2655

Device         Start       End   Sectors  Size Type
/dev/sda1       2048  46139391  46137344   22G Microsoft basic data
/dev/sda2   46139392 255850495 209711104  100G Microsoft basic data
/dev/sda3  255850496 272623615  16773120    8G Microsoft basic data
/dev/sda4  272623616 274726911   2103296    1G Microsoft basic data
/dev/sda5  274726912 275048447    321536  157M EFI System
/dev/sda6  275048448 358940671  83892224   40G Microsoft basic data
/dev/sda7  358940672 625141759 266201088  127G Microsoft basic data

Then you are booting Linux using MBR not EFI

TO change in Yast Partitioning set the /dev/sda5 EFI System to mount as /boot/efi in Yast -system boot loader change to grub2-efi save change and reboot

I did the “/boot/rfi” assembly and it was ok
In the Yast -> System -> Boot Loader
I change to “grub2 for efi” But when I try to save the configuration
It comes with this error message below

That’s is my fstab

UUID=1492-850F /boot/efi vfat umask=0002,utf8=true 0 0