Boot issues after installing Nvidia drivers on Aeon

Hello! I was hoping someone could help me get the proprietary Nvidia drivers working on my Aeon installation, or at least give me some debugging tips.

I’ve got a GeForce GTX 1080 and Intel integrated graphics (Intel UHD Graphics 630 I believe). I guess this is referred to as hybrid graphics.

I followed the instructions found at SDB:NVIDIA drivers - openSUSE Wiki including some of the troubleshooting tips:

  • Set multiversion = provides:multiversion(kernel) in /etc/zypp/zypp.conf (although I skipped this step on my most recent attempts because I read somewhere that for Aeon you shouldn’t do this).
  • Disabled Wayland in /etc/gdm/custom.conf
  • Blacklisted the Nouveau drivers in /etc/modprobe.d (although I’m pretty sure the driver installation does this anyway)
  • zypper addrepo --refresh https://download.nvidia.com/opensuse/tumbleweed NVIDIA
  • sudo transactional-update -i pkg in nvidia-driver-G06-kmp-default nvidia-video-G06 nvidia-gl-G06 nvidia-compute-G06
  • sudo reboot
  • Enrolled the keys in the MOK database, which results in a reboot

The boot then hangs, so I used advice from SDB:Debugging boot hang - openSUSE Wiki to be able to view debug info, and it hangs on the i915 init, which is related to the Intel graphics.

So in Grub I edited the boot config to blacklist the i915 module (using module_blacklist=i915). That gets me past the hanging part, but then the Gnome GUI never actually loads. I’m able to log in via the command line though. I ran lsmod | grep nvidia and didn’t see anything about nvidia, so I guess the drivers didn’t actually load.

I’m hoping someone can help me figure out where to go from here in terms of debugging. I’d also like to know if blacklisting i915 is a valid “fix” for the initial hanging issue, or if Intel graphics are required even if you’ve got a separate graphics card (i.e. do they work in tandem?).

Thanks,
Mike

1 Like

Showing full log after reboot may give some hints. Run as root

journalctl -b --no-pager --full

and upload full output to https://susepaste.org/

1 Like

I just had an nvidia update to 535 and this driver kills functionality.

I have a Ryzen 4600h HDMI port with a nvidia 1660 ti connected to USB-C .

worked fine with tumbleweed and 4 screen

https://youtu.be/a3DKCin56wA

But now, I do have an either or Situation.
Only Nvidia with Wayland and the help of an MST DP adapter or only internal screen.

Leap never works well with multi GPU, try Tumbleweed.
For Aeon I don’t even want to try.

Thanks for that tip. Here’s the output after booting with i915 on the module_blacklist list (because otherwise I can’t get to a command line): https://paste.opensuse.org/pastes/e9d12b7a8434

I see that it says “Failed to initialize the NVIDIA kernel module” but I’m not seeing much else that I can go off of.

It comes from X server but there is no trace of kernel NVIDIA driver. Do you even have it? What says as root

uname -r
modinfo nvidia

there is no trace of kernel NVIDIA driver. Do you even have it?

I think I do not.

uname -r gives 6.3.7-1-default

sudo modinfo nvidia gives modinfo: ERROR: Module nvidia not found

Here is the output from installing Nvidia, minus thousands and thousands of lines of duplicated build warnings: https://paste.opensuse.org/pastes/798f63935474

This stands out:

dracut-install: Failed to find module 'nvidia_drm'
dracut[E]: FAILED:  /usr/lib/dracut/dracut-install -D /var/tmp/dracut.3bSpfs/initramfs -N ^i2o_scsi$|^bbswitch$ --kerneldir /lib/modules/6.3.7-1-default/ -m nvidia nvidia_drm nvidia-modeset nvidia-uvm

According to this output nvidia module was built for kernel 6.3.9 and you do not have kernel-default-devel for version 6.3.7 so nvidia module cannot be built for this version. Show output of

zypper -si kernel

Have you tried booting kernel 6.3.9?

Thanks to this hint I managed to get it working. I did this:

sudo transactional-update dup --interactive
sudo transactional-update --continue pkg remove nvidia-driver-G06-kmp-default

(for some reason dup was bringing in an nvidia package and I wanted a clean nvidia-free upgrade, hence that package removal line)

Then I rebooted and was successfully on kernel 6.3.9. Then I ran the nvidia driver installation again:

sudo transactional-update -i pkg in nvidia-driver-G06-kmp-default nvidia-video-G06 nvidia-gl-G06 nvidia-compute-G06

That caused a boot hang as usual, but I got past it by blacklisting i915. Once I was logged in at the command prompt, I ran sudo modprobe nvidia which launched the GUI. Then I ran sudo prime-select boot nvidia, rebooted, and logged in successfully with graphics and without needing to edit boot params.

I don’t know how to prove that the 3d graphics card will actually get used, but at least modinfo nvidia shows that the drivers are installed and lspci -nnk shows:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP104 [GeForce GTX 1080] [10de:1b80] (rev a1)
	Subsystem: Dell Device [1028:3366]
	Kernel driver in use: nvidia
	Kernel modules: nouveau, nvidia_drm, nvidia

Thanks for your help!

1 Like

Hmmm… I’ve been having practically the same issues with Nvidia 535 drivers on Tumbleweed, and I uninstalled the drivers and tried using the intel igpu I have, and it worked, but only on one monitor. I reinstalled the nvidia drivers to see if it was some configuration mishap and back to the same issues. I wonder if I disable the i915 drivers if the system will work again. I’ll try it in the morning.