Boot into Console - No GUI

Hi there,

I have a problem… I turned on my laptop at work this morning and it booted up into console mode! Rebooting and booting into Failsafe Mode do nothing…

It reports that it has reached Runlevel 5, but I can’t get into the GUI. I have tried to run “startx” which works (Sort of) but I have no mouse or keyboard control. Same goes for if I run “sax2 -r -m 0=radeon” and I have to hard power off the machine to get out of there.

If I try to load the vesa driver, it fails and the SaX.log tells me:
(II) VESA(0): Totl Memory: 256 64KB banks (16384kB)
(EE) VESA(0): No matching modes
(II) UnloadModule: “vesa”
(II) UnloadModule: “init10”
(II) Unloading /usr/lib64/xorg/modules//
(II) UnloadModule: “vbe”
(II) Unloading /usr/lib64/xorg/modules//
(EE) Screen(s) found, but none have a usable configuration.

Fatal servererror: no screens found

I have renamed the xorg.conf file and rebooted, but come to the same place…

Nothing reports to have failed on bootup, so I have no clue where to start trouble shooting. It does tell me though that there were “Skipped features: boot.cycle”. Is this the problem area?

Thanks for the help. :slight_smile:



Any idea why it stopped working? Were you installing updates when you
turned it off?

Have you tried installing updates from the CLI, using Zypper, to see if that helps?

Barry Nichols


Well I do remember doing an update earlier this week, but I have no idea if I have rebooted since then, or what it was. I do know that it wasn’t a Kernel update, as I keep an eye open for those.

I did install a new Samsung printer thought with the software and drivers from the samsung website…


Hi Barry,

Your recommendation of doing an update worked like a charm… Thanks!

I basically downloaded almost all of KDE 4.3.5 as an update, and after that everything worked… I have no idea what was the originating fault, but I am stoked to be up and running again.

Thanks again,

Dredger. :wink:


You’re welcome, I’m glad it helped.

Barry Nichols