Boot into black screen with input cursor flashing at left top of the screen


I am using Thunderobot laptop with TumbleWeed installed. I have worked on the system for several years without problem. Today it becomes to status as saying in the title of my post. In the black screen, ctrl + alt + f2 could work. Then I enter rescue mode by my installation udisk, run fsck -y on my system partition, no error found. Then reboot and still black screen with flashing input cursor.

Wait any suggestions.

Thanks in advance

Do Ctrl-Alt-F2 and login, then do

cat /var/log/Xorg.0.log | susepaste
inxi -SGayz | susepaste

and report the resulting URLs here.


sudo systemctl restart xdm

cause anything useful to happen?

The systemctl command bring me back to black screen with flashing cursor

inxi -SGayz | susepaste produced error from a broken old inxi version. Please run sudo inxi -U, then provide URL resulting from inxi -SGayz | susepaste. From the looks of the uploaded log, I suspect you upgraded to the 5.16.11 kernel before there was an NVidia driver package to support it, or it didn’t get installed.

when running inxi -U, getting error 33: error downloading file with tiny:
Error: main branch

I don’t know what would cause that error. :frowning: What does inxi -I report? Try following the instruction here.

inxi -l output nothing and the instruction does not help which time out for connection when I do manual setup for inxi

a moment ago, I turn off the silent splash and quite mode on boot, so I can view scrolling screen during boot process. The screen stops scrolling at following text:

ppdev: user-space parallel port driver

These errors suggest you’re boot process doesn’t proceed far enough along to have working network. Have you tried the advanced options menu option in Grub to boot the prior kernel, or to boot in failsafe mode?

It is unnecessary to continue researching on. I just back up home folder and reinstall the newest OS. All things are well back.