Boot from hard disk install fails, but live CD boots OK.

I used the live cd (dvd) to do an install of openSUSE:Education-Li-f-e (openSUSE 11.4). Upon reboot to the HD the splash screen appears, but then this message:

Doing fast boot
Creating device nodes with udev
1.467026] fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing ge
Trying manual resume from /dev/sda1
resume device /dev/sda1 not found (ignoring)
Trying manual resume from /dev/sda1
resume device /dev/sda1 not found (ignoring)
Waiting for device /dev/sda2 to appear: … Could not find /dev/sda2.
Want me to fall back to /dev/sda2? (Y/n)

At this point Y response gets the following

Waiting for device /dev/sda2 to appear: … not found – exiting to /bin/sh
sh: cannot set terminal process group (-1): Inappropriate ioctl for device
sh: no job control in this shell

I am new at this, so any pointers appreciated. This is on a Dell PowerEdge 1800 which before was running OpenSUSE 11.2 in a server configuration.

This is a second attempt to install from the live cd, this time reformatting to use the entire disk space.


Perhaps the startup train fell of the tracks after it hit a Radeon video card/chipset? You might try typing in the kernel load option **nomodeset **before you press the enter key or try the FailSafe startup option to see what that does for you.

Thank you,

I get similar messages, except it doesn’t mention “radeon” (I have intel graphics). It boots ok. I doubt that part is the problem.

That is more likely to indicate the problem.

Can you say a bit more about your setup and what you are doing?

It sounds as if you are booting with some overlay code that logically switches the disks around, and then when the boot gets to the point of directly accessing the disks, they have different names from what was expected. (I’m doing lots of guessing there).

Nomodeset option gets rid of the " 1.467026] fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing ge" line, but after that nothing else changes - still can find the sda1 or sda2 devices.

Seems you are right about the video, nomodeset fixed that but the rest of the messages are unchanged, and still can’t boot from the hd.

The hd is a raid array. If I boot from the live cd(dvd) all appears normal and I can browse the hard disks. When I try to boot from the hd the problems occur.

The first attempt to install from the live cd upon reboot from the hd the same messages occurred except it was sda2, sda5, and sda7 referenced. I tried another install but specified the whole hd be used, so it erased the partitions that existed (at least it said it would) and now the message reference sda1 and sda2.

Any other suggestions? (As I mentioned, I am new at Linux/SUSE use)


When I boot, I see a message something like:

Waiting for device /dev/disk/by-id/ata-WDC_WD3200AAKS-75SBA0_WD-WCAPZ2050503-part8 to appear.

I am wondering why you have device names, instead of device IDs.  The use of IDs is supposed to avoid the problem of device names changing.

As I recall, there's an install choice on how to identify partitions.  The default is by-id.  Other options include by-uuid and by-label.

You might try to reinstall, and make sure that you use something other than device names in that section of the install.

This is important information that should have been your first post “The hd is a raid array.”

I don’t have an answer but maybe you should expand the “The hd is a raid array.” statement and say what kind of RAID. There are 3 basic technologies, hardware, software, and FAKE (BIOS assist) . Which is this one?

The hd install from the live cd/dvd indicates that it is a SCSI Disk, 136.48 GB, /dev/sda, MegaRAID-LD 0 RAID5 139G

During boot up BIOS indicates Dell PERC4/SC, and there is one logical drive.

There are 3 physical SCSI drives connected to the controller.

Any thoughts?

I’ve gone through the install again, I am using the latest live dvd of of openSUSE:Education-Li-f-e (openSUSE 11.4) to do the install and I don’t see that option or choice unless its LVM? Maybe I’ll try that and see what happens.

I seem to recall that there’s an “option” button while doing the partition setup, and you see the choice after clicking on that option button.

Well, LVM didn’t work, on reboot it didn’t recognize the disks, had to clear and reinitialize them.

On the install from the live dvd the suggested disk partitioning page does have 3 buttons, one each for Create, Import, and Edit partitioning, I looked but couldn’t find where to change volume labelling … should it be there somewhere? under another name … ?

I guess it isn’t obvious.

I just started a test install, to look for it.

After the installer suggest a partitioning, I can click “edit” (or clicking “create partitions” works too, if I follow with “expert”)
The next screen shows a list of partitions. In the left column, there is a list called “system view” with file system types. At the very bottom, there is “setup”. Clicking on setup gives me a screen where I can set how disks are to be mounted and how they are to be shown during the install. The default for me is to mount by device-id, and to show by device name during the install.

I’m looking at this on the 12.1 rc1 live KDE install CD, since that’s what I happened to have sitting on my desk. It is probably similar for the 11.4 install program, but I can’t be certain. Give it a try and see if you can find it there. Otherwise, I’ll dig up an 11.4 install disk and search again.

Another poster (gogalthorp) asked what type of RAID you have. I suggest you answer that. I haven’t used RAID, but the other poster seemed to think it relevant.

I finally found it after poking around for some time on the partitioning menus, and labelled the 3 suggest partitions as swap, system, and home, but on attempted boot it still fails with the same messages except they now refer to dev/disk/by-label/swap etc… So no luck there. I also saw a post about another Dell Poweredge but a different model number, having similar problems that eventually were resolved by enabling mbr, I also did that and still no go with that enabled during the next install.

I did give the particulars about the disk system as a response few posts back, maybe I missed something?

I have downloaded a RAID disk driver controller update from Dell, so I’ll try that next …

The BIOS update didn’t help either. I am out of ideas …

Well, I had one more idea, I downloaded OpenSUSE 11.4 dvd and it installed and booted with the defaults. To get to the openSUSE:Education-Li-f-e install which is based on 11.4 with additional software for schools I am wondering is there a way to “upgrade” this install? I can’t find a repository with the education version, but is there a way to use the education live dvd to do upgrade on the base 11.4 install without replacing the whole (working) OS?

I want this as a server for 20 thin client workstations in a school setting, and the education version has everything in it to make this “easy” (although nothing appears easy after this experience).

In Yast installing the education pattern should do it. Go to Yast - software Management select patterns - education install it.

I don’t see education under patterns, could you be a little more specific (I am new at linux/suse)?


You may need to add the Education repo. It’s amongst the Community repos.

Could you install it without problems?
I ask because I have the same problem here with an OpenSUSE 11.4 install from liveCD.
The machine is similar (Dell PoweEdge 2850).
Devices sda1 and sda2 are not recognized in a RAID 1 configuration
Enabling MBR didn’t solve the problem either.