Boot failure: Will not start X/KDE

Just replaced my CPU cooler.
Have had my PC offline for two weeks.
Now it will not start up again.

It is booting from Grub, but somewhere it just stops

This comes up:
OK Started Show Plymouth Boot Screen.
OK Started Forward Password Requests to Plymouth Directory Watch.
OK Reached target Paths.

Then nothing…

Any suggestion to what I could do? I do not have a different troubleshooting Grub boot option.

Worst Case I will have to reinstall OpenSUSE, but I will try to find a solution first.

Possibly lost of contacts.
Try to disassemble, clean contacts, reassemble again.
I hope cooler is working now with thermal paste, plugged fan, etc.

Yes the cooler is working. I have checked in BIOS.

I do not want to disassemble my computer. I will rather try to reinstall OpenSUSE.

The grub boot hang did not help me much. I tried to “Edit entry”. Then I got some grub configuration, but there was no option for quiet.
> In grub, edit your kernel command line, remove both quiet and splash=whatever options and replace them with debug and initcall_debug.

The grub shows
> kernel /boot/vmlinuz-2.6.150 root=/dev/rootdisk quiet other_option splash=silent

No it does not.
I have two options: Command Line, Edit Entry.
Edit entry gives me something like this.

setparams 'openSUSE Leap 15.1'
    set gfxpayload=keep
    insmod gzio
    insmod part_gpt
    insmod ext2

Somehow now I managed to get a maintenance console as root.
I have no Internet, or I would have tried to run an update.
Tried to start network, but then it restarted the maintenance console with login

When the cooler was malfunctioning, the system shut down.
Could this be the cause, a corrupted system?

After some troubleshooting, and debugging, I could not find the problem, nor a solution.
I created an OpenSUSE Leap 15.2 USB drive, and are in the process or performing an upgrade.
Hopefully it will get my box up and running again.

No success. It even got worse after the upgrade to Leap 15.2

After Grub all it displays is

  3.597228]  ata3: COMRESET failed (errno=-32)
13.597484]  ata3: COMRESET failed (errno=-32)
23.297785]  ata3: COMRESET failed (errno=-32)
60.452283]  ata3: COMRESET failed (errno=-32)
3.5972282]  ata3: reset failed, giving up

I think I have to make a fresh reinstall instead.

Grub still had option for the older kernel that was with Leap 15.1
I choose that kernel, and the boot process did show up. It did not so with the new kernel.

With the old kernel all I get after boot is after several OK lines.
Give root password for maintenance
(or press Control-D to continue):

Providing the root password gives me a prompt.
Pressing Control-D
sulogin: cannot read /dev/tty1: Operation not permitted

It annoys me that I have to make a fresh install.
It takes me back to when I was using Windows and the only option to fix things was a reinstall

Anyone have a suggestion what I can do before I go and perform a reinstall ?

I perfectly understand that. On a different occasion I spent hours on trying to avoid the fresh install. Later I had to admit to myself the immediate fresh install would have saved me (exactly these) many hours. It wasn’t that bad after deciding to move to a new ssd having everything still available and /home on it’s own partition.

I’d try to run a life system - you should be able to create one as you could create the media for the update, right? If it works it would

a) confirm it wasn’t your processor getting damaged but “only” your OS and
b) give you the chance to save any settings in /etc or /home.

Edit: Well, and then go for the fresh install. :rolleyes:

AFAIK this is a hardware problem, I doubt if any numbers or re-installs will fix it.

Possibly your ata3 device (I suppose it is on sata 3 port) is failing, either the drive itself, the sata cable or the power cable.

I’d also reseat the memory, I’ve seen memory failures after a long time off.

Just my 2c.

I think I will try that. I have just made a Live USB stick using my work laptop. I will use that to backup my /home before the fresh install.

I was afraid of that. The last thing I want is to disassemble my computer.
I have one NVME M.2 drive which runs my Linux. One additional SSD SATA for Steam.
If a fresh install doesn’t work I see no other option than to disassemble my computer, and then reassemble.

I removed my secondary SSD drive, but the problem still persist.

It now only boots up in “emergency mode”.

I then removed the secondary drive from my /etc/fstab, and my computer booted up in KDE. Yay!

How come a single drive should cause so much trouble booting up. If the drive did not work, it should have just ignored it and logged in, then continued booting up.

That’s what “nofail” option is for.

It seems like the SATA cable was loosly connected.
After I plugged it firmly back in, I could boot, and the drive was again visible.

I noticed something in YAST, while trying to add mount point back to the secondary drive.
I get a warning up:

The system might not be able to boot

  • A partition of type BIOS Boot Partition is needed to install the bootloader
  • Such a setup is not supported and may cause problems with the bootloader now or in the future.

What is actually wrong with that warning? I am able to boot, and I do in fact have a boot partition.

If you

  • are using GRUB2 and
  • do NOT boot in UEFI-mode (but CSM-mode aka BIOS-mode) and
  • are using a GPT partition schema on your disks

then you might need a BIOS-boot-partition.

See here (chapter 4.4 GPT) for more details.