BNC4352 Broadcom WiFi not working

Hi folks,
i just switched from Ubuntu to OpenSuse as I wanted to try a rolling distro for a change.

My wireless card seems to be misbehaving, as it doesn’t show in connection manager:
http://i.imgur.com/SukxTrf.png

The card worked out of the box in Ubuntu.

here are some of the infos i could gather based on the various threads i’ve already read while trying to fix this.


uname -a
Linux linux-igmb 4.10.5-457.gf3fbfc6-HSF #1 SMP PREEMPT Wed Mar 22 13:15:00 UTC 2017 (f3fbfc6) x86_64 x86_64 x86_64 GNU/Linux

sudo zypper in broadcom-wl-kmp-HSF
Loading repository data...
Reading installed packages...
'broadcom-wl-kmp-HSF' is already installed.
No update candidate for 'broadcom-wl-kmp-HSF-6.30.223.271_k4.7.6_274.gfb37fcc-42.19.x86_64'. The highest available version is already installed.


YaST2->Hardware Information:

26: PCI 100.0: 0280 Network controller
  [Created at pci.378]
  Unique ID: VCu0._1GVq2iUfC7
  Parent ID: z8Q3.gVXacIJHMBB
  SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: network
  Model: "Broadcom BCM4352 802.11ac Wireless Network Adapter"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x43b1 "BCM4352 802.11ac Wireless Network Adapter"
  SubVendor: pci 0x1a3b "AzureWave"
  SubDevice: pci 0x2123 
  Revision: 0x03
  Driver: "bcma-pci-bridge"
  Driver Modules: "bcma"
  Memory Range: 0xf0600000-0xf0607fff (rw,non-prefetchable)
  Memory Range: 0xf0400000-0xf05fffff (rw,non-prefetchable)
  IRQ: 16 (no events)
  Module Alias: "pci:v000014E4d000043B1sv00001A3Bsd00002123bc02sc80i00"
  Driver Info #0:
    Driver Status: bcma is active
    Driver Activation Cmd: "modprobe bcma"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #22 (PCI bridge)

sudo lshw -C network :


  *-network                 
       description: Network controller
       product: BCM4352 802.11ac Wireless Network Adapter
       vendor: Broadcom Limited
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=bcma-pci-bridge latency=0
       resources: irq:16 memory:f0600000-f0607fff memory:f0400000-f05fffff

@linux-igmb:~> 
dmesg | grep firmware
    3.052648] psmouse serio1: elantech: assuming hardware version 4 (with firmware version 0x361f00)
    6.957860] bluetooth hci0: Direct firmware load for brcm/BCM20702A1-13d3-3404.hcd failed with error -2


In Yast->Network Settings, Network Manager is selected.

Welcome to openSUSE Forums. I’m not convinced that you’ve installed the required broadcom packages.

rpm -qa|grep broadcom

The hardware info should list the wl drivers as being available

Driver Info #0:
    Driver Status: bcma is active
    Driver Activation Cmd: "modprobe bcma"

and installing the broadcom packages should also cause the bcma (et al) drivers to be blacklisted in a /etc/modprobe.d/ file.

thanks.

# rpm -qa|grep broadcom
broadcom-wl-6.30.223.271-42.19.x86_64
broadcom-wl-kmp-default-6.30.223.271_k4.7.6_274.gfb37fcc-42.19.x86_64
broadcom-wl-kmp-HSF-6.30.223.271_k4.7.6_274.gfb37fcc-42.19.x86_64

should I remove some?
And if yes, how?
Update:
i tried

# sudo zypper rm broadcom-wl-kmp-default 
Reading installed packages...
Resolving package dependencies...

The following 2 applications are going to be REMOVED:
  Desktop "System Tray"

The following package is going to be REMOVED:
  broadcom-wl-kmp-default

1 package to remove.
After the operation, 7.2 MiB will be freed.
Continue? [y/n/? shows all options] (y): y
(1/1) Removing broadcom-wl-kmp-default-6.30.223.271_k4.7.6_274.gfb37fcc-42.19.x86_64 ...............................................................................................................[done]

which executed successfully. the problem is still present

off topic:
these lines appear on every zypper command i do. what do they mean, how do i make them disappear?


The following 2 applications are going to be REMOVED:
  Desktop "System Tray"
broadcom-wl-6.30.223.271-42.19.x86_64
broadcom-wl-kmp-default-6.30.223.271_k4.7.6_274.gfb37fcc-42.19.x86_64
broadcom-wl-kmp-HSF-6.30.223.271_k4.7.6_274.gfb37fcc-42.19.x86_64
Linux linux-igmb 4.10.5-457.gf3fbfc6-HSF

The Broadcom is for Kernel 4.7, you are running Kernel 4.10…
And why HSF Kernel?

The broadcom kernel package needs to match the running kernel. Where did you get those packages? You should probably share your configured repos

zypper lr -d

The Repo you get broadcom-wl is not maintained anymore?
https://build.opensuse.org/package/show/home:X0F:HSF:Kernel/broadcom-wl

A Side Effect:
For Bluetooth you need the Firmware:

6.957860] bluetooth hci0: Direct firmware load for brcm/BCM20702A1-13d3-3404.hcd failed with error -2

Download this and copy the File to /lib/firmware/brcm:
https://github.com/winterheart/broadcom-bt-firmware/raw/master/brcm/BCM20702A1-13d3-3404.hcd

# | Alias                               | Name                       | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                          | Service
--+-------------------------------------+----------------------------+---------+-----------+---------+----------+--------+------------------------------------------------------------------------------+--------
1 | download.opensuse.org-non-oss       | Main Repository (NON-OSS)  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/non-oss/                        |        
2 | download.opensuse.org-oss           | Main Repository (OSS)      | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/oss/                            |        
3 | download.opensuse.org-tumbleweed    | Main Update Repository     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                              |        
4 | http-download.opensuse.org-34ac9c90 | openSUSE:Leap:42.2:Ports   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/repositories/openSUSE:/Leap:/42.2:/Ports/ports/ |        
5 | http-download.opensuse.org-a1196b25 | home:X0F:HSF:Kernel        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/X0F:/HSF:/Kernel/standard/   |        
6 | openSUSE-20170320-0                 | openSUSE-20170320-0        | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/oss/                            |        
7 | repo-debug                          | openSUSE-Tumbleweed-Debug  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                      |        
8 | repo-source                         | openSUSE-Tumbleweed-Source | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/                     | 

No idea why HSF, actually I have no idea what HSF is.

I prolly ended up with all these repos, firmwares and kernel version after some attempts of self-doctoring based on googled results:)

Also all these repos I am using are an effect of these attempts. not something i actually want or need.

All I really wanted is a clean tumbleweed install with kde and working wifi :slight_smile:

thanks i did that and that dmesg entry is gone.

You should remove repos 4 and 5.

ok, just did that. does this help me further with the wi-fi problem, or was this just something that didn’t belong in my system?

It just removes potential incompatible repos.

The packman repo has the required packages…
https://en.opensuse.org/Additional_package_repositories#Packman

You can add it wih

zypper ar -f -n packman http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/ packman

Then install the broadcom packages with

zypper in broadcom-wl

That should drag in the broadcom-wl-kmp-default package as well. Then reboot.

whoa, this really starts to be a drag. i have uninstalled everything with zypper rm broadcom*

then reinstalled broadcom after removing wrong repositories. no change at all.

i have looked and also realised none of my printers are recognized. suse is definitely less noob-oriented than i expected.
i think i’ll quit for now. will do a fresh install.

thanks to all for your kind help.

Re-installing won’t solve a thing. Sometimes there are additional steps required to get things working. Time and effort are required. It can be a steep learning curve for new users, but it’s worth the effort.

TW is a rolling release and therefor near the cutting edge. It really is not for beginners. Try Leap there are far less problems with incompatible drivers

When riding the cutting edge be prepared to bleed :open_mouth:

Did you get as far as getting the drivers installed from the Packman repo? After a reboot, the wl driver should be loaded. You can confirm this with

/usr/sbin/hwinfo --wlan

*Post the output here if you need help interpreting.

And please the output of:

uname -a
zypper se -si broadcom kernel

I guess i just went into frustration mode, seeing how things working right out of the box in Ubuntu need so much fussing about in opensuse.
So it wasn’t the sight of blood that made me cringe. Blood I can handle. This does not look like a bleeding edge issue, it rather looks to me like a free-software related issue and I expect to stumble upon it in Leap also, but I am ready to stand corrected as suse is still alien to me.

Alright I’m back giving it another go.
Thanks guys for your patience.

There is no output at all for command :
/usr/sbin/hwinfo --wlan
Output for **uname -a **is:

4.10.5-457.gf3fbfc6-HSF #1 SMP PREEMPT Wed Mar 22 13:15:00 UTC 2017 (f3fbfc6) x86_64 x86_64 x86_64 GNU/Linux

Output for zypper se -si broadcom kernel is:


S | Name                    | Type    | Version                     | Arch   | Repository           
--+-------------------------+---------+-----------------------------+--------+----------------------
i | broadcom-wl             | package | 6.30.223.271-2.19           | x86_64 | (System Packages)        
i | broadcom-wl-kmp-default | package | 6.30.223.271_k4.10.4_1-2.19 | x86_64 | (System Packages)           
i | kernel-HSF              | package | 4.10.5-457.1.gf3fbfc6       | x86_64 | (System Packages)                
i | kernel-default          | package | 4.10.4-1.1                  | x86_64 | (System Packages)                   
i | kernel-default          | package | 4.4.27-2.1                  | x86_64 | (System Packages)                       
i | kernel-firmware         | package | 20170303-1.1                | noarch | Main Repository (OSS)                       
i | kernel-firmware         | package | 20170303-1.1                | noarch | openSUSE-20170320-0

Output for **uname -a **is:

4.10.5-457.gf3fbfc6-HSF #1 SMP PREEMPT Wed Mar 22 13:15:00 UTC 2017 (f3fbfc6) x86_64 x86_64 x86_64 GNU/Linux

The running (HSF) kernel and broadcom-wl-kmp-default packages don’t match, Any reason for using that kernel? If not, I’d delete it and just use 4.10.4-1.1.

In short, the required packages should look like this…


i | broadcom-wl             | package | 6.30.223.271-2.19           | x86_64 | (System Packages)        
i | broadcom-wl-kmp-default | package | 6.30.223.271_k4.10.4_1-2.19 | x86_64 | (System Packages)           
i | kernel-default          | package | 4.10.4-1.1                  | x86_64 | (System Packages)                   
i | kernel-firmware         | package | 20170303-1.1                | noarch | Main Repository (OSS)                       

Ok, i’d love to, but how do i delete the active kernel and switch to the other one?