BMC4310: drivers, firmware installed, dont' work

I’m trying to set up wlan with a Broadcom BCM4310 on an Acer Extensa 5220 with OpenSuse 10.2.

Following the instructions in “My wireless doesn’t work” in this forum I did and checked:

As far as I can see the driver and the firmware are in place

find -iname 43xx


lspci finds the card


04:00.0 Network controller: Broadcom Corporation BCM4310 USB Controller (rev 01)

lspci -n

04:00.0 Class 0280: 14e4:4315 (rev 01)

Than I looked for kernel-messages

dmesg |less

no information about the card was to be found

So I tried

modprobe -v bcm43xx

insmod /lib/modules/
insmod /lib/modules/
insmod /lib/modules/
insmod /lib/modules/

dmesg | grep 43xx

bcm43xx driver

But still I get:


lo no wireless extensions.
irda0 no wireless extensions.
eth0 no wireless extensions.
sit0 no wireless extensions.

What next?

Thank you for any help

gimli-of-gloin wrote:
> What next?
> Thank you for any help

Unfortunately, the BCM4310 is not yet supported by b43. The reverse
engineering is in progress, but it will be some time before the code
is ready. In the meantime, you will have to run ndiswrapper using the
Windows driver. If your system is x86_64, this may be a problem. My
computer came from the factory with that card. When I tried the 64-bit
Windows driver, the computer crashed repeatedly. My fix was to go to
my shelf, get a BCM4311/2 that I had there and put it in to use b43.
Of course the BIOS complained due to HP’s white listing. That was
handled with a relatively risky procedure that I will not describe
here. If you use a 32-bit kernel, it should be as OK as ndiswrapper
ever gets.


Thank you!