Bluetooth speakers stopped working after latest Tumbleweed DUP


Long time OpenSUSE user, but new to the forums.

So, last week I nervously did a looong time overdue zypper dup on my Thinkpad Laptop’s Tumbleweed. To my big relief everything seemed to work as usual after rebot without any issues at all!

But the other night when I tried connecting my bluetooth speakers (actually bluetooth headset), something seems amiss, even though it has just worked™ before DUP. The headset connects fine using the bluetooth applet (XFCE), but then the headset no longer appear as an output or input option in pulseaudio settings.

I searched for the error and found lots of suggestions, reset pulseaudio, load module-bluetooth-discover as user, etc… etc… And not sure what suggestions are still up to date info and/or relevant for OpenSUSE?

So, did anyone have similar issues with Tumbleweed after recent updates, and if so, any idea what to do about it?

You can try the following at your risk,

sudo zypper install pipewire-alsa pipewire-pulseaudio pipewire-aptx pipewire-tools

Reboot the machine after installing these packages and once the system starts again, try your bluetooth speakers. Fingers crossed :crossed_fingers:

Thanks, will give it a try later on, is pipewire some sort of experimental audio package?

Default for most nowadays.

1 Like