Bluetooth problems

I recently bought a BT dongle, a USB2 Asus. I then went through Yast2 to find any Bluetooth software and installed them, mainly Bluez and KBluetooth.

Unfortunately the apps do not see any adapter, but when I use hwinfo, I get the following;

hwinfo --bluetooth
06: USB 00.0: 11500 Bluetooth Device
[Created at usb.122]
Unique ID: UfPf.mft2TtF4GnE
Parent ID: 2XnU.CCckIHJirFC
SysFS ID: /devices/pci0000:00/0000:00:1d.3/usb5/5-1/5-1:1.0
SysFS BusID: 5-1:1.0
Hardware Class: bluetooth
Model: “ASUSTek Bluetooth 2.0 USB Device”
Hotplug: USB
Vendor: usb 0x0b05 “ASUSTek Computer, Inc.”
Device: usb 0x1715 “Bluetooth 2.0 USB Device”
Revision: “1.00”
Driver: “btusb”
Driver Modules: “btusb”
Speed: 12 Mbps
Module Alias: “usb:v0B05p1715d0100dcE0dsc01dp01icE0isc01ip01”
Driver Info #0:
Driver Status: btusb is active
Driver Activation Cmd: “modprobe btusb”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #5 (Hub)

hci0: Type: BR/EDR Bus: USB
BD Address: 00:00:00:00:00:00 ACL MTU: 0:0 SCO MTU: 0:0
RX bytes:0 acl:0 sco:0 events:0 errors:0
TX bytes:0 acl:0 sco:0 commands:0 errors:0

lsusb -t
5-1:1.2: No such file or directory
5-1:1.3: No such file or directory
/: Bus 05.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
|__ Port 1: Dev 2, If 0, Class=‘bInterfaceClass 0xe0 not yet handled’, Driver=btusb, 12M
|__ Port 1: Dev 2, If 1, Class=‘bInterfaceClass 0xe0 not yet handled’, Driver=btusb, 12M
|__ Port 1: Dev 2, If 2, Class=vend., Driver=, 12M
|__ Port 1: Dev 2, If 3, Class=app., Driver=, 12M
/: Bus 04.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/: Bus 03.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci_hcd/8p, 480M

To me it looks as though the adapter is seen by the kernel, but the software to use it is not seeing the adapter. Looking at the System services I see bluez-coldplug enabled and running.

I did a test on a Fedora v14 live DVD and it worked with no problems, no additional software was needed.

Any help?

openSuse 11.3, KDE 4.5.4, Kernel

as su -

modprobe btusb

No luck.

KBluetooth has all the entries greyed out and Bluetooth Monolithic does not see any adapters still.

Is there a list of Bluetooth libraries anywhere that details what I should have installed?

Unfortunately my laptop with bluetooth is on loan so I can’t go and check for you

There is a hardware list here:
HCL:Bluetooth - openSUSE

And yours looks to be the second in the list.

Me too, i’ve a problem with bluetooth (running Suse 11.3, Smeegol , on a Samsung N150). I don’t know which is exactly the frontend used by Smeegol (Connman ?). In any case, i see the bluetooth devicesaround (a Nokia phone, an Apple PB running MintPPC). I can send files but i cannot search and get files. When i click on <Send Files> it works, but when i click on <Search> or <Connect> (to the configured devices) nothing happens.

Is there, eventually, an alternative bluetooth manager i could install. Blueman, for what i understood does not work with Suse 11.3 ?


bluedevil works great for me in 4.6b2 never tried it in earlier kde releases but there was some buzz about it then too. So I’d imagine it works fine there.

It does not exist in my repositories. Anyway, i saw that there is an rpm package of blueman (but for another distro). Could i install that nevertheless or would it ruin my system?


Why ‘blueman’ - where did you come up with that?

Because at least in my experience with Ubuntu (on a Vaio) and Debian/MintPPC on a G4 PB it works just fine and provides all needed services (even without installing obex).

At least me, i’m not going anywhere with the bluetooth frontend coming with Smeegol. In the repositories i don’t see anything else, what could help me out . . . (?)


PS. I don’t think Smeegol is somewhat related to KDE (rather to Gnome, but not sure on this (?) ).

To install blueman click here

Thanks a lot! I did and now, things become a little bit more explicite. When i’m trying to open the phone device (looking for files on it) i’m getting this error msg:

Could not display “obex://[00:25:48:3A:A9:58]/”.
Error: DBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
Please select another viewer and try again.

Any idea what that means? (I suspect the built-in bluetooth frontend gets the same error but doesn’t verbose it).

Again…could be a bug with Smeegol. I only use a bluetooth mouse and it
works fine… Need to look at hooking up my phone.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 5 days 1:17, 2 users, load average: 0.08, 0.08, 0.06
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.29

Am i a kind of truffle pig? :wink:

No, no don’t worry, i like that interface a lot (esthetically) and i prefer it over unity. So, no problem, i’m happy if i could contribute in some way to make it better . . . :slight_smile:

I’ll wait. . .

PS. The bluetooth feature, frankly, at least for me in an all-day-use, is an important one. I’m taking a lot of photoshots with a phone so there is some pratical need to be able to download from that device to a computer.

Install bluez-hcidump and open a terminal and run the command (as root user) hcidump and see if you can pick up errors here. I suggest starting a new thread as it’s a Smeegol issue probably.

I tried (in the terminal as root) but the result is this

HCI sniffer - Bluetooth packet analyzer ver 1.42
device: hci0 snap_len: 1028 filter: 0xffffffff

and then it hangs (i’m not turning back to the prompt). It remains the same, when i try hcidump with some specific comands . . .

I don’t have an idea, what to do with that and how to start about that a new thread. But if you think it’s sufficient i will . . .

I don’t know why the KDE team have remained unmoved for such a long time by the bluetooth device browsing disparity between the openSUSE workbenches but I found myself having to troubleshoot this problem back in 2009 with openSUSE 11.2 (and the same disparity persists today) when I purchased my first bluetooth mobile phone. Regrettably it took a long journey via Fedora, Ubuntu and back to openSUSE Gnome desktop to identify this easy working solution. It is the main reason (but not the only one) why I changed from installing just KDE to installing KDE and Gnome together.

I do not see this dual workbench strategy as a problem for the following reasons:

  1. It is all openSUSE (I prefer openSUSE’s gui Yast method of configuration to the command line method of the other distributions I have tried such as Fedora and Ubuntu).
  2. Installing both workbenches only occupies about 4.4GiB.

As a result I find that browsing bluetooth devices in openSUSE 11.2 or 11.3 is absolutely no problem:

I merely point out that you have the option of adding the Gnome desktop to your current installation via Yast / Software / Software Management / Patterns and choosing to install “Gnome Desktop Environment” and “Gnome Base System” (I believe the Base System is selected automatically once you select the Desktop). This would give you access to the best (and worst) of both desktops but crucially, give you bluetooth software that would allow you to browse bluetooth devices. You are able to choose between desktops at the bottom of the login screen when the password box is visible via the “Session Type” menu. The default desktop is always the one used in the last session.


Sorry! This terminology relates to a different operating system. Workbench should replaced by desktop.

User Farinet is using Smeegol (based on openSUSE Gnome) Desktop which is the cutdown version on Gnome for the netbook, it’s still in beta so issues like this occur…

I apologize for not paying enough attention to the detail I clearly missed and therefore adding a red-herring to this thread. I wanted to add this last reply just to thank you for being so polite whilst explaining my error. I compliment your good manners.

Ah! So i was guessing right: It’s based on Gnome! Thanks for that info. Turning back to the previous point: hcidump - the result i got (or better: the non-result!) is sufficient from your point of view to start a particular thread?