Bluetooth not discovering Logitech mouse (mice)

New install of KDE Tumbleweed, hard stuff went well like blacklisted nouveau, nvidia download drivers working. Puzzled why bluez is not discovering my logitech mouse. It sees my TV and my radio speakers but neither of my mice. I have MX Anywhere 2S and a MX Master 3 by Logitech. So I ran this sudo lsusb | grep Bluetooth. It reported : Bus 003 Device 003: ID 8087:0026 Intel Corp. AX201 Bluetooth; as I expected. So then ran: dmesg | grep -i blue and the result was:

[    3.592908] Bluetooth: Core ver 2.22
[    3.592918] NET: Registered PF_BLUETOOTH protocol family
[    3.592919] Bluetooth: HCI device and connection manager initialized
[    3.592923] Bluetooth: HCI socket layer initialized
[    3.592925] Bluetooth: L2CAP socket layer initialized
[    3.592926] Bluetooth: SCO socket layer initialized
[    3.786538] Bluetooth: HCI UART driver ver 2.3
[    3.786541] Bluetooth: HCI UART protocol H4 registered
[    3.786542] Bluetooth: HCI UART protocol BCSP registered
[    3.786552] Bluetooth: HCI UART protocol LL registered
[    3.786553] Bluetooth: HCI UART protocol ATH3K registered
[    3.786560] Bluetooth: HCI UART protocol Three-wire (H5) registered
[    3.786606] Bluetooth: HCI UART protocol Intel registered
[    3.786638] Bluetooth: HCI UART protocol Broadcom registered
[    3.786643] Bluetooth: HCI UART protocol QCA registered
[    3.786644] Bluetooth: HCI UART protocol AG6XX registered
[    3.786648] Bluetooth: HCI UART protocol Marvell registered
[    3.790090] Bluetooth: hci0: Bootloader revision 0.4 build 0 week 30 2018
[    3.791120] Bluetooth: hci0: Device revision is 2
[    3.791122] Bluetooth: hci0: Secure boot is enabled
[    3.791123] Bluetooth: hci0: OTP lock is enabled
[    3.791124] Bluetooth: hci0: API lock is enabled
[    3.791125] Bluetooth: hci0: Debug lock is disabled
[    3.791126] Bluetooth: hci0: Minimum firmware build 1 week 10 2014
[    3.822556] Bluetooth: hci0: Found device firmware: intel/ibt-19-0-4.sfi
[    3.822569] Bluetooth: hci0: Boot Address: 0x24800
[    3.822570] Bluetooth: hci0: Firmware Version: 206-22.23
[    4.187815] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    4.187817] Bluetooth: BNEP filters: protocol multicast
[    4.187819] Bluetooth: BNEP socket layer initialized
[    5.704964] Bluetooth: hci0: Waiting for firmware download to complete
[    5.705065] Bluetooth: hci0: Firmware loaded in 1838385 usecs
[    5.705080] Bluetooth: hci0: Waiting for device to boot
[    5.720205] Bluetooth: hci0: Device booted in 14777 usecs
[    5.720236] Bluetooth: hci0: Malformed MSFT vendor event: 0x02
[    5.720392] Bluetooth: hci0: Found Intel DDC parameters: intel/ibt-19-0-4.ddc
[    5.722127] Bluetooth: hci0: Applying Intel DDC parameters completed
[    5.723986] Bluetooth: hci0: Firmware revision 0.4 build 206 week 22 2023
[    5.791206] Bluetooth: MGMT ver 1.22
[   25.040841] Bluetooth: RFCOMM TTY layer initialized
[   25.040848] Bluetooth: RFCOMM socket layer initialized
[   25.040851] Bluetooth: RFCOMM ver 1.11

I have uninstalled and reinstalled, the mouse is charged up fully, I added my user to lp group. I don’t have anything I understand, left
to try. I was just using it on Debian 12, EndeavourOS before that. Can you lend a helping hand? Confused why it sees other devices but not my mice.
I’ll check back tomorrow while at work, going to sleep tonight.
Thank you in advance for insights you may have.

This is of no help to you, but strange things happen with bluetooth. I had a similar problem sometime back. I don’t remember exactly how I fixed it, so I navigated to the settings with a logitech bluetooth mouse. When I got there, it said bluetooth was disabled. So, I used my bluetooth mouse to hover over the “enable” button but decided not to press it.

I had trouble disconnecting a set of bluetooth earbuds and ended up disabling bluetooth. Yet, the mouse continues to work. I suspect a reboot will shut that down. For now, my responses to the commands you used are essentially identical except for the HCI UART lines and all but one of the hc10 lines.

Sometimes the simplest things are the ones we miss. Is there a “connect” button on the mouse itself?

Oh yes, Logitech not only built in a connect button but it provided three so you could switch from one device to another with ease and switch back to first. The connect button flashes rapidly so you are cognizant it is attempting to connect. Implementing this connect flashing flushes any connection that button had previously from memory. That is when I request bluedevil to “add a device” and yet it never shows up while my TV and music speakers do. What is puzzling I never had this to happen on Debian 12 KDE or EndeavourOS KDE it just happens now on openSUSE. What makes it even more puzzling is all three use the same bluetooth packages. Bluez, Bluez-utils and Bluedevil. I’m sure KDE finds this easier to integrate in their settings.

I can not really follow you.

With an new install, the computer lost it Bluetooth associations so you have to reconnect your Bluetooth devices. Make the device discoverable and have your computer do a scan. When it finds the device, do connect and likely you have to get the pin to finish the connection. After that you can you the device.

To check things using the command line:

bluetoothctl devices Paired

I think this will return an empty list for you. When things are fine, it should list all devices known.

Sorry if I confused the problem. I do make the device discoverable. I do have computer do a scan. The problem is the computer never finds the mouse.
That said, it does find the bluetooth on my TV and it finds bluetooth on my music speakerd but I’m not trying to connect them. I want to find my mouse but it cannot. I get the same result using the command line.

Was the mouse working before and if so was that using the same computer/Bluetooth dongle.

A possible reason can be that your computer/Bluetooth dongle is not not supporting the latest bluetooth version, for example Bluetooth Low Energy while your mouse requires it.

1 Like

Thank you for the idea. That is not problem.

8-29 update:
I appreciate the time spent with replies and those who read as well. Does not seem to be a problem run into a lot on openSUSE. This is on my daily driver laptop, I have to get it whole again. Not going to discard $250 worth of mice. Forgive me, going back to EndeavourOS, quicker than Arch to install. In fact I just did that. Both mice are working well, as they should.
I look quickly for a way to cancel/close this post. Sorry I did not see it. I may have overlooked it. Would someone kindly close this out as I will not pursue a solution any longer. Thank you.
PS: EndeavourOS has a better install method for Nvidia proprietary drivers too.

No, we won’t do that. Announcing that you have no wish to pursue this is sufficient here. Use what works for you. :wink: